RADEON + BLENDER

General discussion about the development of the open source Blender

Moderators: jesterKing, stiv

Post Reply
jazzroy
Posts: 10
Joined: Thu Oct 17, 2002 9:39 am

RADEON + BLENDER

Post by jazzroy »

I have tried Blender on many computers (windows XP and 98) and I've always noticed a lot of slowdowns (especially in the menus) when using Radeon videocards.
By now Radeon series are used a lot also on Linux systems (mandrake 8+ claims native 3D acceleration with it) , so I think a better implementation would be useful!

Mats78
Posts: 100
Joined: Thu Oct 17, 2002 5:06 pm
Location: Vantaa, Finland

Post by Mats78 »

Is it an ATI related OpenGL support type of problem? Someone had alot of trouble using Radeon cards and OpenGL. And Blender is of course just that.. OpenGL =)

Best of luck

dreamerv3
Posts: 119
Joined: Wed Oct 16, 2002 10:30 am

Post by dreamerv3 »

When is ATI finally going to wake up and suport linux?

I find it hard to belive that they've fallen into the world of windows and refuse to acknowledge a user base that could only grow and grow.

Linux is only going to get stronger and stronger, and sooner or later they'll figure it makes good business sense to develop drivers for linux, then maybe I'd buy an ATI card. It would at least introduce competition and give Nvidia a reason to expand thier linux support or perhaps release an SDK.

You can also argue that the driver from Summit X are available for ATI card now, but they cost $99.00 and unless Blender was developed to the point of being better than 3DS Max (C'mon be realistic), I for one would find it hard to buy a commerical closed source driver.

Anyone else share this view?

dittohead
Posts: 122
Joined: Mon Oct 14, 2002 2:49 am

Post by dittohead »

ATi is total crap. no opengl support get a new card.
dittohead

IoN_PuLse
Posts: 212
Joined: Wed Oct 16, 2002 6:05 am
Location: Canada, BC
Contact:

Post by IoN_PuLse »

Try setting the "ATI settings" to default, and make sure anti-aliasing is off. Blender supports OpenGL properly, it's up to the graphics card manufacturer to make proper OpenGL drivers. Ati doesn't seem to, because Blender runs beautifully on every Geforce there is.

slikdigit
Posts: 133
Joined: Wed Oct 16, 2002 3:52 am
Location: Northampton, MA (US)

Post by slikdigit »

I'm using an ati (radeon 7500 mobility, 64meg) with linux and blender. It works with the dri project opensource drivers. I believe ati released some data to them to do it. there are still some bugs, but its workable even not using the latest dri drivers.
so I think things are looking up for linux using radeon owners.

ve4drk
Posts: 1
Joined: Tue Oct 22, 2002 4:25 am
Location: Winnipeg, Manitoba

RE: ati opengl drivers ...

Post by ve4drk »

OK ... I've seen the discussion on the ati radeon cards .. I've got a similar one .. an ati Rage128 ultra 32mb (AKA ati rage 128 pro II) . I have it running on this dell 4550 2.4ghz machine under this xp thing :x for a week or so ... my 11yr old son was doing a project for school and was using blender to try and do some solar system designs... i noticed that the menu options are EXTREMELY slow .. so slow that it is *very* hard to use .. I don't blame blender for this ... I installed the opengl drivers from ati (replacing these cruddy directx drivers) and they show all the options set properly, yet the speed of the menus is still unusable. I'm in the midst of installing debian on the machine, so will have a better chance to compare on the linux side once I get there. I would have thought that ati would have adequate opengl drivers on the windoz side of things though...
meanwhile ...
I have redhat 7.3 installed on a pII350MHz with blender 2.22 with an ATI expert98 8MB card and it works just great. Go figure eh? :D
any advice on the windoze side of things would be great .... at least until i get to the debian side. Thanks. Dan.

jazzroy
Posts: 10
Joined: Thu Oct 17, 2002 9:39 am

Post by jazzroy »

ve4drk, that's exactly my problem: menus are unusable on my Win XP AMD 1800 Radeon 7200 64MB : I run every OpenGL game smooth at 1280x1024 and I have to wait to see a menu appear in Blender (with empty scenes). What's the matter? Of course tried different settings but nothing happened.

Post Reply