Suggestion for Windows version of Blender.

General discussion about the development of the open source Blender

Moderators: jesterKing, stiv

Post Reply
amy_aimei
Posts: 0
Joined: Sat Feb 19, 2005 9:04 pm

Suggestion for Windows version of Blender.

Post by amy_aimei » Sat Feb 19, 2005 9:10 pm

I would like to know if it is possible to build a static linked
version Blender in Windows? In the past, there was a static version
for Linux. I want to have Blender works with software OpenGL,
provided by MS OpenGL libraries, rather than the hardware accelerated
version. It sounds crazy, but on my computer, the hardware
accelerated version is 4 to 5 times slower than the software OpenGL
version!

I've found that the slowest is the text editor screen. It is not
usable at all!

Too bad, it is a notebook computer, I can't simply tossed away that
ATI video component and replaced with NVidia.

I'm using other software requires the hardware acceleration. It is
annoying to change the display settings back and fore.

Second thought, if the software allows the user to choose OpenGL library. It will be great too.

I've
found that Blender links to the OpenGL DLL after it started. I can
switch back to accelerated mode after that moment. This is why I am
thinking of a way to do that automatically.

OpenGL drivers on windows machines are implemented as a DLL named
OpenGL32.dll. Every 32-bit windows OS comes with this DLL (except the
very original Win95 retail edition). This is the MS software OpenGL
renderer, which is a full implementation of OpenGL 1.1.

When the software/driver kits for the video card is installed, it also
installed another OpenGL driver which is for that card. In my case,
it is a ATI Card, the OpenGL driver is atioglxx.dll. It also updated
the registry to tell the system that an driver has been installed and
what the name of the dll is.

When Blender started, it loads OpenGL32.dll because it was linked to
opengl32.lib, and when it makes OpenGL function calls they are
directed at the OpenGL32.dll, which in turn forwards them on to the
video card driver.

In theory, if the code can bypass that "forward" function, and there
is a command-line option for Blender to pick up any driver to be
loaded. That will be great!

mchs3d
Posts: 0
Joined: Thu Feb 03, 2005 6:05 am
Location: Loveland, CO

Post by mchs3d » Sat Feb 19, 2005 10:28 pm

I am with you. This SAME exact thing happened to me, and I hope that you won't have to go through as much trouble as I did to get it to work. Follow these steps CAREFULLY!

1. What the problem is is that Blender needs quick acess to the atioglxx.dll file.
2. To get the *proper* atioglxx.dll file, follow this link (http://www2.ati.com/drivers/wxp-w2k-7-9 ... 11774c.exe).
3. Once downloaded, extract all the files into the default location ( DON'T GO THROUGH INSTALL, THOUGH)
4. Find atioglxx.dl_ in C:\ATI\SUPPORT\wxp-w2k-7-95-031028m-011774c\2KXP_INF\B_11914
and copy it to C:\.
5. Now find expand.exe in %SystemRoot%/SYSTEM32 and copy it to C:\
6. Open up a command prompt and type C:\expand atioglxx.dl_ atioglxx.dll
7. Copy the new C:\atioglxx.dll to the Blender main directory.

Marty_D
Posts: 0
Joined: Mon Jun 09, 2003 11:16 pm

Post by Marty_D » Sun Feb 20, 2005 1:40 pm

Static version sounds interesting. Does MS OpenGL use the hardware acceleration? Haven't heard that before.

I've never really had any touble before with slow video, maybe because I don't use Shaded mode too often. Latest CVS was being slow though so tried the atioglxx.dll trick and, what do you know, it seems to work.

A couple thoughts. You could try to just copy the current atioglxx.dll in the system directory to the blender folder and see how it goes. Also, at number 5 in the above instructions do you really need to copy expand.exe? If you have Expand it's in the path so you should be able to just type 'expand' at the commnd prompt shouldn't you?

Friday13
Posts: 54
Joined: Wed Oct 16, 2002 10:40 pm

Post by Friday13 » Sun Feb 20, 2005 8:20 pm

To disable hardware acceleration, go to desktop, then right click, Properties>>Settings>>Advanced Settings>>Troubleshooting and set the hardware acceleration slider to none.

Marty_D: as far as I know, MS OpenGL doesn't do hardware acceleration. The standard drivers provided with the Windows installation accelerate DirectX (naturally...), but not OpenGL. Only software acceleration is provided unless you install new drivers (or any other drivers other than the standard ones).

I'm using software "acceleration" (I can't really call it that :P), because my video card is using the standard drivers (new ones are buggy and make Blender behave strangely).
Don't miss the sequel: "I still see dead people"

amy_aimei
Posts: 0
Joined: Sat Feb 19, 2005 9:04 pm

Post by amy_aimei » Tue Feb 22, 2005 3:13 pm

I've tried that.

The MS Open GL driver is "software", no "hardware acceleration", as Friday13 mentioned.

Keep enable and then disable "hardware acceleration" is not I want to do. I've struggled with that for a long time.

BTW, I found that the menu display speed is a lot better than the previous version. Can someone tell me what had been done? I think if someone can apply the same fixes/enhancements to the text editor window and the 3D window, it will solve the problem with the ATI video driver.

Post Reply