Page 1 of 1

Sound in blender

Posted: Sat Oct 01, 2005 8:37 am
by yertari
Hi,

How does sound work in blender?

I have just made a sci fi based music pack that i am selling for the various game engines in mp3 and ogg format, and am wishing to know if sound works well in Blender? and is easy to use. Does blender use ogg?


http://www.arteria-gaming.com

Re: Sound in blender

Posted: Mon Oct 03, 2005 4:13 am
by simonharvey
yertari wrote:Hi,

How does sound work in blender?

I have just made a sci fi based music pack that i am selling for the various game engines in mp3 and ogg format, and am wishing to know if sound works well in Blender? and is easy to use. Does blender use ogg?


http://www.arteria-gaming.com
To the best of my knowledge blender only supports 16 bit wav audio streams.

Simon

Re: Sound in blender

Posted: Fri Oct 21, 2005 7:55 am
by juanjavier_xxx

To the best of my knowledge blender only supports 16 bit wav audio streams.

Simon
---How can you manage to make sound work in blender? I am using it under Debian GNU Linux (kernels 2.6.8 and 2.6.12) and I am completely unable to make sound work.

Whenever I try to play a sequence with imported wav at 16 bits, console says

Code: Select all

Unable to open audio: No available audio device
Audio works correctly on every application outside Blender, such as VLC, Mplayer, Audacity audio sequencer, and so on.......I tried with the onboard sound and with the PCI 128 Ensoniq chipset from Creative SoundBlaster. I tried turning onboard chip off in the BIOS as well...nothing works: audio gets imported but does not sound.

What is wrong?
Thanks.

Posted: Fri Oct 21, 2005 11:45 pm
by simonharvey
Blender's sound system in linux has always been a bit flakey, if you have compiled it from source you will have to enable in in the toplevel SConstruct file, other than that I dont know what to say to help you.

Kind Regards
Simon Harvey

To whom may interest about sound in blender:

Posted: Sat Oct 22, 2005 11:02 am
by juanjavier_xxx
simonharvey wrote:Blender's sound system in linux has always been a bit flakey,
Simon Harvey
Yeah, you can bet it for sure ;-P LOL

But anyway got issue solved:

Blender starts the sound system of the game engine by default. So actually it gets control over one sound device of the computer just at blender boot.

If you try to import audio on the sequencer and then play it, Blender will complain that the audio device is busy, and thus not available. No sound will come out. And that was my issue.

You have to tell Blender at startup that don't get any sound device occupied by starting it from the console and typing

Code: Select all

blender -g noaudio
if you want it full-screen or

Code: Select all

blender -w -g noaudio
if you want it window-resizeable.

That worked for me. Hope it heps.