Official 2.40 alpha1 testing build

General discussion about the development of the open source Blender

Moderators: jesterKing, stiv

Posts: 0
Joined: Sat Oct 15, 2005 2:04 am
Location: PEI Canada

Post by Bight_Jeremy » Sat Oct 15, 2005 2:10 am

When I bake out my actions in 2.4 they are only baking out the rotations and locations for the ik handles, not all the joints that are in the armature. Not sure if this is due to the Python API still to be put in?
- Jeremy

Posts: 0
Joined: Sat Jun 19, 2004 3:06 am

Post by madman » Sat Oct 15, 2005 6:23 am

On my mandriva 2005 LE and my RADEON 9250 (I installed ATi driver)

'/home/madman/apps/blender-2.40alpha1/blender' -w
With this option fo'r show blender in a window (under KDE 3.3), i cant see the 3d view... not responding... i can't see objects... NOTHING!

But if I run blender without -w option... i can see blender OK

In Blender 2.37a oficial, option -w work fine.
Srry bad englsh. :P [/b]

Posts: 0
Joined: Sun Mar 02, 2003 4:27 am
Location: Santo Domingo, Dominican Republic

Post by Apollux » Sat Oct 15, 2005 7:59 am

Just found a GUI bug regarding the new *and great* hair particle feature. ... 9&atid=125

Posts: 0
Joined: Sat Sep 04, 2004 2:32 pm

Post by kakapo » Sat Oct 15, 2005 8:21 am

the alpha is great! :)

anyone played around with the new curve/action/nla windows already? i have some problems with them. for example i can't get any curves of pose actions to be shown. it could be that it's my fault though because i just started learning animation with blender. :)

and [add driver] crashes blender sometimes.

Posts: 0
Joined: Sat Oct 15, 2005 2:32 pm

Post by aph » Sat Oct 15, 2005 2:37 pm

and where are sources of 2.40 alpha1?
i'm using amd64 architecture and i can't compile the new blender :(

Posts: 0
Joined: Wed Jul 23, 2003 4:31 pm

Post by kidb » Sat Oct 15, 2005 8:16 pm

aph wrote:and where are sources of 2.40 alpha1?
i'm using amd64 architecture and i can't compile the new blender :(
Maybe one of these works for you ... /20051014/

Posts: 0
Joined: Sat Oct 15, 2005 2:32 pm

Post by aph » Sat Oct 15, 2005 8:56 pm

i have already downloaded souces from cvs. and it looks like 2.40 alpha1 :)
but thank you :wink:

Posts: 0
Joined: Mon Sep 20, 2004 5:05 am

Post by brucegregory » Sun Oct 16, 2005 1:01 am

I noticed in the release notes for the new "IPO Driver" animation upgrade that even actions can be driven by the movement of another object, just like any IPO can be driven. How can an object be added as a driver for an action composed of armature movement?


Greg Smith

Posts: 0
Joined: Thu Jun 05, 2003 10:13 am

Post by modron » Sun Oct 16, 2005 5:50 pm

hi guys, i have a question. blender 2.4 won't start for me, and it asks for MSVCR71.dll, which i found a copy of on the net, but I'm not sure whether to put it in my blender directory or my win32 directory. anyone know?

Posts: 60
Joined: Wed Oct 16, 2002 8:51 pm

Post by OTO » Sun Oct 16, 2005 6:12 pm

As a Linux user I would say C:\windows\system :)

Posts: 0
Joined: Fri Oct 24, 2003 6:07 pm
Location: UK

Post by Bogey » Mon Oct 17, 2005 2:04 am

Following on from my last post, I have been using 2.40a for some concept stuff, just using the standard modeling tools, with no real problems. I did notice a draw problem where joining a standared mesh to a subsurfed mesh caused the standard mesh to dissapear until I reentered, then exited edit mode. Any way, ive downloaded the program again, and cant recreate this problem, but; now blender crashes as soon as I try to appened, with the same error I mentioned earlier. Now it crashes before I even get to the file select window.

Will keep testing.

Posts: 0
Joined: Tue Mar 01, 2005 3:39 am
Location: FRANCE

Fluid Simulator in 2.40 Alpha1

Post by ROUBAL » Mon Oct 17, 2005 1:02 pm


The 2.40 seems marvelous, though, I noticed a weird behaviour in the fluid simulator:

- When several objects are used as obstacle, some of them are detected as obstacle and some others are not.

In a test file using 3 planes as obstacles, the 1st and the 3rd are detected as obstacles, and the fluid passes through the second one.

- I have tried to pour some water in a glass, and the water is stopped by the upper side of the glass, whic his open.

The bound box seems to be used for the glass (set as obstacle) obstacle instead of the real shape...

Normals have been recalc outside with no better result.(Checked also with recalc inside).


Posts: 0
Joined: Sat Oct 15, 2005 2:04 am
Location: PEI Canada

Post by Bight_Jeremy » Mon Oct 17, 2005 4:12 pm

Been having alot of fun working with the Armatures in 2.4 Alpha1, but I'm encountering a problem while working on my rig using Copy Location Constraints. In past Blender versions, even in some CVS test builds (Up to october 3rd), when I added 2 Copy Location Constraints, it would blend between the constraints 50/50. Now when I add the 2 constraints, it completly copies the location of the second constraint. I can correct this by setting the second constraints influence to 0.5, but when I add more than 2 location constraints it starts becoming quite complicated. I tried to add this to the bug tracker but I'm have alot of trouble logging into the server.
- Jeremy

Posts: 11
Joined: Wed Oct 16, 2002 9:53 am

Post by lusque » Mon Oct 17, 2005 5:40 pm

Bight_Jeremy: this is not a bug, it's the new behaviour for multiple constraints of the same type.
For more than 2 copyLocation set the third influence to 0.333 (=1/3), for the forth 0.25 (=1/4), for the fifth 0.2 (=1/5) and so on. For further information try this topic:

Posts: 0
Joined: Mon Oct 21, 2002 6:34 pm

Will OS X 10.2 be supported?

Post by pamtango » Mon Oct 17, 2005 9:59 pm

Will OS X 10.2 be supported when the official release comes around?
Folks stuck wiht old iBooks want to know.

Post Reply