Segmentation fault.. please help!

General discussion about the development of the open source Blender

Moderators: jesterKing, stiv

Post Reply
weijie90
Posts: 0
Joined: Tue Oct 18, 2005 5:11 am
Location: Singapore

Segmentation fault.. please help!

Post by weijie90 » Tue Oct 18, 2005 5:17 am

hi!
i ran

Code: Select all

apt-get install blender
in ubuntu as root.
t tried to launch blender, but :

Code: Select all

root@wj:/home/di # blender
Using Python version 2.4
libGL warning: 3D driver claims to not support visual 0x24
libGL warning: 3D driver claims to not support visual 0x28
libGL warning: 3D driver claims to not support visual 0x2c
libGL warning: 3D driver claims to not support visual 0x30
/usr/bin/blender: line 46: 20511 Segmentation fault      blender-bin $@
please help! thanks!!

sten
Posts: 177
Joined: Sun Oct 13, 2002 7:47 pm

Post by sten » Tue Oct 18, 2005 6:19 am

telling maybe a bit more what your systemspecs are, would help, no?

and why as root? usually you work as 'user' ...and did you install opengl drivers for your gfxcard?

did you try to download the official build and run it instead?

weijie90
Posts: 0
Joined: Tue Oct 18, 2005 5:11 am
Location: Singapore

Post by weijie90 » Tue Oct 18, 2005 6:32 am

i got the same errors in the system build.
i'm running ubuntu 5.10, i686, ati rage 128 pro.
what openGL drivers? thanks!

sten
Posts: 177
Joined: Sun Oct 13, 2002 7:47 pm

Post by sten » Tue Oct 18, 2005 6:35 am

Blender can't be run without proper OpenGL drivers, try to find a solution for Ubuntu in their documentation or their sites/forum...for your ATI, I am sure there is such...if not...try to download the static build of the official build/binary of Blender and see if that works, but it will be slower.

weijie90
Posts: 0
Joined: Tue Oct 18, 2005 5:11 am
Location: Singapore

Post by weijie90 » Thu Oct 20, 2005 7:01 am

the static build worked. thanks!

Post Reply