Page 1 of 1

Blender 2.4x + Gentoo works bad on my box

Posted: Mon Jan 30, 2006 4:28 am
by AkhIL
At start blender takes 0.3 % of CPU. But after pressing Alt-A (play animation) and Esc (stop playing) Blender slows down and takes 20% of CPU time even scene is empty. Then CPU load slowly increase till Blender gets 100% of CPU.
After saving and restoring Blener takes 0.3% CPU again.
When I start playback by pressing play button in timeline window Blender didn't slows down.

I tried to compile and run Blender under Debian Linux on same box. Blender runs smooth.
But when I ran binary compiled in Debian under Gentoo bug appear again.

I think this bug appear only with Gentoo distribution. Can somebody help me fix it? I can debug Blender if yo give detailed instructions.

CPU: Athlon XP 2500+
MB: ABit KV7
OS: Gentoo Linux 2005.1 Optimazed
Kernel: 2.6.13-gentoo-r5

Blender compiled from official 2.41 sources

Posted: Mon Jan 30, 2006 6:33 am
by stiv
ATI graphics card?

Posted: Mon Jan 30, 2006 9:15 am
by AkhIL
stiv wrote:ATI graphics card?
nVidia GeForce4 MX 440
drivers version 1.0.6629

Posted: Mon Jan 30, 2006 9:17 am
by AkhIL
And one thing. Blender 2.3x works as well on my gentoo box.

Posted: Mon Jan 30, 2006 9:28 am
by AkhIL
I tried to switch video driver to vesa and opengl to xorg-x11. Same results.
Changing window mananger do nothing to.
Seems bug in library dependences.
Tommorow I'll try to update my system. Might be this helps

Posted: Mon Jan 30, 2006 2:54 pm
by gabio
Maybe your make.conf have some weird flag.
Try dowloading the official build from
If you builded your system with wrong flags, it can't be helped...

here is mine, I have a P4:
CFLAGS="-O2 -march=i686 -fomit-frame-pointer -pipe"

Posted: Wed Feb 01, 2006 3:27 am
by AkhIL
I tried blender-2.41-linux-glibc232-py24-i386-static. Same results.
But my system still not updated.

Posted: Tue Feb 07, 2006 4:48 pm
by AkhIL
Problem solved by updating system and rebuilding all blender's dependences from empty tree.
Thanks for all! I am happy now!