Blender starts fast then slows and hangs.

General discussion about the development of the open source Blender

Moderators: jesterKing, stiv

Post Reply
Teoma
Posts: 0
Joined: Tue Feb 14, 2006 7:16 pm

Blender starts fast then slows and hangs.

Post by Teoma » Tue Feb 14, 2006 7:27 pm

I have a:

AMD 1538 MHz Processor
959 MB RAM
Radeon Xpress 200 Series SW TLL
Blender version 2.3 i believe (it's not the new one)

Blender starts fine but as it runs it gets slower and slower, until it hangs.
(almost like a memory leak....) I'm assuming it's an OpenGL problem with my video card but i don't know how to fix it. (it seems to slow more with extensive 2d usage- file saving, uv mapping, ect..) I tried putting the atioglxx.dll from the Catalyst 3.7 driver package in my blender directory, but then Blender gives me an error and won't start at all. Any ideas on how to fix it or what driver I need?

z3r0_d
Posts: 289
Joined: Wed Oct 16, 2002 2:38 am
Contact:

Post by z3r0_d » Wed Feb 15, 2006 4:18 am

have you tried the latest drivers?

this problem went away for me when I upgraded from 98 to xp... but I have a radeon 9600se

simonharvey
Posts: 0
Joined: Tue May 18, 2004 8:11 am

Post by simonharvey » Wed Feb 15, 2006 11:45 am

ATI cards have always had problems with rendering and preformance of the blender user interface.

The usual remedy is to install the latest set of drivers, and the problem should go away (as z3r0_d mentioned).


Kind Regards
Simon Harvey

jgaray
Posts: 0
Joined: Tue Jul 27, 2004 4:08 pm
Contact:

Post by jgaray » Wed Feb 15, 2006 5:15 pm

I've had the same problem (ATI Radeon Xpress 200M) and the driver trick didn't work either. Something that does work is to open the display icon in the control panel, go to the Settings tab, click on advanced, click on the Troubleshoot tab (might be different on other machines), and lower the hardware acceleration until it disables the Direct Draw and Direct 3D accelerations (on mine, it's the third setting from the left). After that, Blender works OK, and I only have to remember to set it back when I'm done. The only problem is that sometimes it will crash when zooming in/out of the UV/image editor.

mchs3d
Posts: 0
Joined: Thu Feb 03, 2005 6:05 am
Location: Loveland, CO

Post by mchs3d » Sat Feb 18, 2006 1:42 am

Try this:
1. Download this file and put it in the same directory that blender.exe is in.
2. Set all graphics acceleration to maximum.

This will either crash the program upon start, or cause it to work smoothly. If it crashes, delete the dll. I hope for you it works smoothly, though. :wink:

jgaray
Posts: 0
Joined: Tue Jul 27, 2004 4:08 pm
Contact:

Post by jgaray » Sat Feb 18, 2006 3:28 am

Is that a newer version of the dll? It still makes mine crash. :(

Post Reply