Page 1 of 1

Problem with Blender - crashes on save (Win2K Pro, 2.42a)

Posted: Mon Sep 18, 2006 1:35 pm
by jtuttle
I'm planning on doing an independent study in 3d modeling using Blender; I'm going to be using Blender off my USB key on the school computers (as I have done for a few years now). Lately, however, Blender has been crashing when I use it on the school computers. It has crashed a few times while it's running, but it seems to (sometimes) consistently crash whenever I save. Blender does save the file and everything; I haven't lost any data (yet), but it's really annoying having to open Blender up again every time I save. The error is the following:

Title Bar -> 6c0: blender.exe - Application Error

v Message in dialog v

The instruction at "0x00840520" referenced memory at "0x0000000c". The memory could not be "read".

Click on OK to terminate the program
Click on CANCEL to debug the program


Blender is running off a USB key (I don't think that matters...); it's 2.42a. The computer I'm using right now (and that I just crashed it on to get the error) is running Windows 2000 Professional; the output of the 'System Information' script is below (shouldn't there be some sort of attachment button somewhere around here?).

=== BEGIN system-info.txt ===
=====================================
= Blender 2.42 System Information =
=====================================


Platform: win32
========

Python:
======

- Version: 2.4.2 (#46, Nov 17 2005, 20:11:16) [MSC v.1200 32 bit (Intel)]

- Paths:

H:\blender-2.42a-windows
H:\blender-2.42a-windows\python24.zip
.\DLLs
.\lib
.\lib\plat-win
.\lib\lib-tk
H:\blender-2.42a-windows
H:\BLENDE~1.42A
H:\blender-2.42a-windows\.blender\scripts
H:\blender-2.42a-windows\.blender\scripts\bpymodules

- Directories:

Blender home dir:
H:\blender-2.42a-windows\.blender

Default dir for scripts:
H:\blender-2.42a-windows\.blender\scripts

Default "bpydata/" data dir for scripts:
H:\blender-2.42a-windows\.blender\scripts\bpydata

User defined dir for scripts:
<NOTICE> -- not found

Data dir "bpydata/" inside user defined dir:
<NOTICE> -- not found

Default config data "bpydata/config/" dir:
H:\blender-2.42a-windows\.blender\scripts\bpydata\config

- Modules: all basic ones were found.

OpenGL:
======

- Renderer: Intel 915G
- Vendor: Intel
- Version: 1.4.0 - Build 4.14.10.3829

- Extensions:

GL_ARB_depth_texture GL_ARB_fragment_program GL_ARB_multitexture
GL_ARB_point_parameters GL_ARB_shadow GL_ARB_texture_border_clamp
GL_ARB_texture_compression GL_ARB_texture_cube_map
GL_ARB_texture_env_add GL_ARB_texture_env_combine
GL_ARB_texture_env_dot3 GL_ARB_texture_env_crossbar
GL_ARB_transpose_matrix GL_ARB_vertex_program GL_ARB_window_pos
GL_EXT_abgr GL_EXT_bgra GL_EXT_blend_color GL_EXT_blend_func_separate
GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_clip_volume_hint
GL_EXT_compiled_vertex_array GL_EXT_cull_vertex
GL_EXT_draw_range_elements GL_EXT_fog_coord GL_EXT_multi_draw_arrays
GL_EXT_packed_pixels GL_EXT_rescale_normal GL_EXT_secondary_color
GL_EXT_separate_specular_color GL_EXT_stencil_wrap
GL_EXT_texture_compression_s3tc GL_EXT_texture_env_add
GL_EXT_texture_env_combine GL_EXT_texture_filter_anisotropic
GL_EXT_texture3D GL_3DFX_texture_compression_FXT1
GL_IBM_texture_mirrored_repeat GL_NV_blend_square
GL_NV_texgen_reflection GL_SGIS_generate_mipmap GL_WIN_swap_hint


- Simplistic almost useless benchmark:

Redrawing all areas 10 times took 0.5203 seconds.

..

(*) Found 2 notices, documented in the text above.

=== END system-info.txt ===

Anyone have any ideas? Thanks.

-- J.P.

Posted: Mon Sep 18, 2006 2:05 pm
by Caronte
I think thi's a malfunction of either the computer or the windows. :roll:

Posted: Mon Sep 18, 2006 5:54 pm
by jtuttle
It also did it on my brother's Core 2 Duo laptop running Windows XP MCE. Weird.

-- J.P.

Posted: Mon Sep 18, 2006 9:39 pm
by Caronte
jtuttle wrote:It also did it on my brother's Core 2 Duo laptop running Windows XP MCE. Weird.

-- J.P.
:shock: Try to download Blender again
I never have seen a case like that, may be the usb memory?

Posted: Fri Oct 06, 2006 7:03 am
by Theran
I'm having the same problem.

The crash only happens when running as a normal user. Saving works fine when I'm running as admin. That's probably why it works fine at home but not at school.

The crash is 100% reproducible even when saving the default plane. This is on Windows XP x64.

Posted: Fri Oct 06, 2006 1:21 pm
by elubie
just wanted to let you know that I am convinced that this error is the same as in this bugreport:

http://projects.blender.org/tracker/ind ... 9&atid=125

The crash happens when saving the recent file list and has already been fixed in cvs on 2006-09-16.

What you could do, is try a recent testbuild to see if the problem persists, in which case I'll take a look at it again.

--- Andrea

Posted: Tue Dec 12, 2006 3:35 pm
by PeeGee
I have been using 2.41 happily for quite some time. Downloaded 2.42a today and was having big, big problems.

The process went like this... import .obj file, save as .blend file and crash. And I couldn't even restart Blender, I had to uninstall and reinstall it.

In desperation I tried a number of things and found the solution - I was trying to save the file (by this time called test1.blend) at the bottom of a long directory path.

Shorten the path, test1.blend saves fine and no crash.

Specifically, this is the issue:

Save as
C:\Documents and Settings\Chrissy & Phil\My Documents\Downloads\Red Orchestra\Campagna Italiana\Grenade\PanzerIIUVmap\PzII Interior\Panzer 2 interior\test1.blend
is a guaranteed crash every time

Save as
C:\Documents and Settings\Chrissy & Phil\My Documents\RO\test1.blend
works fine every time

Possible fix

Posted: Sat Jan 27, 2007 7:10 am
by a3141592
It looks like Blender is trying to write to the file

c:\windows\.blog

If you make that file writable, it should fix the problem.

Posted: Sat Jan 27, 2007 10:58 am
by LetterRip
please try 2.43rc2 it should be fixed and yes attempting to write to the .blog file was likely the issue.

LetterRip