rendering crashes

Blender's renderer and external renderer export

Moderators: jesterKing, stiv

Post Reply
Posts: 0
Joined: Sun Aug 24, 2003 7:22 pm

rendering crashes

Post by kvdman »


I have installed the latest versions of Blender in both Windows XP and Red Hat Linux 9 (taroon). Blender crashes everytime I click on the render button...

I have a Radeon 7500, and have the latest drivers installed in XP, and in Linux am using xfree86 4.3, and DRI.

I get the following errors:

In Windows XP:
AppName: blender.exe AppVer: ModName: atioglxx.dll
ModVer: Offset: 001baa8e

In Linux:
blender: radeon_vtxfmt.c:1061: radeonVtxfmtUnbindContext: Assertion `vb.context == ctx' failed.

I had the program working initially in Windows, but for some reason it won't work anymore. Tried installing, and reinstalling, tried older version; same error.

Any help would be appreciated,

Posts: 289
Joined: Wed Oct 16, 2002 2:38 am

Post by z3r0_d »

looks like your drivers are to blame

some other ramblings: the assert stament (they are left in final driver releases?) is a check to see if something weird is going on. It is a debugging tool.

For the moment a static build should work fine (in linux) but I don't know why your drivers would cause these errors.

Posts: 0
Joined: Sun Aug 24, 2003 7:22 pm

thought so too

Post by kvdman »

I thought so too...

What gets me, is that it was working in Windows... but now, I can't get it to work at all, it never did work in Linux (well it works, but every time I press render it crashes). The static version crashes when rendering too.

I am mainly concerned about getting it working in Windows...

I reinstalled my ATI drivers, and still no luck!

I am using blender now under Windows 98 in Vmware. How pathetic is that? That is actually working, but it sucks!

You know, I did a bit of research on this problem, and came across this: ... aq_id=1354

I tried to locate the files the guy is talking about, but only found the .Bfont in the Blender directory...

If anyone has any other ideas, it would be greatly appreciated!


Posts: 0
Joined: Sun Nov 16, 2003 4:28 pm

Post by he_man »

I have exactly the same problem with the same error. I've got an ATI Radeon 7500 too.

Post Reply