Page 1 of 1

can't avoid fireflies

Posted: Wed Feb 29, 2012 9:51 pm
by steve4891
Hello everybody...

i need an help to resolve a problem with light..

i have a room and i want to illuminate it with a lamp...

i bult a lamp with a cone in the upper side and a plane with emission material.

the problem is that this emission material gives me a lot of white dots pixels. even though i reduce the intensity to 20 the problem remain..

the strange thing is that if i put a plane (emisison) in the middle of the roof with example intenisty 50 the result is perfect... this second emission doens't provide white dots..instead the other one yes.

can someone tell me why this happen and how can this problem be solved?

thanks to all...

Stefano

Posted: Wed Mar 07, 2012 8:15 am
by ldo
Tried increasing the number of samples?

Same problemo

Posted: Thu Mar 08, 2012 2:07 pm
by Oippis
Hei, I assume you're using Cycles. I came to this Forum with the same problem. I've been working on a simple room scene (for my school project), and I'm losing my nerve because of these "fireflies".

http://dl.dropbox.com/u/63105448/huone_edistyy4.jpg

I realise that Cycles has problems rendering glass, (the windows here for example) is there a solution?

First I tried 200 samples, then I lifted it to 600 (in the pic) but the result is equally shitty so I figured it's not the amount of samples. I also tried different light bounce settings with no difference.

What's really annoying is that the rest of the image looks somewhat sharp and noiseless (just some light default "cycles grain") except these big white dots.

Posted: Thu Mar 08, 2012 6:52 pm
by ldo
In one previous test I was able to get less noisy-looking results by going as high as 2000 samples. What version are you using? With a more recent (2.62+) build, it seems to look better with just the default values.

Posted: Sat Mar 17, 2012 8:54 am
by stijntas

Posted: Wed Jun 20, 2012 2:00 am
by iliketoblender
I had the same exact problem for a long time. I had given up on all my cycles work that involved glass until I decided to spend some time troubleshooting. What I found to work was scaling up the light source (use a plane with the emission shader if you weren't already) and decreasing the emission level of the light source.

Posted: Thu Jul 12, 2012 3:37 pm
by Batty
The only thing that helped hugely, as I found out by searching the Net, is to set "Clamp" to 1.
But this goes at the expense of having caustics. This made my fireflies vanish even in complex glass scenes. I hope this might help until there is hopefully a better solution. :)

kr Batty