Several issues actually....

Blender's renderer and external renderer export

Moderators: jesterKing, stiv

Post Reply
CyberGolem
Posts: 0
Joined: Sat Oct 17, 2009 12:12 pm

Several issues actually....

Post by CyberGolem »

I followed BelnderGuru's tutorial on how to create a realistic Earth and now want to animate it. I'm a Maya/Max user so I apologize ahead of time if my language has a bit of a user-accent if you will.

The Earth object is 1 unit in diameter, but when I back my camera up just 200 units away, the Earth clips. I adjusted the 'end' on the camera to 5000 to no avail. Is there another place I need to make changes?

Now that the camera is backed away 200 units, I can't get my 'User Perspective' view to zoom closer anymore. This is frustrating since all I want to do is create a fly around of the model I built... but wait, there's more....

For anyone familiar with the Earth building tutorial, the following will hopefully make sense.
--The night map is the only map rendering (possibly from the separator material getting blacked out and excluding the day map altogether...?)
--The cloud layer is completely gone.
--The atmosphere isn't rendering though its opacity does affect how much when can see through to the city lights below.
--The sky-dome is overlit. The map I have is nearly black, but it's rendering a bright blue color.
When I delete the sky-dome, everything returns to normal.

I'm running OSX Snow Leopard.
Thanks for any and all help,
~Chaz

ldo
Posts: 0
Joined: Sun Nov 07, 2010 11:30 pm
Location: Hamilton, New Zealand

Post by ldo »

There are two separate sets of clipping planes, one that takes effect in the 3D view (and set in the Properties shelf), and the other that is part of the camera settings (and set in the camera tab in the object properties window). The latter is the one that affects rendering with that camera.

CyberGolem
Posts: 0
Joined: Sat Oct 17, 2009 12:12 pm

Post by CyberGolem »

ldo wrote:There are two separate sets of clipping planes, one that takes effect in the 3D view (and set in the Properties shelf), and the other that is part of the camera settings (and set in the camera tab in the object properties window). The latter is the one that affects rendering with that camera.
Thanks Ido.

In case others are wondering about my questions they were solved.

--The night map problem was cured when the 'traceable' function within the skydome's shader was disabled.
--The cloud layer restored itself as well since it was only gone since this particular tutorial doesn't account for its visibility on the night side of the planet.
--I have no idea how the atmosphere shader was restored but it's now working fine. I suppose it could be due to the new node arrangement created to accommodate for the render layers.
--Skydome works fine. My Mac isn't the most reliable for handling much of my software and often glitches on graphics... yay, and I paid so much for it :)

Anyway, I believe it's now safe to consider this case closed.
~Chaz

Post Reply