Yafaray 1.2 with Blender 2.64a in Debian Squeeze (64 bits)

Blender's renderer and external renderer export

Moderators: jesterKing, stiv

Post Reply
Posts: 0
Joined: Mon Jun 16, 2008 2:14 am

Yafaray 1.2 with Blender 2.64a in Debian Squeeze (64 bits)

Post by cochedelaferte »

Hi all,

Installing the Yafaray addon as normal like iit's explained in all tutorials, the render (standard Blender cube scene) starts, but provides only a black image.

To investigate more, i launch Blender in command line and starts again the render. Same result, and following in the terminal :

dlerror: /home/user/.config/blender/2.64/scripts/addons/yafaray/bin/plugins/libpngHandler.so: undefined symbol: _ZN7yafaray6yafoutE

Others undefined symbols, but not a lot, essentially this, which is of course, like all, defined in the main libs in yafaray/bin

In this case, i try again in command line, after a LD_LIBRARY_PATH export pointing to my .../yafaray/bin, where the libs have my missing symbols as defined. After that, i verify with a ldd that for the plugins all required libs are visible. But... Unfortunately, exactly same result, black render and same complain about the missing symbols in my terminal.

I suppose that something is wrong in my addon install, but for the moment have no pertinentl idea...

I posted the same in the Yafaray forum but, for the moment, nobody was able to help me.



(Nvidia GTX card and driver full OK, Xeon, sufficient RAM)

Post Reply