Light does not pass through a transparent mesh

Blender's renderer and external renderer export

Moderators: jesterKing, stiv

Post Reply
gregkwaste
Posts: 0
Joined: Tue Nov 27, 2012 6:13 pm

Light does not pass through a transparent mesh

Post by gregkwaste » Tue Nov 27, 2012 6:22 pm

hi there,

i guess i am in the correct subforum so i move on on my question:

I am making a football stadium and i am experiencing a very weird issue.

In the stadium there is one entire vip section which is actually a very wide box, with its front side having a plexy glass.

Normally light will pass through the transparent plexy glass, and make the objects inside the box visible.

So in blender (i am using world lightning for now), light never passes through this side... I can easily confirm that by moving the mesh... When i move this side and make an opening for the light to pass directly inside the box then i can see the objects. When my transparent mess "closes" the box i can't see anything...

How can i get a good render of that? Is my lighting wrong? Is it a material option? I am completely lost to be honest :S

Thanks in advance

Sascha
Posts: 0
Joined: Sat Dec 08, 2012 10:49 pm
Location: Berlin

Post by Sascha » Sun Dec 09, 2012 1:28 am

Hi gregkwaste,

it seems you have to have at least one simple light that effects the transparent glass but Environment Light will still not work "inside the room".
  • - If you don't want to have any spec on your glass uncheck the Specular Checkbox in the Light Object Data.

    - If you insist on environment light you could try to solve this with multiple render layers and the node editor.
Regards
Sascha

gregkwaste
Posts: 0
Joined: Tue Nov 27, 2012 6:13 pm

Post by gregkwaste » Sun Dec 09, 2012 3:28 pm

Sascha wrote:Hi gregkwaste,

it seems you have to have at least one simple light that effects the transparent glass but Environment Light will still not work "inside the room".
  • - If you don't want to have any spec on your glass uncheck the Specular Checkbox in the Light Object Data.

    - If you insist on environment light you could try to solve this with multiple render layers and the node editor.
Regards
Sascha

Thanks for your answer,

i've already unchecked the specular option in the light options, it had nothing to do with that.

I discovered a second object in the same place with my first one. The thing is that i had unchecked both the visible and the rendering option, and it seemed that somehow that object bothered the final render...

I deleted it completely and finally it let there be light :D

Sascha
Posts: 0
Joined: Sat Dec 08, 2012 10:49 pm
Location: Berlin

Post by Sascha » Sun Dec 09, 2012 3:54 pm

Yeah :) Have a nice weekend

Post Reply