Apple Mac & Nvidia - CUDA requires 1.3 Computer Capabil

Blender's renderer and external renderer export

Moderators: jesterKing, stiv

Post Reply
sunbeamrapier
Posts: 0
Joined: Mon Mar 30, 2009 6:37 am
Location: Byron Bay, Australia

Apple Mac & Nvidia - CUDA requires 1.3 Computer Capabil

Post by sunbeamrapier » Sun Mar 10, 2013 5:22 am

It has taken me some time to install and test CUDA on my early 2008 Macbook Pro, which has the NVIDIA GeForce 8600M GT 256 MB.

If you are thinking to do the same, I can save you the trouble - it doesn't work.

If you have a later model Macbook, then the following may help:

1. Download CUDA from the Nvidia website at: https://developer.nvidia.com/cuda-downloads

2. Installation instructions are here: http://docs.nvidia.com/cuda/cuda-gettin ... index.html

3. You need to create or edit a bash_profile file to include some path commands. The Nvidia instructions for this are somewhat lacking.

3.1: Open Terminal

3.2: In your user directory (should be the default) enter the following:

touch ~/.bash_profile; open ~/.bash_profile

3.3: Textedit should open with a file which looks like this (the first line is a blank line):


# Setting PATH for MacPython 2.6
# The original version is saved in .bash_profile.pysave
PATH="/Library/Frameworks/Python.framework/Versions/2.6/bin:${PATH}"
export

3.4: Change the last line to export PATH=/Developer/NVIDIA/CUDA-5.0/bin:$PATH

3.5 and add a new line:

export DYLD_LIBRARY_PATH=/Developer/NVIDIA/CUDA-5.0/lib:$DYLD_LIBRARY_PATH

3.6 Check that your bash_profile file now looks like this: (this first line is a blank line)


# Setting PATH for MacPython 2.6
# The original version is saved in .bash_profile.pysave
PATH="/Library/Frameworks/Python.framework/Versions/2.6/bin:${PATH}"
export PATH=/Developer/NVIDIA/CUDA-5.0/bin:$PATH
export DYLD_LIBRARY_PATH=/Developer/NVIDIA/CUDA-5.0/lib:$DYLD_LIBRARY_PATH

Finally, start Blender and change the rendering processor to GPU.

On My Macbook Pro I get the error:

Error | CUDA device supported only with compute capability 1.3 or up, found 1.1.

You can check the compute capability of your Nvidia card here:

https://developer.nvidia.com/cuda-gpus

Post Reply