GPU rendering option not available 2.66 (ATI)

Blender's renderer and external renderer export

Moderators: jesterKing, stiv

Post Reply
sclong
Posts: 0
Joined: Thu Mar 28, 2013 6:20 pm
Location: Chattanooga,TN

GPU rendering option not available 2.66 (ATI)

Post by sclong » Thu Mar 28, 2013 6:25 pm

Im new to the Cycles rendering engine, and I am trying to enable GPU rendering for still images etc. However, in version 2.66, the option for GPU is not there (only CPU option available).
I am on Mac osx with an ATI Radeon HD 5750. How can I enable this?

sclong
Posts: 0
Joined: Thu Mar 28, 2013 6:20 pm
Location: Chattanooga,TN

Post by sclong » Fri Mar 29, 2013 5:18 pm

Ok so I have discovered OpenCL is the equivalent to CUDA for Nvidia.
Can anyone show me what/where to download? All I know is that OpenCL is a language. What program am I looking for?

Tehrasha
Posts: 0
Joined: Wed Apr 21, 2010 6:21 am
Location: Iowa

Post by Tehrasha » Fri Mar 29, 2013 7:18 pm

Previously quoted material....
OpenCL support for AMD is currently on hold. Only a small subset of the entire rendering kernel can currently be compiled, which leaves this mostly at prototype. We will need major driver or hardware improvements to get full cycles support on AMD hardware. For NVidia CUDA still works faster, and Intel integrated GPU's are unlikely to give any speed improvement over CPU rendering.


In Blender 2.65, OpenCL is not available as a choice in the UI by default. The environment variable CYCLES_OPENCL_TEST can be defined to show it, which can be useful for developers that want to test it. The OpenCL kernel is located in 2.65/scripts/addons/cycles/kernel. In the file kernel_types.h specific functionality can be enabled/disabled for testing, without recompiling Blender.
AFAIK, it has not yet been turned back on since 2.65...
Sothe short answer is, the reason there is no GPU option for your card in Blender, is because it has been disabled for now.

You might find a OpenCL-compiled version that you can use, over at graphicall.org.

http://graphicall.org/?keywords=opencl

sclong
Posts: 0
Joined: Thu Mar 28, 2013 6:20 pm
Location: Chattanooga,TN

Post by sclong » Fri Mar 29, 2013 10:12 pm

Ill give this a look as well as using Luxrender until then. Thanks!

j kaulfers
Posts: 0
Joined: Tue Feb 08, 2011 5:20 am
Location: Mississippi

Post by j kaulfers » Wed Apr 03, 2013 5:42 am

good question. My renders are useless in cycles since 2.66. I have a NVIDIA GPU but can't use it.

CPU renders take enormus amounts of time and I have an I7 CPU. With 2.65 the same Cycles renders using GPU were just seconds now they take minutes, literally. Way off the chart, not even practicle to wait 2 or 3 minutes because you change a particle setting by .001 %

Hopefully the issues will be resolved. I updated my drivers for Nvidia and thought Blender would then recognise it,,, but,,, it did not,,,,still no option

Some nice things in 2.66 but I may go back to 2.64 because of the render times.

One example is the Long Hair rendering series / tutorial on CG Cookie, render times went from a minute or two to over one hour.

fersonjames
Posts: 0
Joined: Wed Apr 10, 2013 1:38 pm

Post by fersonjames » Wed Apr 10, 2013 1:47 pm

not sure this will help, but i was looking for the GPU 'switch" for a while, and it was in the user preferences. once i found it there i was very very happy!
Prevention is Difficult

j kaulfers
Posts: 0
Joined: Tue Feb 08, 2011 5:20 am
Location: Mississippi

Post by j kaulfers » Wed Apr 10, 2013 6:42 pm

Ya I found it under system, once activated you can then select experimental in the render settings and choose GPU.

FYI, my render time on one model went from about a minute to under 5 seconds using CUDA setting. Blew me away. I cant even imagine how fast it would be if it worked with the Blender internal engine.

Post Reply