2.37 ortho camera bug?

Blender's renderer and external renderer export

Moderators: jesterKing, stiv

Post Reply
lusque
Posts: 11
Joined: Wed Oct 16, 2002 9:53 am

2.37 ortho camera bug?

Post by lusque »

When rendering with an ortho camera and a ray-shadow lamp 2 intersecting objects, a black line appears on the intersecting edges of the objects.

Tested on a WinXP SP1, AMD AthlonXP 1600+, GeForce3 Ti200

If this is a bug, can someone post in the bugtracker? I don't know how to do it :oops:

bullx
Posts: 0
Joined: Mon Jan 05, 2004 9:25 pm

Post by bullx »

cannot replicate. post the blend please.
:-)

lusque
Posts: 11
Joined: Wed Oct 16, 2002 9:53 am

Post by lusque »

Here it is: right-click "Save Link Target As"

http://lusque.altervista.org/OrthoCameraBug.zip

press F12, there is a thin black line where the cubes intersect.
Try with a perspective camera and the line goes away.

* hint hint *
I remember a similar bug when the raytracer was first introduced into Blender, maybe is the same problem?

bullx
Posts: 0
Joined: Mon Jan 05, 2004 9:25 pm

Post by bullx »

the zip resuts corrupted, i'm sorry

lusque
Posts: 11
Joined: Wed Oct 16, 2002 9:53 am

Post by lusque »

My provider has problems sorry, here I can download without problem.
So here's a quick tutorial:

-start with the standard scene
-duplicate the cube and place it in such a way it intersects the firs cube
-select the lamp and enable "ray shadow" in the lamp buttons(F5_KEY)
-select the camera and enable "ortho" in the editing panel (F9_KEY)
-go in the rendering panel(F10_KEY) and enable the "ray" button
-do the rendering (F12_KEY) you will notice a black line along the cubes intersectin edge
-if you disable the "ortho" camera and render again the black line goes away

and just because I can't trust my english well enough, here's the italian version: :wink:

-inizia con la scena standard
-duplica il cubo e piazzalo in modo che si interpenetri con il cubo originale
-seleziona la lamp e attiva "ray shadow" nel pannello luci F5
-seleziona la camera e attiva "ortho" nel pannello di editing F9
-vai nel pannello di rendering F10 e seleziona il bottone "ray"
-fai il rendering e noterai una riga nera dove i cubi si interpenetrano
-se disabiliti la "ortho"camera e fai un nuovo render la linea nera scomparirà

bullx
Posts: 0
Joined: Mon Jan 05, 2004 9:25 pm

Post by bullx »

Image

i can hardly see it but maybe you are right

Alvaro
Posts: 10
Joined: Thu Oct 24, 2002 6:45 pm

Post by Alvaro »

Thats true, I've had some problems with the new ortho camera. In general, that problem happens when AO is activated.
On the other hand, the Anti Aliasing seems to be better with the new ortho camera.
I was expecting some problems since there are some comments in the release notes, but not that much.
IMO that new ortho camera is great for profiles and technical stuff.

Blender 2.36
Image
Blender 2.37, same settings, notice the artifacts and AA
Image

Something I would like to comment is that with previous releases, you could see all the rendering done so far. If you didn't like the result you could cancel it.

But now the rendering only shows the pixels since the last window refreshing.

Rendering progress, 2.36
Image

Rendering progress, 2.37
Image

lusque
Posts: 11
Joined: Wed Oct 16, 2002 9:53 am

Post by lusque »

Thank you bullx and Alvaro for confirming the bug.
I've just posted in the bugtracker

YAY my first bugtracker entry :D

by the way: wonderful plane :shock:

lusque
Posts: 11
Joined: Wed Oct 16, 2002 9:53 am

Post by lusque »

WOW :shock: Ton is very fast indeed.

I submitted the bug at 11:32
Ton hunted the bug (and other two he found in the same area of code)
and at 14:47 the three bugs were fixed

I'm amazed :shock:, and happy to be a Blender User :D

Alvaro
Posts: 10
Joined: Thu Oct 24, 2002 6:45 pm

Post by Alvaro »

thanks people. The ortho camera works fine!
example:
http://img59.echo.cx/img59/7818/comp7ee.jpg

Post Reply