alpha uv texture shows up in 3dview but not in render

Blender's renderer and external renderer export

Moderators: jesterKing, stiv

Post Reply
pgavazzi
Posts: 0
Joined: Tue Mar 14, 2006 6:47 am

alpha uv texture shows up in 3dview but not in render

Post by pgavazzi » Tue Mar 14, 2006 7:16 am

Hi,

I'm pretty new at using blender. I followed a tutorial on UV alpha textures and everything is fine until I render. In my 3Dview the alpha is transparent, but when I hit the render current frame, the render has white where it should be transparent. Did I miss a setting somewhere?

I am running blender 2.41 on a Mac OSX.

regards,

Paul

treedeejoe
Posts: 0
Joined: Sun Apr 09, 2006 12:34 am
Location: Jensen Beach

Post by treedeejoe » Thu Apr 13, 2006 5:20 am

I'd like to see the tutorial. Where is it? maybe if I wak through it myself I can find the reason it is not working for you.
And there was light.

solmax
Posts: 86
Joined: Fri Oct 18, 2002 2:47 am
Contact:

Re: alpha uv texture shows up in 3dview but not in render

Post by solmax » Mon Apr 17, 2006 6:20 pm

pgavazzi wrote:I followed a tutorial on UV alpha textures and everything is fine until I render. In my 3Dview the alpha is transparent, but when I hit the render current frame, the render has white where it should be transparent. Did I miss a setting somewhere?
hi,

yes it seems you missed an important part - or simply didn't know abt. it.
simply UV mapping and assigning an image to selected faces only defines the look for the 3D view and the game engine. To make the same texture show up in the final render you have two possibilities:

1: add a material for the object, if it hasn't any. locate the button "TexFace" and activate it. This will take the UV editor assigned image and apply it to the color of the object. Just note: this way you can assign the UV texture to the color only.

or
2: again add a material, if there isn't already one. also add a texture. make the texture be an image. for the image file, choose the same one you used in the UV editor. in the material tab, under "Map Input", choose "UV". and under "Map To" you can choose to which channel (Color, Bump, Specular etc.) this image should be assigned to. Multiple selections possible. And this is the big difference between method one and two. One cares only abt. the color channel, two gives you more control.

BTW: this belongs to elysiun.com

Post Reply