Save runtime doesn't work for 2.44 on OSX?

Game Engine, Players & Web Plug-in, Virtual Reality, support for other engines

Moderators: jesterKing, stiv

Post Reply
Posts: 0
Joined: Mon May 28, 2007 3:29 pm

Save runtime doesn't work for 2.44 on OSX?

Post by pihlaja » Mon May 28, 2007 3:46 pm

I've been trying to create a standalone runtime with Blender 2.44 on OSX 10.4.9, Intel mac.
It doesn't work for me, atleast, and it just gives an error message: "Unable to make runtime: Unable to find runtime."

I have the blenderplayer binary in /Applications/blender2.44/ (where I have Blender installed).

When I run blender from the commandline from /Applications/blender2.44/
It doesn't print any info about the error to the commandline output.

A bug? Or am I doing something wrong. I've never created a runtime before on any platform, but all the documentation says that you just have to click Save runtime... and that should do it.

Any help would be appreciated. Especially before thursday morning!

Posts: 0
Joined: Tue Apr 10, 2007 7:06 am
Location: Michigan, USA

Re: Save runtime doesn't work for 2.44 on OSX?

Post by blendenzo » Wed May 30, 2007 8:10 pm

A member of my team recently ran into this problem with version 2.43, but when he tried the 2.44 RC2, it worked fine. I won't be able to talk to him until Thursday morning, though.

The error you are getting means that Blender cannot find the blenderPlayer runtime, which is what it uses as the base for building a runtime off (runtimes are really just the blenderPlayer and a .blend combined together into one file).

For now, I would recommend that you make a copy of the blenderPlayer and place it in the root directory (that is, the topmost directory on your filesystem, namely "/"). My experiments with the Mac blender have shown that it regularly believes that the root directory is its working directory, regradless of where you are running the program from. Perhaps it is saying "cannot find runtime" because it is looking in the wrong directory for the blenderPlayer.

Keep in mind that if you are using external resources, Blender will probably also look in the root directory for those. Because of that, it is best to pack your sounds and textures using "File >> Pack Data" before you make the runtime.
The life is in the blood...
(Find useful Game Engine tutorials @

Posts: 0
Joined: Thu Mar 25, 2004 7:03 am

Post by LetterRip » Wed May 30, 2007 11:35 pm

please file a bug report in the bug tracker, if that is a problem in 2.44


Posts: 0
Joined: Thu Jun 28, 2007 4:44 am


Post by saelun » Thu Jun 28, 2007 4:55 am

I am a new MAC user having the same problem getting runtime to work in BLender 2.44. Can you tell me were I find the file you mentioned? (blenderPlayer)

I hate asking stupid questions but I have no experience with MAC or blender. I appreciate any help you might be willing to offer.

Posts: 13
Joined: Tue Jan 14, 2003 12:44 pm
Location: São Paulo, Brasil

Post by Lorca » Fri Jun 29, 2007 6:53 pm

Hi! I was having some problems using the Intell version i guess it is a bug.

Then i used the Power PC version of Blender and it works.

Its also nice to install Python.
"First they ignore you, then they lough at you, then they fight you. And then... you win."

M. Gandhi

Posts: 0
Joined: Thu Jun 28, 2007 4:44 am

Post by saelun » Sat Jun 30, 2007 4:05 am

Ok you guys were really helpful and I have a fix that seems to work.

I downloaded the power PC version and copied the to the aplication folder.

So I am using the intel version of blender with the power pc version of
Blender Player. It works though.

Thank you all for your help.


Posts: 0
Joined: Fri Feb 08, 2008 2:42 pm

Post by Registered » Fri Feb 22, 2008 10:27 am

I don't know much about OSX programming but i see that the intel version of blenderplayer doesn't have the .app extension.

that means that its a terminal application.

The trick with the PPC version worked for me, but the resulting runtime is a PPC application.

Can anyone compile the intel app of blenderplayer so that the resulting app is intel and not ppc???


Post Reply