Game engine troubles

Game Engine, Players & Web Plug-in, Virtual Reality, support for other engines

Moderators: jesterKing, stiv

Post Reply
brando132
Posts: 0
Joined: Sat May 07, 2011 3:39 am

Game engine troubles

Post by brando132 » Sat May 07, 2011 3:48 am

I'm new to blender but have been watching blendercookie tutorials which are very helpful, but I'm stuck on a problem with the game engine. I have my mesh model and armature all rigged and have 2 animations, idle and walk, but I cant for the life of me get the animations to work in the game engine. I have logic bricks exactly as he shows in the video on making a video game here -> http://www.blendercookie.com/2010/05/13 ... er-part-1/ I can get it to move. As soon as i start the game engine the model goes from the first keyset of the walk animation to the default arms and legs out looking like it was before i added armature and posed it. I would appreciate any help, and can give more info if necessary.

Thank you.

SolarLune
Posts: 0
Joined: Sun Feb 06, 2011 8:58 pm

Post by SolarLune » Sat May 07, 2011 4:00 am

Are you sure that you're activating Action actuators to run the animations?
Check out my blog of game design and BGE tutorials at http://solarlune-gameup.blogspot.com/

brando132
Posts: 0
Joined: Sat May 07, 2011 3:39 am

Post by brando132 » Sat May 07, 2011 4:08 am

Yes and I have set the start and end frames correctly too. It just seems as though as soon as I start the game engine the skeleton just stops effecting the mesh or maybe disappears, I don't know because it doesn't show up.

brando132
Posts: 0
Joined: Sat May 07, 2011 3:39 am

Post by brando132 » Sat May 07, 2011 9:54 pm

Ill upload a .blender so someone can take a look at it and hopefully tell me whats going on. FYI I'm using the latest version if that matters. http://www.megaupload.com/?d=GFQTFVUQ

brando132
Posts: 0
Joined: Sat May 07, 2011 3:39 am

Post by brando132 » Sat May 07, 2011 11:18 pm

I figured it out, I had to move the armature modifier above the sub-surf modifier.

Post Reply