help! textures works in Blender render but now in game mode!

Game Engine, Players & Web Plug-in, Virtual Reality, support for other engines

Moderators: jesterKing, stiv

Post Reply
msantamaria
Posts: 0
Joined: Sat Sep 01, 2012 10:42 pm

help! textures works in Blender render but now in game mode!

Post by msantamaria »

I have to deliver a school project next week. And i have a big problem. After i finished my project on render, the images are displaying well when i use the blender render but there a some texutes that are not displayed well when i run it as a blender game.

Actually it happends only on big textures, as floors, sky, parkings..

The plane appears in black. What is not correct because they have textures applied and are showing in the render mode well. Please help if any one know how to solve this.

stiv
Posts: 0
Joined: Tue Aug 05, 2003 7:58 am
Location: 45N 86W

Post by stiv »

I *believe* the game engine needs UV-mapped textures.

msantamaria
Posts: 0
Joined: Sat Sep 01, 2012 10:42 pm

Post by msantamaria »

stiv wrote:I *believe* the game engine needs UV-mapped textures.
i have some mapped, and they are not showing too.

Any expert in game devolpment in blender ?

OTO
Posts: 60
Joined: Wed Oct 16, 2002 8:51 pm
Contact:

Post by OTO »

Hello
no need to be an expert to answer your basic question ( already answered a million times I guess?)!

As stiv stated above UV textured objects should work in Single Texture mode!
In Multi Texture or GLSLyou must add a Texture ( image) to the Material of the object!
Bye

Post Reply