Page 1 of 7

Game Engine Issues

Posted: Tue Apr 06, 2004 5:44 pm
by Saluk
Use this thread to help find all issues with the game engine so they can be fixed by 2.33

Definately getting close, most things work, theres a few general issues I've seen:

*Some issues with slowdown on added objects (in one case leading to a crash)
*dRot in motion actuators still does nothing
*In several cases, where I tried to convert dRot to torque, the axis was backwards (left before became right, right before became left) and in these cases I also seemed to have more physics errors than in cases that already used torque or AngV. Makes me think there is a load error or something.
*Some physics errors, things falling through the ground on startup.
*New ui has problems scrolling the game logic window if there are a lot of logic bricks

If sumo is the default physics (I.e, when no world is selected), the gamelogic buttons should be visible by default as well.

I am having trouble finding the "view axis" button. Did it disapear?

I've uploaded some of my old blends I have been testing with. I also have docs that explain what is wrong with them. ... tGames.rar

Posted: Tue Apr 06, 2004 6:16 pm
by calli

I still use some days old source an there the dRot Actuator works ok? Who did broke it? ;-)

I will now test some of our *.blends, however my Linux box is only a 700MHz Celeron with a TNT2....


Posted: Tue Apr 06, 2004 11:44 pm
by Ghost
I have found this issue:

If a Ray Sensor and a Near Sensor are attached to the same object, it will bring Blender to its knees, that is Blender will stop responding.

I tested this with gabio's Windows CVS-builds from 2004/04/03 and 2004/04/05 found here: ... forum&f=18


Posted: Thu Apr 08, 2004 12:29 am
by Saluk
Good find ghost!

That's probably the root of most of the problems with my blends.

Another thing that's a bit worrysome are the falling through the ground problem. If you combine something with animation, dynamic objects have a real hard time on the collision detection, more than before. But even without animation, there are still some collision issues it seems.

Posted: Sat Apr 10, 2004 12:02 pm
I've notice that the field 'To' in message Actuators is not working. I didn't post a bug because with 2.25 there is the same result. Maybe I don't understand how 'To' is working in this Actuator, but the Tooltip is clear: The message is sending to object with this property. Even adding the right property to the destination Object doesn't make change. Without this field filled, all is OK.

Is it a bug or am I Bugging ? :wink:


Posted: Sat Apr 10, 2004 5:22 pm
by Saluk
Yep, you are clear on how it is supposed to work, and it just doesn't.

Bug bug bug. It was on the old bug tracker list from NaN, along with 100 or so other bugs from 2.25 and earlier. I'm not sure if that bug tracker is still around?

Posted: Sat Apr 10, 2004 6:58 pm
Thanks Saluk, I'll check in the BugTRacker and post if it's not there !

Posted: Sun Apr 11, 2004 11:01 am
by pildanovak
i'm not able to import any Blender libraries in realtime in the latest build(8.4.04), except of GameLogic. Is it supposed to be this way?
these commands (for example)don't work>

import Blender
from Blender import Scene

import Scene

Posted: Sun Apr 11, 2004 11:11 am
by Ghost
The import of the Blender Python module have been disabled:

Kester (CVS log):
Don't import Blender python module into the gameengine. It causes link problems for blenderplayer. Added a python function for MT_Vector4s

Look here: ... 01464.html

Posted: Tue Apr 13, 2004 6:48 am
by Rebel
Hi Guy's,
Please don't forget the doppler shift that does not work, and although it seems that not many people use joysticks these days, I still believe that reading the joystick ports should not be such a big problem to access.
This would enable guys like me to make programs like simulators for planes and cars etc. Thanx


Posted: Sun Apr 18, 2004 4:13 pm
by malCanDo
> If sumo is the default physics (I.e, when no world is selected), the gamelogic buttons should be visible by default as well.

I just downloaded the latest version of Blender ( it's been a while since I used it ) to try out the new physics features. I couldn't find the game logic buttons ( where you used to be able to set mass, actor stats etc ). Your posting seems to indicate that something has to be toggled first... what do you have to do to make the sumo options appear when starting from a new file?

Best regards...

Posted: Mon Apr 19, 2004 4:02 am
by alien-xmp
You have to set the physics engine to 'Sumo' in the world buttons for the logic buttons to appear.

Posted: Mon Apr 19, 2004 6:30 pm
by jd-multi
I played around with the last build and the game engine in it. But it still seams the actors still go traight trough the ground using force or torque.
When I made a little Pod racing test game, I could fly traight trough it, even when I added materials or anything else. :?

Is there a way to fix this, because I've seen this in all build, non of them had this fixed. I hope it could be done before it's released as 2.33. :P

Posted: Tue Apr 20, 2004 4:01 am
by alien-xmp
Can you post the .blend? Collisions should be working right now.

Posted: Tue Apr 20, 2004 5:56 pm
by jd-multi
Ok here's the .blend test I was talking about. When you run the game, it works sometimes, but most of the time (when restart game) the actor goes traight trough the ground. I don't know why, I made a lot of tests and even some game demos in 2.25 so I know what I do, but I don't get it why this happens. :(

The controls are:
forwards: W
left: A
right: D
Boost: numpad 1
fly: numpad 0

link .blend file: