Sound with OS X

Game Engine, Players & Web Plug-in, Virtual Reality, support for other engines

Moderators: jesterKing, stiv

Post Reply
tsalagi
Posts: 0
Joined: Mon Nov 01, 2004 11:39 pm

Sound with OS X

Post by tsalagi » Mon Nov 01, 2004 11:46 pm

I am trying to create a game with Mac osx (blender 2.34). I load a wav file and make an actuator for it, but when I press p to start the game, Blender crashes. I can play other peoples games with sound, and they work fine. Is this a bug in osx? or am I missing a setting or something?

Thank you for your help!

garycmartin
Posts: 0
Joined: Mon Sep 06, 2004 6:20 am
Location: Edinburgh
Contact:

Post by garycmartin » Fri Nov 05, 2004 12:15 am

Yea, sound crashs under OS X with 2.34 the SECOND time it is attempted (between game engine runs or use in the blender UI and then a game engine run). :(

Games with sound will play fine, the first time through, but crash if stopped and played again, but trying to add sounds into your own game can be a pain as testing cycles mean repeated re-launching of blender between crashes (tweak sounds, play game engine = crash'n'burn, re-launch blender, play game engine, tweak a bit more = crash'n'burn, re-launch again, etc).

I must sadly admit I now leave sound out of any projects under 2.34 for fear of loosing work while testing in hope that this will be fixed in the next version in time for me to re-visit sounds again.

tsalagi
Posts: 0
Joined: Mon Nov 01, 2004 11:39 pm

Thanks for the reply

Post by tsalagi » Fri Nov 05, 2004 1:43 am

I guess I'll just have to wait until its fixed. Thanks.

alien-xmp
Posts: 0
Joined: Sun Apr 06, 2003 2:22 pm
Location: Wellington, New Zealand
Contact:

Post by alien-xmp » Fri Nov 05, 2004 11:56 am

I don't have access to an OSX machine, so you are better off prodding the code than waiting.

I tracked down the same thing for Linux (there was a bug in OpenAL.)

ute
Posts: 0
Joined: Sun Mar 30, 2008 6:46 pm

Post by ute » Sun Mar 30, 2008 9:55 pm

have the same problem in 2008: I am working on mac os x 10.5:
MacBook Pro, 2.33 GHz Intel Core 2 Duo, 2GB sdram.

i noticed, that my intel-version of blender (2.44 Intel or 2.45 Intel or 2.46rc Intel) can´t play wav-files. there is simply nothing to hear (in the blender sound block, pressing play after loading), but the wav-file is ok (16bit) and it is displayed in the sound window.

the PPC-Version works, but it would be great, if someone has an solution!
because of my second problem – the runtime-export doesnt work on the intel-version too – i decide now to work with the PPC-version.

not really cool.

SirDude
Posts: 233
Joined: Sun Oct 13, 2002 7:37 pm
Location: University of Minnesota (USA)
Contact:

Post by SirDude » Mon Mar 31, 2008 4:54 pm

I haven't looked at the sound issue. Just wanted to let you know that
I'm working on the make runtime issue though and should have a fix
later today. :)

The problem is its looking for blenderplayer.app and that wasn't provided
in the x86 release. I'm going to try and fix it so that it can use
blenderplayer.app or the commandline blenderplayer.

ute
Posts: 0
Joined: Sun Mar 30, 2008 6:46 pm

Post by ute » Wed Apr 02, 2008 12:11 pm

that is really nice, thanks a lot!
i want to make a course at an art university with blender next week and have to convince a lot of students from blender and its famous possibilities like the game engine. it doesn´t sound really seriously, when i say at the beginning, that we have to use the ppc-app (most are mac-user).
but blender is great!
thanks

malCanDo
Posts: 1
Joined: Mon Oct 21, 2002 1:44 pm
Location: Ireland
Contact:

Post by malCanDo » Wed Apr 02, 2008 6:26 pm

Hi ute,

This might be a useful PDF based Introduction to the Game Engine tutorial to allow the students to download / print out, as part of the course / pre-training for the course.

http://wiki.blender.org/uploads/3/3e/BS ... torial.pdf

( here's the area on the Blender WIKI that it is taken from )
http://wiki.blender.org/index.php/BSoD/ ... ame_Engine

Enjoy!
Mal

SirDude
Posts: 233
Joined: Sun Oct 13, 2002 7:37 pm
Location: University of Minnesota (USA)
Contact:

Post by SirDude » Wed Apr 02, 2008 7:47 pm

ute if you download the test2 or RC2 build from:
http://download.blender/org/release/Blender2.46rc

it should have the blenderplayer.app in it so you should be good to
go.

I'm going to try and get the 2.45 bins rebuilt with blenderplayer.app
and everything should be good. It may take a few days though to
get this done.

ute
Posts: 0
Joined: Sun Mar 30, 2008 6:46 pm

Post by ute » Sat Apr 05, 2008 6:05 pm

:D thanks a lot SirDude and malCanDo! the pdf is very helpful!

Post Reply