Page 1 of 1

Flip pose for a whole animation, all keys

Posted: Tue Jan 18, 2011 6:07 pm
by zoltankovary
Hey blenderers!

Created a 180 frame long animation in 2.54a with like 40-50 key-frames. This will be for a game, with at least an other 30 animations. All the animations are from left to right, then the same from right to left.

After I finished the animation from one side I can create the mirror of it, by copy-flip paste every key-frame, but that is a loads of extra work throughout the whole project. Is there any method to automatically flip-pose all the keys for the whole animation?

Thanks for any help.

Posted: Thu Mar 07, 2013 1:31 pm
by kayyy
2 years and 2 months later :-) I ran into same problem and have developed an add-on called Flip Animation.

It iterates over all keyframes of an action and creates the exact mirrored poses. Altenatively there is an append mode which considers a specified range only and appends the X-flipped poses afterwards (nice to complete a run cycle or similar symmetric stuff). The add-on places a new sub panel with a button and few options in the tool shelf of 3D view when in pose mode.

I wrote a blog post about this including a video tutorial (the first 90 seconds are enough information to start using it):
Flip Animation Add-On for Mirroring Keyframes in Blender

Or the direct link to download the add-on: FlipAnimation.zip file

Posted: Fri Aug 30, 2013 8:24 pm
by vinoroidski
kayyy wrote:2 years and 2 months later :-) I ran into same problem...
5 months later... :)

Thank you guys, especially @kayyy. I was looking for a way to animate my dragon and i had to mirror a lot of animations to provide variety. Manually doing so would take ages.

I am very new to Blender and the CAD world itself. I am so happy that there are such great contributors such as yourself who take the time to help out others, like me. Thank you for an AMAZING add on which I am sure I will benefit from greatly!

Thank you sir!

regards,

vinoroidski

Posted: Fri Aug 30, 2013 8:35 pm
by kayyy
Be warned that my FlipAnimation plug-in refuses to work with version newer than 2.6.2. I had no time to fix this