Linux Alt-A Playback = Instant Blender Crash

Animation tools, character animation, non linear animation

Moderators: jesterKing, stiv

Post Reply
Posts: 254
Joined: Wed Jan 28, 2004 7:39 pm

Linux Alt-A Playback = Instant Blender Crash

Post by Pablosbrain »

Anyone else have this problem?

Opening up a .blend with some objects animated and then pressing Alt-A blender proceeds to crash instantly.
I'm currently running on Redhat Fedora Core 3. I've tried 2.35/a/b all with the same result. A segmentation fault is all thats displayed with no additional output. Is this something being fixed for the next Bug Fix release they are working on according to the email discussions? or should I submit to the tracker?

Posts: 289
Joined: Wed Oct 16, 2002 2:38 am

Post by z3r0_d »

have you tried disabling audio?

Posts: 254
Joined: Wed Jan 28, 2004 7:39 pm

Post by Pablosbrain »

Yup... I'm pretty sure thats in my .b.blend file. I'll verify that tonight after work though.

Posts: 13
Joined: Tue Oct 15, 2002 11:10 pm

Post by basse »

last time something like this was happening, it was fedora core 2 SDL packages, that were built in a certain way that caused trouble. I wouldn't be surprised if they still are doing that :)

to fix it, was an enviroment variable to be set.

"export SDL_AUDIODRIVER=dma"

it was quite horrible when this happened. and it was quite a debug session and I think it was Unnamed who finally thought about this dma thingy.. don't remember anymore. it ended up into FAQ too ..

just one of the reasons that made me switch to debian, finally :)


Posts: 0
Joined: Tue Jan 18, 2005 2:33 am


Post by ArkyMedia »

I had this happen too. I compiled it from source as a 64-bit version and it works fine now.

Posts: 0
Joined: Wed Jan 07, 2004 6:08 pm

Post by hanspb »

This happened to me once. At that time I was playing a cd (music) with Kaffeine. It has never happened when I have no sound, so it's got something to do with sound. Quite annoying for those who like listening to music while blendering. (Blender 2.36, Mandrake 10.1, Alsa 1.0.6 sound driver).

Hans Petter

Posts: 0
Joined: Tue Aug 05, 2003 7:58 am
Location: 45N 86W

Post by stiv »

The problem is two applications trying to grab the same sound device. This is a system issue and not an application problem. For this to work, you need a mixer or sound daemon that allows multiple connections to the sound device.

Post Reply