Page 1 of 1

[SOLVED] Installing on Ubuntu 10.10 x64

Posted: Sun Feb 20, 2011 5:44 pm
by Bucic
Hi! I'm new to the forums. After great experiences with GIMP and Inkscape I hope to learn at least basics of Blender :)

Here we go...

Due to UI problems I had with 2.49 I've decided to install the latest dev version. I've downloaded the tar.bz2 archive from blender.org, extracted it...

The readme.html inside the archive says
Linux, FreeBSD, Irix, Solaris: Unpack the distribution, copy the .blender directory from it to your home directory. Then run the Blender executable.
Install scripts by putting them in the .blender/scripts inside your home folder.
1. There is no .blender dir in the archive (even though I have "show hidden files" option checked)
2. 2-Clicking on the blender executable included in this archive does nothing.

Can anyone help me out.

Posted: Tue Feb 22, 2011 5:11 pm
by ebb
if you are building blender form source i don't know anything about that, but if you want the file provided by blender.org it's here http://www.blender.org/download/get-blender/ .The blender executable is in that file, just click on it.

ebb

Posted: Tue Feb 22, 2011 9:41 pm
by Bucic
I already did - as stated above.

Posted: Wed Feb 23, 2011 9:03 pm
by stiv
Run blender from the command line as ./blender . Likely there is something missing that is keeping it from running.

A more sophisticated approach would be to run ldd on the blender executable and look at the missing shared libraries.

Posted: Wed Feb 23, 2011 9:21 pm
by Bucic
stiv wrote:Run blender from the command line as ./blender . Likely there is something missing that is keeping it from running.

A more sophisticated approach would be to run ldd on the blender executable and look at the missing shared libraries.
Already tried that. It returns "blender not installed". It obviously tries to launch an "installed blender" and doesn't even care about that executable from the package. When I had 2.49 installed a command to launch 2.56 was launching... the installed 2.49.

Posted: Thu Feb 24, 2011 5:35 am
by stiv
This suggests you are trying to run blender from the command line as
blender
not as
./blender
(that is dot-slash-blender).

Just typing blender will look for an executable in your PATH. dot-slash-blender will execute that specific file. If this does not work, show the results of running
file ./blender

Posted: Fri Feb 25, 2011 9:00 pm
by Bucic
I've been given a 32 bit Ubuntu CD instead of 64 bit so I was trying to run blender x64 on 32 bit system without even a clue that this was the reason of all the troubles. On top of that I ran 2.49 instead of 2.56 by mistake. Bad, embarassing day all around :oops: Sorry for bothering you.

So:
- run the right executable for your system architecture e.g. run 32 bit executable on 32 bit system
- running blender 2.5x from tar.bz2 archives from blender.org is the easiest way to run blender 2.5x and works flawlessly

Posted: Fri Feb 25, 2011 10:23 pm
by stiv
We love a happy ending!

Posted: Fri Feb 25, 2011 11:35 pm
by Bucic
:)