Page 1 of 1

bf-blender linux-glibc2.2.5-Python 2.3 (20040427)

Posted: Tue Apr 27, 2004 10:41 pm
by Michel
Hi,

Here's finally another update on the Linux build front. IanWill again made some updates that should fix the problems with crashes. Please, test again, and let me know the results.
Thanks again!

Oh, here you can find the packages as usual.

With regards,
Michel

Bus error

Posted: Wed Apr 28, 2004 5:47 am
by aether17
First,
Game engine makes me soooooo happy. Thank you.
Build 04/21 worked out of the box on RH9, celleron 1.8 1g ram, 128mb nvidia. Upgraded to python 2.3
Build 04/27 returned Buss error
Do you want me to run the gdb script from 04/21 ?
Thanks agiain for bringing back and old friend.
Kind Regards
Daniel

Re: Bus error

Posted: Wed Apr 28, 2004 8:34 am
by Michel
aether17 wrote:First,
Game engine makes me soooooo happy. Thank you.
Build 04/21 worked out of the box on RH9, celleron 1.8 1g ram, 128mb nvidia. Upgraded to python 2.3
Build 04/27 returned Buss error
Do you want me to run the gdb script from 04/21 ?
Hi,

Yes, please, I'm very interested in the gdb output. Do you get the bus error at startup or at another time?

With regards,
Michel

Posted: Wed Apr 28, 2004 9:45 am
by OTO
Hi

remember me?? The guy who always reports crashes???
Well, NO MORE CRASHES....hooray

I've made some quick tests with old files and the game engine seems to work
quite well (maybe faster??...)

Thank you to all for the hard work, I'ts much appreciatted

Mandrake 10 Comunity, Python 2.3.3

Posted: Wed Apr 28, 2004 10:52 am
by raphael
Congratulation ! You defeat the ugly bug !
No more SegFault on startup and everything seams to work.

I'm going to make some tests with the new API. The "Noise" module is very interesting, as the improvments made in the Scene module, and,....

wow, lot of new stuff to test !


great work :)

Posted: Wed Apr 28, 2004 11:01 am
by raphael
hoho..

i don't find the rendering submodule...

s=Blender.Scene.Get("Scene")
print dir(s)
['copy', 'currentFrame', 'endFrame', 'frameSettings', 'getBackbufdir', 'getChildren', 'getCurrentCamera', 'getName', 'getRenderdir', 'getRenderingContext', 'getWinSize', 'link', 'makeCurrent', 'name', 'setCurrentCamera', 'setName', 'setWinSize', 'startFrame', 'unlink', 'update']

Posted: Wed Apr 28, 2004 12:08 pm
by mox
very good work!

I don't test in deep, but all seem to work!

(mdk 9.2; ati 9200; 512 ram; PIV 2.4)


grazie

Posted: Wed Apr 28, 2004 2:26 pm
by Michel
Hey hey!

The big big thank you must go to IanWill for this one! It's good to hear this one finally is tackled!
Thank you all for testing. The problems reported in this thread will be looked at.

With regards,
Michel

Posted: Wed Apr 28, 2004 9:42 pm
by shadow
Is it normal that this build with yablex script generates these messages?:?

Code: Select all

Can't get traceback
warning: name 'sunbg' is used prior to global declaration
ImportError: No module named warnings
And what is wrong? The script halts on:
return preview_file.name

Any ideas?

Posted: Wed Apr 28, 2004 9:46 pm
by Napoleon
Private napoleon reporting sir !

No seg fault and no <invalid read error> sir
All correct sir!

Thanks a great deal guys, really i mean it. You are special indeed.
Have some beers on me :P