bf-blender / Windows (2004/05/09)

User-contributed CVS development builds. Please test and give feedback!

Moderators: jesterKing, stiv

Post Reply
gabio
Posts: 0
Joined: Thu Jan 15, 2004 6:41 am
Location: Canada - Québec - Sherbrooke
Contact:

bf-blender / Windows (2004/05/09)

Post by gabio »

Hey! New build...

Why?
Some unwanted bug was left after the 2.33 release... so a 2.33a release is planned in the following week. Ton said: Testing Testing Testing.
So...

relevant Commit to look at:

hos:
Log:
Check that deformer is an armature defore updating the displists
of it's children (gives speed up for alt-A, animation rendering).

kester:
Log:
Mouse Wheel Support for the Game Engine.

This adds "Wheel Up" and "Wheel Down" as choices to the Mouse sensor brick.

blendix:
Log:
Fixed a bug where From Window mapping in perspective view would give strange
results, caused by a little typo. The solution was proposed by bjornmose.

ton:
Log:
Apparently the sequencer has its own audiosystem, so the change I did
for init sound only when needed, was not catched by sequencer.

Somehow, however, the SND_xxx library needs to be set when using the
sequencer... so, here a patch!

kester:
Log:
Fix for bug #945 getVertexArrayLength(x) returns different values on different runs of the game engine.
http://projects.blender.org/tracker/ind ... 9&atid=125

The material buckets were being sorted by pointer (ie their location in memory.)

Also fixed find shared verticies.

siredude:
Log:
Removed the printf that was causing about 50000
"Color depth R=8 G=8 B=8" lines.....
Log:
Added Camera Fly Mode (Shift F) to the toolbox.

Kent

kester:
Log:
Fix Bug #1243: http://projects.blender.org/tracker/?fu ... 9&atid=125

Use external velocity (velocity set by the game engine - not the physics engine) for Motion Actuators.

ton:
Log:
Member added, who wasnt included due to wrong subscription.(txt file)
Log:
fix for bug #1226:
With subsurf level 0, in editmode, the hidden faces where still drawn.
Was caused because subsurfing code then is skipped.
Log:
fix for bug #1223

Bump was inverted in previewrender for planar preview.
Log:
bug fix #1237

A too strict pointer check caused action browsing in action-window not
to work when object didn't have action yet.
Log:
Fix related to audio crash. Made the check for when audio_init runs a
tinsy bit more strict. Now it did it for each ALT+A play anim.

I leave the debug print in still, for testing.
Log:
potential fix for windows crash when it encounters file dates beyond
the nice limited unix range (1970-2034 or so).
Zr will check!

aphex:
Log:
- switched a strcat and strcpy pair... doh! (well spotted b-ix!)
- appended "./blender" to %HOME% return for Win32. Is consistant now
with the other returns for Win.

ton:
Log:
Improved three tooltips:
- Material Shadow and Traceable still mentioned old shadowbuffer methods
- AngMap option in World mapping has better explanation
Log:
When pressing ALT+A, i noticed other windows advance 1 frame. This is
caused by swapbuffers system, which redraws the other windows when the
CFRA timer already advanced 1 frame.

Added an extra redraw to fix this. Could fix report #964, will wait for
JWalton to verify.
Log:
Added two more mapping types to World buttons for sky render.

"Sphere": spherical mapping for a 360 degree panorama
"Tube": cylindrical mapping for a 360 degree panorama

Both mappings by default do only the sky (upper) hemisphere. The color
below is same as regular Horiz and Zenith colors, useful for setting
an AO effect.

Sample pics:
http://www.1000skies.com/fullpanos/index.htm (commercial)
Log:
Num-slider buts and CTRL didn't work when range was > 1.0
Log:
Fixed little annoyance that caused previewrender not to clear sometimes.
For example when no Texture exists, and you switch from material to
texture buttons.
Log:
As we dutchies say: "Now breaks my clog!"

Apparently the 'sync' option for alt+a anim playback *can* run without
the sound_init_audio() being called, but it cannot play audio... o_O
(For who doesnt know, syncing was coded abusing audio timing)

Anyhoo. This also fixes #1267, reporting that 'sync' option didnt work.
Log:
fix for bug #1263

When zooming in extreme, scaling things outside of view caused dashed
line to be wrong... it used shorts for screencoords. Made it a float.
Log:
Added tooltips for Lattice editbuttons.
Log:
Bug #1264

When in texture buttons, selecting Lamp, Camera or other Object didnt
update the shown texture correctly. Now it nicely switches.
Log:
Bug fix for AO and Soft shadow:

When Traceable was off, and the rendered pixel outside Octree, the
intersection was going wrong. Due to the many samples taken not easy
to see, but certainly causing extra noise.

--------
That's all

a new build is available
Last edited by gabio on Wed May 12, 2004 12:23 am, edited 1 time in total.

klopes
Posts: 5
Joined: Wed Oct 16, 2002 10:33 am

Post by klopes »

WOWWW :shock: What a fixing list, so people will notice the difference Thanks both, coders and compilators!

env
Posts: 12
Joined: Thu Oct 17, 2002 9:58 pm
Location: Italy
Contact:

Post by env »

That's great, gabio, thanks for all the new builds. :D
I noticed a strange thing, but I'm not sure if this is a bug: with the new API we can add vertices, subdivide faces or delete them also with rvk applied to the mesh, and this is great; but if I try to join a different mesh to a rvk mesh (first select the no-rvk mesh, then the rvk mesh), the result keep the rvk but all the faces of the mesh are instantly deleted. The vertices anyway have the rvk positions correctly applicated. Any hint about this?

Env

Manuel
Posts: 56
Joined: Wed Oct 16, 2002 12:48 am
Location: Italy
Contact:

Post by Manuel »

It seem it's fixed this bug too:

http://www.blender.org/pipermail/bf-pyt ... 01312.html

right?

Thanks,

Manuel

patricks
Posts: 0
Joined: Sat May 01, 2004 1:27 pm
Location: Baleares Spain

Re: bf-blender / Windows (2004/05/09)

Post by patricks »

gabio wrote:Hey! New build...

Why?
Some unwanted bug was left after the 2.33 release... so a 2.33a release is planned in the following week. Ton said: Testing Testing Testing.
So...

relevant Commit to look at:

hos:
Log:
Check that deformer is an armature defore updating the displists
of it's children (gives speed up for alt-A, animation rendering).

kester:
Log:
Mouse Wheel Support for the Game Engine.

This adds "Wheel Up" and "Wheel Down" as choices to the Mouse sensor brick.

blendix:
Log:
Fixed a bug where From Window mapping in perspective view would give strange
results, caused by a little typo. The solution was proposed by bjornmose.

ton:
Log:
Apparently the sequencer has its own audiosystem, so the change I did
for init sound only when needed, was not catched by sequencer.

Somehow, however, the SND_xxx library needs to be set when using the
sequencer... so, here a patch!

kester:
Log:
Fix for bug #945 getVertexArrayLength(x) returns different values on different runs of the game engine.
http://projects.blender.org/tracker/ind ... 9&atid=125

The material buckets were being sorted by pointer (ie their location in memory.)

Also fixed find shared verticies.

siredude:
Log:
Removed the printf that was causing about 50000
"Color depth R=8 G=8 B=8" lines.....
Log:
Added Camera Fly Mode (Shift F) to the toolbox.

Kent

kester:
Log:
Fix Bug #1243: http://projects.blender.org/tracker/?fu ... 9&atid=125

Use external velocity (velocity set by the game engine - not the physics engine) for Motion Actuators.

ton:
Log:
Member added, who wasnt included due to wrong subscription.(txt file)
Log:
fix for bug #1226:
With subsurf level 0, in editmode, the hidden faces where still drawn.
Was caused because subsurfing code then is skipped.
Log:
fix for bug #1223

Bump was inverted in previewrender for planar preview.
Log:
bug fix #1237

A too strict pointer check caused action browsing in action-window not
to work when object didn't have action yet.
Log:
Fix related to audio crash. Made the check for when audio_init runs a
tinsy bit more strict. Now it did it for each ALT+A play anim.

I leave the debug print in still, for testing.
Log:
potential fix for windows crash when it encounters file dates beyond
the nice limited unix range (1970-2034 or so).
Zr will check!

aphex:
Log:
- switched a strcat and strcpy pair... doh! (well spotted b-ix!)
- appended "./blender" to %HOME% return for Win32. Is consistant now
with the other returns for Win.

ton:
Log:
Improved three tooltips:
- Material Shadow and Traceable still mentioned old shadowbuffer methods
- AngMap option in World mapping has better explanation
Log:
When pressing ALT+A, i noticed other windows advance 1 frame. This is
caused by swapbuffers system, which redraws the other windows when the
CFRA timer already advanced 1 frame.

Added an extra redraw to fix this. Could fix report #964, will wait for
JWalton to verify.
Log:
Added two more mapping types to World buttons for sky render.

"Sphere": spherical mapping for a 360 degree panorama
"Tube": cylindrical mapping for a 360 degree panorama

Both mappings by default do only the sky (upper) hemisphere. The color
below is same as regular Horiz and Zenith colors, useful for setting
an AO effect.

Sample pics:
http://www.1000skies.com/fullpanos/index.htm (commercial)
Log:
Num-slider buts and CTRL didn't work when range was > 1.0
Log:
Fixed little annoyance that caused previewrender not to clear sometimes.
For example when no Texture exists, and you switch from material to
texture buttons.
Log:
As we dutchies say: "Now breaks my clog!"

Apparently the 'sync' option for alt+a anim playback *can* run without
the sound_init_audio() being called, but it cannot play audio... o_O
(For who doesnt know, syncing was coded abusing audio timing)

Anyhoo. This also fixes #1267, reporting that 'sync' option didnt work.
Log:
fix for bug #1263

When zooming in extreme, scaling things outside of view caused dashed
line to be wrong... it used shorts for screencoords. Made it a float.
Log:
Added tooltips for Lattice editbuttons.
Log:
Bug #1264

When in texture buttons, selecting Lamp, Camera or other Object didnt
update the shown texture correctly. Now it nicely switches.
Log:
Bug fix for AO and Soft shadow:

When Traceable was off, and the rendered pixel outside Octree, the
intersection was going wrong. Due to the many samples taken not easy
to see, but certainly causing extra noise.

--------
That's all

Download Me!!!!!
:roll: I testet 2.33a
and when you render the 2.33 testfil "meterbols" you get blak stipes.
The AO is better now but it is stil noisier then your bf blender (2004/16/04).It is hard to notic but when you put skay textur for the AO I notict a difrenc .In your bf blender(2004/16/04) when you disabelt ray in the renderbuttons you stil haf AO light just like a normel hemilight but better :D .In blender 2.33 and 2.33a when you du that ther is no ligt :( .Is it posibel to get it back agen?It saves alot of tim when you ar testing ligt intenseti or other things.The export of HDRI or normel images to yafray in the world setings dont work .
thenk you for your worg :wink:

ada89
Posts: 0
Joined: Sat Sep 06, 2003 10:26 pm

Re: bf-blender / Windows (2004/05/09)

Post by ada89 »

patricks wrote: The export of HDRI or normel images to yafray in the world setings dont work .
Try puting something like c:\ before the image address if you are using windows.

patricks
Posts: 0
Joined: Sat May 01, 2004 1:27 pm
Location: Baleares Spain

Re: bf-blender / Windows (2004/05/09)

Post by patricks »

ada89 wrote:
patricks wrote: The export of HDRI or normel images to yafray in the world setings dont work .
Try puting something like c:\ before the image address if you are using windows.
:D I did whot you told my and it works.Thanks

teachtech
Posts: 60
Joined: Wed Oct 16, 2002 12:58 am

Post by teachtech »

Any idea on when the "save runtime" feature and settings will come back?

Post Reply