bf-blender / Linux (2004/07/15)

User-contributed CVS development builds. Please test and give feedback!

Moderators: jesterKing, stiv

Post Reply
blendix
Posts: 51
Joined: Wed Oct 16, 2002 1:00 pm

bf-blender / Linux (2004/07/15)

Post by blendix »

Build of current bf-blender for Linux glibc-2.3.2. This includes Weighted Creases, Particle Interaction, Save Runtime, Yafray using Plugin, LSCM UV Unwrapping, Color Picker, many new Python Scripts, Wipe Sequence Effect, Ramp Shader, ... .

Latest new features, added by intrr (implementation), guitarGeek (UI) and ideasman (idea):
http://www.blender.org/pipermail/bf-ble ... 02006.html
http://www.blender.org/pipermail/bf-ble ... 02009.html

For a more extensive summary, read the b3d.org page or the raw commit logs:
http://www.blender3d.org/cms/Changes_si ... 319.0.html
http://www.blender.org/pipermail/bf-blender-cvs/

Download (4.4MB):
http://users.pandora.be/blendix/blender ... 15.tar.bz2

I've also compiled yafray binaries, not sure how they are supposed to be packaged. The package now includes bin/, lib/ and etc/ dirs. Copying the contents to their /usr/local/ equivalents did the trick for me. Disable "xml" in the Yafray panel to see the image being rendered step by step in the render window.

Download (485KB):
http://users.pandora.be/blendix/blender ... 15.tar.bz2
Last edited by blendix on Tue Jul 20, 2004 11:15 pm, edited 1 time in total.

Apollux
Posts: 0
Joined: Sun Mar 02, 2003 4:27 am
Location: Santo Domingo, Dominican Republic

Post by Apollux »

I'm having troubles to start the program, same error with both Blender and Blenderplayer.
./blender: error while loading shared libraries: libsmpeg-0.4.so.0: cannot open shared object file: No such file or directory
I have allways used the dynamic version of Blender, but this is the first time I get such error.

RH9, P4 2.4 GHz, NVidia GFx4 Ti 4200.

OTO
Posts: 60
Joined: Wed Oct 16, 2002 8:51 pm
Contact:

Post by OTO »

Hello

It works perfectly well for me:
Yaf-Ray, plug-in's, LSCM...alll

Great build
Thank you very much!!!

Mandrake 10 Official

blendix
Posts: 51
Joined: Wed Oct 16, 2002 1:00 pm

Post by blendix »

./blender: error while loading shared libraries: libsmpeg-0.4.so.0: cannot open shared object file: No such file or directory
The OpenAL lib on my computers had some unneeded dependencies. I uploaded a new build that should fix this.

It also seems International fonts are disabled by default, and not included in this build. Don't have time to do a rebuild now though.

Apollux
Posts: 0
Joined: Sun Mar 02, 2003 4:27 am
Location: Santo Domingo, Dominican Republic

Post by Apollux »

Seems that there are some more weird dependencies left

The previous error is gone, but now I got this one instead:
./blender: error while loading shared libraries: libasound.so.2: cannot open shared object file: No such file or directory
Trying to start with './blender -noaudio' gives the same error.

blendix
Posts: 51
Joined: Wed Oct 16, 2002 1:00 pm

Post by blendix »

Updated build with International fonts and hopefully no unexpected dependencies. Thanks for your patience.

Apollux
Posts: 0
Joined: Sun Mar 02, 2003 4:27 am
Location: Santo Domingo, Dominican Republic

Post by Apollux »

:P The built is opening and looking good.

There are some issues with keyboard control inside the Game engine (on some games keyboard control is actually worse than it was on 2.33a).

International fonts are working really fine, without the bugs found on 2.33a. (¨Save runtime...¨ option needs to be translated).

I specially like the wire outline for selected objects while in shaded view.

I'll keep testing and posting.
Thanks for yor patience.
No problem man, specially because we are playing on the same team: http://www.blender3d.com/cms/Project_li ... 0.html#651
(I'm the guy directly below you on the linux team members list). 8)

Post Reply