bf-blender / Windows (2004/09/26)

User-contributed CVS development builds. Please test and give feedback!

Moderators: jesterKing, stiv

Doogs
Posts: 41
Joined: Wed Oct 16, 2002 1:16 am

Post by Doogs » Sun Sep 26, 2004 9:00 pm

Yeah well all these bugs, you now see why its a testing build and not official ;)

RonC

ElBarto
Posts: 0
Joined: Fri Jun 11, 2004 3:24 pm
Location: Berlin
Contact:

Post by ElBarto » Sun Sep 26, 2004 10:17 pm

When Cilp Z Buffer is on there are some problems with selecting edges, most of them couldn't be selected. If Cilp Z Buffer off anything works fine.

Falgor
Posts: 0
Joined: Tue Sep 07, 2004 7:19 pm
Location: Israel

Post by Falgor » Mon Sep 27, 2004 12:49 am

Thank you for these new features. So cool, guys! :o
God bless you. :)

oyster
Posts: 0
Joined: Sat Mar 29, 2003 4:41 pm
Contact:

Post by oyster » Mon Sep 27, 2004 4:37 am

Thank you for the new features. I think the "Subdivision surface draw" is a big approach to iso lines in SILO :lol: :
Iso Lines >>

Silo's subdivision surfaces now use iso line display and selection,. This means that only the edges descended from edges on the control mesh show up on the subdivided mesh.

Moreover, you can select the iso edges/faces/vertices directly and edit your subdivided mesh directly from the iso surface. Several options allow you to customize the iso line functionality.
Image

thoro
Posts: 15
Joined: Thu Oct 17, 2002 10:20 am
Location: Berlin, Germany
Contact:

Post by thoro » Mon Sep 27, 2004 10:07 am

Wow, the new Zbuffer clipped selection mode is very useful - and the Optimal draw subsurfs mode looks better than ever. Thank you so much!

pildanovak
Posts: 18
Joined: Fri Oct 25, 2002 9:32 am
Contact:

Post by pildanovak » Mon Sep 27, 2004 2:15 pm

the additions are great, especially the new select modes.
But somtimes the button for z-buffer selection disappers(??)

jesterKing
Site Admin
Posts: 207
Joined: Fri Oct 18, 2002 12:48 pm
Location: Finland

Post by jesterKing » Mon Sep 27, 2004 2:18 pm

pildanovak wrote:the additions are great, especially the new select modes.
But somtimes the button for z-buffer selection disappers(??)
The zbuffer selection is available only in solidmode

/Nathan

pildanovak
Posts: 18
Joined: Fri Oct 25, 2002 9:32 am
Contact:

Post by pildanovak » Mon Sep 27, 2004 2:18 pm

another bug- edge-loop select in edge mode- if you select 2 colinear loops, also the edges which connect them are selected.


... and the same with poly loops

Crawl
Posts: 0
Joined: Thu Aug 05, 2004 3:18 pm
Contact:

Post by Crawl » Mon Sep 27, 2004 7:35 pm

Hmm i've found something.

Added 2 Arealights, both the same setup: Shadows True, Samples 2, Noise.
But one of the Arealight shadows isnt noised. :shock:

Look:
Image

Yfkar
Posts: 0
Joined: Thu Feb 19, 2004 8:32 pm

Post by Yfkar » Mon Sep 27, 2004 9:57 pm

This looks really promising! This is what I've been waiting for! It's pretty difficult to select an edge in the optimal subsurf mode but that doesn't matter at this stage. Wooooo!

SamAdam
Posts: 0
Joined: Thu Mar 04, 2004 1:28 pm
Contact:

Post by SamAdam » Tue Sep 28, 2004 12:34 am

how about adding more information to the transform properties based on selection method:
face: midpoint or meanpoint, area
edge: two endpoints, length

yamyam
Posts: 16
Joined: Mon Oct 14, 2002 8:39 am

Post by yamyam » Tue Sep 28, 2004 3:52 am

UV/FaceSelectMode works wrong, some faces are flipped. AFAIK, this problem has already been in 9/24 bf-windows build.

I don't know that ton(or other coder) is going to fix it or remove that mode, but I report it.

*** Edit ***

Sorry, I'm stupid. It's due to see the new monkey. :oops:

*** Edit ***

Dani
Posts: 143
Joined: Fri Oct 18, 2002 8:35 pm

Post by Dani » Sat Oct 02, 2004 4:18 pm

When I select four edges around one face, blender selects the face... same thing if I select four vertices... ie. if I extrude i'll extrude the face and not the (edges/verts)

This is not how I expect it to behave... if a select four edges and extrude them, I expect it to extrude the edges, not the face... I think this is the whole point in having edge/face distinction... no?

Or did i miss something?

Dani

Bellorum
Posts: 0
Joined: Wed Jan 21, 2004 3:27 pm

Post by Bellorum » Sat Oct 02, 2004 4:35 pm

When I select four edges around one face, blender selects the face... same thing if I select four vertices... ie. if I extrude i'll extrude the face and not the (edges/verts)
You're not alone:) It's been brought up. There's also a proposal by broken here:
http://mke3.net/blender/etc/mesheditrewrite/mesh01.html
There's no such thing as democracy. There's only the tyranny of one, and the tyranny of many.

Dani
Posts: 143
Joined: Fri Oct 18, 2002 8:35 pm

Post by Dani » Sat Oct 02, 2004 10:22 pm

oh allright ;)

I guess the "Shift+R and friends selection doesn't work in zbuff mode" problem is a known one too...

what else? I found display glitches from place to place...
ie. when, in edit mode, you do an "Edge: Delete" in the F9 panel the seam is still draw until you "tabtab".

Creases seem to be working wrong though i need further testing...

Finally theres an ultimate (but big) problem due to the multiple selection modes.
I made a proposal here

http://www.blender.org/modules.php?op=m ... pic&t=4678

the discussion ended short when eric told me the three selection modes could be active at a time... I was sooo happy! But acutally, it's quite messy... selections mix up! This needs to be fixed!

Dani

Post Reply