BF-Blender / Linux 64-bit ( 2004-10-17)

User-contributed CVS development builds. Please test and give feedback!

Moderators: jesterKing, stiv

Posts: 76
Joined: Wed Oct 16, 2002 12:53 am
Location: Valencia-Spain-Europe

Post by Caronte »

somebody has a speed comparison between the version of 64 and 32 bits?
"Some Day, All Will Be Digital"

Posts: 0
Joined: Mon Apr 05, 2004 1:26 pm

Post by leope »

My "test":

sorry ... in Italian. ... c&start=15

1. W98 (slower than XP) blender 2.35 optimized

2. Linux FC2 x86_64 , blender 2.35 official version

3. Linux FC2 x86_64, my own (cvs) compiled blender

The scene is at page 1.


Posts: 0
Joined: Fri Nov 05, 2004 7:42 pm

Post by okchoir »

OK, have built up machine with FC3 and compiled Blender again. I would expect it to be 'better' than my last 64-bit buid because of the modern gcc compiler.

Let me know if it works/doesn't work for you! ... 041112.bz2

Build date : 2004-11-12
This works on my machine. Not a thorough test, yet.
AMD64 3400+, SUSE 9.2

I am trying to compile my own test build of 64-bit blender with scons. [sympathy]Brave Newbie[/sympathy] I see already that config.opts has to be tweeked. Has anyone succeeded in SUSE distro?
Ars Longa Vita Brevis
loosely, "Life is short, but art is long"

Posts: 0
Joined: Fri Nov 05, 2004 7:42 pm

Post by okchoir »

Linux 64-bit Blender...

[stunned]Brave Newbie[/stunned] WOW! IT COMPILED!
Very little tweaking in config.opts. Here's what I changed:


Changed to:
SDL_INCLUDE = ['/usr/include/SDL']
SDL_LIBPATH = ['/usr/lib']

I did get a lot of messages that I don't understand:

/usr/lib64/gcc-lib/x86_64-suse-linux/3.3.4/../../../../x86_64-suse-linux/bin/ld: skipping incompatible /usr/lib/libgcc_s.sowhen searching for -lgcc_s

Can anyone interpret this?
Ars Longa Vita Brevis
loosely, "Life is short, but art is long"

Posts: 0
Joined: Mon Apr 05, 2004 1:26 pm

Post by leope »

On fc2 x86_64 I edit the SConstruct file only.

Code: Select all

if sys.platform == 'linux2' or sys.platform == 'linux-i386':
	use_international = 'false'
	use_gameengine = 'true'
	use_openal = 'false'
	use_fmod = 'false'
	use_quicktime = 'false'
	use_sumo = 'true'
	use_ode = 'false'
	use_buildinfo = 'true'
	build_blender_dynamic = 'true'
	build_blender_static = 'false'
	build_blender_player = 'true'
	build_blender_plugin = 'false'
	release_flags = ['-O2']
	debug_flags = ['-O2', '-g']
	extra_flags = ['-pipe', '-funsigned-char']
	cxxflags = []
	defines = []
	warn_flags = ['-Wall', '-W']
	window_system = 'X11'
	platform_libs = ['m', 'util', 'stdc++']
	platform_libpath = []
	platform_linkflags = ['-pthread']
	extra_includes = []
	# z library information
	z_lib = ['z']
	z_libpath = ['/usr/lib64']
	z_include = ['/usr/include']
	# png library information
	png_lib = ['png']
	png_libpath = ['/usr/lib64']
	png_include = ['/usr/include']
	# jpeg library information
	jpeg_lib = ['jpeg']
	jpeg_libpath = ['/usr/lib64']
	jpeg_include = ['/usr/include']
	# OpenGL library information
	opengl_lib = ['GL', 'GLU']
	opengl_static = ['/usr/lib64/libGL.a', '/usr/lib64/libGLU.a']
	opengl_libpath = ['/usr/lib64', '/usr/X11R6/lib64']
	opengl_include = ['/usr/include']
	# SDL library information
	sdl_env.ParseConfig ('sdl-config --cflags --libs')
	sdl_cflags = sdl_env.Dictionary()['CCFLAGS']
	sdl_include = sdl_env.Dictionary()['CPPPATH']
	sdl_libpath = sdl_env.Dictionary()['LIBPATH']
	sdl_lib = sdl_env.Dictionary()['LIBS']
	# SOLID library information
	solid_lib = []                                              # TODO
	solid_libpath = []                                          # TODO
	solid_include = ['#extern/solid']
	qhull_lib = []                                              # TODO
	qhull_libpath = []                                          # TODO
	qhull_include = ['#extern/qhull/include']
	# ODE library information
	ode_lib = ['ode']
	ode_libpath = ['#../lib/linux-glibc2.2.5-i386/ode/lib']
	ode_include = ['#../lib/linux-glibc2.2.5-i386/ode/include']
	# Python library information
	python_lib = ['python%d.%d' % sys.version_info[0:2]]
	python_libpath = [sysconfig.get_python_lib (0, 1) + '/config']
	python_include = [sysconfig.get_python_inc ()]
	python_linkflags = Split (sysconfig.get_config_var('LINKFORSHARED'))
	# International support information
	ftgl_lib = ['ftgl']
	ftgl_libpath = ['#../lib/linux-glibc2.2.5-i386/ftgl/lib']
	ftgl_include = ['#../lib/linux-glibc2.2.5-i386/ftgl/include']
	freetype_env.ParseConfig ('pkg-config --cflags --libs freetype2 2>/dev/null || freetype-config --cflags --libs 2>/dev/null')
	freetype_lib = freetype_env.Dictionary()['LIBS']
	freetype_libpath = freetype_env.Dictionary()['LIBPATH']
	freetype_include = freetype_env.Dictionary()['CPPPATH']
	gettext_lib = []
	gettext_libpath = []
	gettext_include = []
	# OpenAL library information
	openal_lib = ['openal']
	openal_libpath = ['/usr/lib64']
	openal_include = ['/usr/include']

changed the search paths

...lot of warnings and probably an unstable executable but for my hobby it's good :)


PS: I compile yafray also to use it as plugin.

Posts: 0
Joined: Sat Aug 14, 2004 5:57 am

...what about 2.36?

Post by waldotim »

Has anyone compiled Blender 2.36 for FC3 x86_64? I can get it to compile, but the Python stuff won't work, which, ironically, is why I got the source code and compiled it to begin with. Your version you posted earlier works fine, python included. :-?


Posts: 0
Joined: Tue Jan 18, 2005 2:33 am

Blender 2.26 x86_64 FC3

Post by ArkyMedia »

I have compiled successfully a Blender 2.36 for FC3 and Athlon64. Everything works, even some things that didn't in the official version. I haven't figured out how to load plug-ins though, maybe a bug? It is WAY more stable than the official release too. I would upload it for testing but I don't have a website :cry: . Any ideas in how to distribute, that is, if anyone is intersted.

Test rendering showed an unbelievable CONSISTENT!!! speed INCREASE!!! of ~42%!!!. My blenderizing friend was amazed as we rendered the same thing side-by-side and mine completed before his was half done! He also has an Athlon64, but runs the official windoze version of 2.36. After seeing this, you can't make me believe that the 64-bit doesn't yield that much performance increase. If you want, I can find my paper with the exact rendering times.

Posts: 0
Joined: Thu Aug 05, 2004 8:19 am

Post by grizzly69 »

ArkyMedia - I would be interested in your build. Could you email it to me at:

Or tell me how you did it and what you had to modify in the files. I just got my FC 3 AMD64 up and running. I just need to get the apps I like to use working now.

Posts: 0
Joined: Tue Jan 18, 2005 2:33 am

amd64 fc3

Post by ArkyMedia »

I will get it to you as soon as I can determine which files to package. I think I know which ones. I will send it as blender-236-linux64.tar.bz2. Excuse my unconventional naming. I would appreciate feedback on the stability, especially when using SubSurf=>3, Yafray export, and plug-in loading. I showed this version to someone who uses Blender for their business, and he was jealous of the speed at which it ran. You don't want to try to duplicate my results on the build, I had to modify my system files to a degree that I had to reinstall FC3 afterward. I could probably have avoided this if I had taken the time to build a script to reverse the effects.

Posts: 0
Joined: Thu Aug 05, 2004 8:19 am

Post by grizzly69 »

Cool, only yafray is not working with blender on my system right now. I installed the i386 rpm for yafray and could call it from a command line, but when I try to use it in blender (i386.rpm) I just get a black render window. and so far I haven't been able to call up the console to check. When I get home tonight I will try to run blender in a terminal window to see whats up with yafray. You wouldn't by chance have a 64 bit compile of yafray? I tried to compile it and got some sort of lights linking error when I did "make" on it.

Posts: 0
Joined: Thu Aug 05, 2004 8:19 am

Post by grizzly69 »

DUH!! I didn't specify an output directory for yafray, thats why it didn't work.
Quick question: Does Blender 64 see the pythonpath? What I have now doesn't see it because I believe its looking in the /usr/lib dir not the /usr/libs64 dir. I am going to set up my pythonpath later to see if it can use the 64 bit libs.

Posts: 0
Joined: Mon Jun 09, 2003 11:16 pm

Post by Marty_D »

I would be interested to hear what happens when you set 3D-Now flags? Anyone tried this with the 64 bit?

Posts: 0
Joined: Thu Aug 05, 2004 8:19 am

Post by grizzly69 »

Spoke too soon on yafray. It seems I can run it from a terminal, but when Blender tries to use it. I get:
Yafray found at : /usr/bin/
Could not open file

But as root it works fine. I checked permissions, users should be able to execute it.

Oh, to make this part of the thread, the 64 bit compile Happy1776 posted worked fine. It found Python just fine while the regular Blender couldn't. But this is 2.34 not 2.36. So I would still be interested in your build.

I haven't done speed comparisons yet but I will soon.
Last edited by grizzly69 on Wed Jan 19, 2005 11:08 pm, edited 1 time in total.

Posts: 0
Joined: Tue Jan 18, 2005 2:33 am


Post by ArkyMedia »

I'm fairly new to Blender and haven't used python. I haven't had much success on any trys with it. I will install full python and configure blender for it and try again. I have tried compiling yafray in 64-bit, but without success. School just started this semester so I have less time to work on compiling stuff. Grizzly69, I will try to e-mail it from school, my dial-up is no good for large downloads.

Posts: 0
Joined: Thu Aug 05, 2004 8:19 am

Post by grizzly69 »

I compiled my own blender 2 ways:

1. Didn't change a thing (references were to /usr/lib not /usr/lib64) ran scons in the blender directory.

2. Changed all references in the config.opts to /usr/lib64 and ran scons again. Config.opts wasn't there until I ran scons the first time.

The results were not what I expected. Warnings whizzed by left and right. Then after awhile scons said

scons: building terminated because of errors.

But I looked in the directory and there was an executable. And it worked.

I have not had time to test it out for stability, but it ran and rendered (no speed tests yet)

An odd thing is all the 64 bit builds I built/ran can see the python install, but the precompiled blender rpm I installed doesn't. What can I do to fix this?

And I still have the yafray problem of not working unless I'm root.

Question: When scons was finished compiling blender, what did it say?

Completed with error? And what all files was it supposed to make? All I got was and executable.

Post Reply