Page 1 of 2

bf-blender / Windows (2004/11/22)

Posted: Mon Nov 22, 2004 10:26 pm
by gabio
well, 2.35 is out. But it's still not perfect. there is some blabla about lauching something even more stable(even if 2.35a is out. there are some bug left) in a near future(talk about weeks). So as this is not worser than the official release I suggest to actually work on something with it. As the flood of report after the release was mainely because now pp are actualy using it for real.
thanks for your time.

Build with MSVC 7 using scons system.
Relevant feature:
-bugfixes : 1843, 1859, 1864, 1865, 1838, 1842
-Disabled B-B to goto circle selecting on armature edit mode.
-game engine bugfixes: 1788, 1799, 1600,

Bugreports keep coming in... including real bad one.

- Deformed mesh didnt give correct 'orco' anymore on render
- Mesh editmode, "Separate loose parts", crash on empty mesh (no verts)
- Global undo; buttons sending redraw events gave extra undo push called
"Make single user or local". That latter was wrong event handling for
REDRAW event, harmless, until now :)

First one is a real showstopper... bah!

- bug fix #1843 ... 9&atid=125

function find_basis_mball() sometimes returned duplicated MetaBall as basis mball, which caused crash of Blender. It happened only when basis MBall object was used for duplication. It was propably caused by some changes in duplicator code.

Fix for strange (showed in windows only) error that delivered flat curve
deforms by default. Proved to be a [3] array passed on to function needing
[4] array. Bad bad...
Thanks Ole for finding it! :)

Bug fix #1859

Appending or Linking data from other file always cleared scene scriptlinks,
due to having 1 line of code just on wrong location... is bug since 2.25,
so finally something again I didn't recently break in working code :)

Fix for #1864

In transform code the old global G.totvertsel was still used to define
centroid (editmesh). Replaced with nice local variable.

Bug #1865

On appending in posemoding, Blender could crash.
Found out the new 'select appended' also sets the 'active base/object'.
This isn't OK on that level of the code, 'active' exists (and needs to be
set) on UI code level in src/, not in the middle of file reading function.

Also removed weird negative bitflag that enforced 'select appended' to
be default. If you want that, set the flag itself in do_versions or so.
In my opinion it is best saved in .B.blend instead. Another time...

Disabled B-B to goto circle selecting on armature edit mode.

Bug fix #1838

AO option "Use sky" or "Use tex" now also take option "Use distances" into
account, so you can control shades of AO better then.

Fix stereo window creation

Fix for bugs: 1788 (forces) and 1799 (python delattr on game objects)
Use Polytope collision for faster mesh intersection tests, so SOLID can actually use that qhull lib now.

Bug fix, irc report.

Move to layer buttons, using SHIFT+hotkeys to set button values and use
mouse to press OK undid the last change, this due to active flag hanging
on that button. It now clears hotkey active flags on mouseclick first.

Fix for bug 1600: alpha sort doesn't work on linked (alt-d) objects

Three cases of unitialized variables found.
Hopefully it fixes the black scanlines error, as reported in #1842, but
need MSVC compiler to test it. ;) (I compiled with msvc)

Oops, just a little initialize too much :)
Previous commit caused vertex color not to work.

Bugfix on irc report;

Static-animated particles didn't recalculate on render
when used for duplicators (did work for halos). Allows material/texture ipo
for animated motion.
A new build is available

Posted: Tue Nov 23, 2004 2:22 am
by poutsa
Possible BUG? i am not sure if this is a bug!

I use the Knight Blend file from the 2.35 Demo Test files.

-open in Blender the "Knight Blend file" as example and go to frame 197
-Then in the Render Buttons F10 Press "Edge" and set the edge Intensity to Eint:255
-Then choose NTSC as example and RENDER

In the render Image you can see trough the Sword the hidden edge Wire lines...from Characters my Question is this Normal or is this a bug???????

Vassilios Bouker

Posted: Tue Nov 23, 2004 7:30 am
by @ner
many thanks gabio (i needed the ocro bug fix btw)

Posted: Tue Nov 23, 2004 10:04 am
by bleen

Posted: Tue Nov 23, 2004 1:19 pm
by bjornmose
thanks for hosting a build,
would be a nice habbit to give

[ ] msvc6, [ ] msvc7 , [ ] gcc/cygwin

Build System:
[ ] Projects, [ ]Scons, [ ]Makefile

along with the build.
( helps to reproduce reported bugs )

Posted: Tue Nov 23, 2004 1:58 pm
by arangel
Great to see the Game Engine force bug solved. Thank you, Kester!

Posted: Tue Nov 23, 2004 3:48 pm
by tester
thank you Kester :D for Game Engine bug fixing!

Posted: Tue Nov 23, 2004 4:25 pm
by gabio
bjornmose wrote:gabio,
thanks for hosting a build,
would be a nice habbit to give

[ ] msvc6, [ ] msvc7 , [ ] gcc/cygwin

Build System:
[ ] Projects, [ ]Scons, [ ]Makefile

along with the build.
( helps to reproduce reported bugs )
doh! :x
yea, kind of forgot to o for the past month. i'll include it again.
see first post.
i'm using msvc 7/scons. As i saw official one are made with msvc6. i hope it's not that much of a problem. (edit) saw in my email, official ones are msvc 7 now.

Posted: Tue Nov 23, 2004 4:56 pm
by adrian
A couple of thing I noticed:

Bugs or my problems? found on windows xp pro-sp2 (amd barton xp3200,gforce 440,512ram,)

1. Zoom mousewheel action - on occasion stops working, usually in large scenes with large no. of objects. Pad keys(+,-) still work.

2. Outliner selection (highlighted blue) & w key doesn't work.

3.New AO (gabio 22/11/04 build) using unified renderer returns excessive white patches.

4. Rendering cashes program completely on occasion, seems to be with large meshes and no manifold situation or large nurbs model.

Other bugs found but not rechecked recently:
5. Alter texture ( clouds ) then global undo a number of times - program crashes

6. Happened only once:- select an editing ipo for armature screwed up A key ( didn't select all -it played animation preview(alt A action )).


Posted: Tue Nov 23, 2004 8:17 pm
by ElBarto
Again to all:

Better put reproduable bugs into the bugtracker!

Posted: Tue Nov 23, 2004 11:06 pm
by matt_e
adrian wrote: 2. Outliner selection (highlighted blue) & w key doesn't work.
This is not a bug, it was disabled before the release since it was rather hackish and not so usable. It was decided that we need more time to test and review this sort of functionality to get it right the first time (next release perhaps)

Posted: Wed Nov 24, 2004 12:29 am
by Saluk
Yes thanks kester, my game runs pretty well again :)

Posted: Wed Nov 24, 2004 2:31 am
by oyster
Does VC 7==.NET? Do I need to install .NET framework?

Posted: Wed Nov 24, 2004 5:11 am
by gabio
oyster wrote:Does VC 7==.NET? Do I need to install .NET framework?
MSVC 7 is the .net platform, yea. but this does mean you need .net framework. because blender is indepandent and don't use framework libs and functionnality. I'm using it just to compile code. could use msvc 6 and it would not do a difference.

Posted: Wed Nov 24, 2004 1:12 pm
by Samjh
Thanks for the build, Gabio. :D

If there is going to be an updated release, will it be an increment of 2.35 or a fresh 2.36?