bf-Blender / Windows (2005/01/03)

User-contributed CVS development builds. Please test and give feedback!

Moderators: jesterKing, stiv

Post Reply
gabio
Posts: 0
Joined: Thu Jan 15, 2004 6:41 am
Location: Canada - Québec - Sherbrooke
Contact:

bf-Blender / Windows (2005/01/03)

Post by gabio »

A new build, bugfixes and all. Happy 2005 to all.
Note: A new splash to make it an officialy unofficial build.. well you know, a CVS one.. anyway.
Build with MSVC 7 using Scons
-----------------------
Relevant feature:
-bugfixes (2056, 2073, 2047, 2053, 2054, 2083,
-some little change in the game engine.
-all snap operations work for MetaElems

Commit:
-broken
Log:
Simple one - update the selected vertex count after doing a vertex
loop select (Alt B)

Reported by Gimble

-kester
Log:
Set the listener properties correctly.

Log:
Set the sound system listener properties.

Log:
Python methods for camera actuators (thanks snailrose)

Log:
Make Python Matrix/Vector conversions more robust

Log:
PyDoc updates

-aphex
Log:
Bug fix #2056:

Material texture channels 9 & 10 could not be deactivated.

Code used a char instead of a short as flag for this.

-theeth
Log:
Object Constraints weren't relinked correctly when duplicating both the target and the owner.
Bug since 2.35.

Was lost when bug #1307 was fixed in this commit: http://projects.blender.org/viewcvs/vie ... f_format=h
This doesn't seem to bring back the bug (copy full scene didn't update links in constraints).

-eeshlo
Log:
If YFexport directory is not set, it will now attempt to use the temp directory.
(/tmp or $TEMP for win.)

Probably too early still, but now in plugin mode the floatbuffer will be used too,
including postprocessing.

-kester
Log:
Fix loading of non-packed sounds for Linux.

-theeth
Log:
Bug #2073: Red value used instead of Green for World sky (render and preview).

Ton will probably have a good laugh when he'll see what the error was. ;)

-aphex
Log:
Small fix:

- if object mode && G.vd==OB_TEXTURE, drawing mesh objects did not check
object's max drawtype (ie. dt).

Log:
Oops!

Fixed the previous fix :)

(Now checks dt>OB_SOLID instead of dt>OB_SHADED which is max anyway!)

-ton
Log:
Small fixes;

- zbuf; error caused by using unsigned int as counter (while >= 0) in radio
- backbuffer didnt load in initrender (was removed from sky render)
- unitialized variable in envmap.c

Log:
Fix proposed by Brecht; on redraw events to renderwindow, it sets back
the active main window, if that was active before.
We need to track down how to solve this more definite... for example, the
"make active" window command can also pop window to front.

Log:
Bug fix 2047

FileWindow didnt sort the dirs "." and ".." correctly. Now these two are
always first.

Log:
Bug #2053

For normal maps only:
Slider for "nor" mapping in "Map to" panel allowed values for over 1.0 in
preview render (not for render itself, causing confusement).

Log:
Bug fix 2054

Alpha for halos was always added, even when "Add" slider was zero. Fixed.

(also; made BROW define BROW16, to distinguish from int version in
BKE_utildefines.h)

Log:
Bug #2083
Rendering in parts, and ESC from render, didn't check for not-rendered
parts yet. (due to recode of parts stuff)

Log:
Thread render fix; using ray-transp + mirror didnt work...
the face-normal had to be local too...

Log:
Forgot to do .h file for previous commit.

Also fixed three small errors in button declarations, to show three digits

-jiri
Log:
- all snap operations work for MetaElems now
- snap to center creates displist for subsurf mesh
----------------
a new build is available
Last edited by gabio on Sun Jan 09, 2005 1:13 am, edited 1 time in total.

ZanQdo
Posts: 0
Joined: Sun Apr 11, 2004 4:57 am

Post by ZanQdo »

Please can somebody confirm that relative path links don't work? I need this for a project and I posted it in the bug tracker but it works fine for ton :?

adrian
Posts: 21
Joined: Fri Oct 18, 2002 1:31 pm

Post by adrian »

Thanks for the build & happy New Year.

The rgb sliders in shader/texture/colours doesn't update preview window - but is ok for colourband. Run on win xp sp2

All the best.

gabio
Posts: 0
Joined: Thu Jan 15, 2004 6:41 am
Location: Canada - Québec - Sherbrooke
Contact:

Post by gabio »

ZanQdo wrote:Please can somebody confirm that relative path links don't work? I need this for a project and I posted it in the bug tracker but it works fine for ton :?
i tried it here. i could segfault blender in less than 5 minutes. gonna work this bug out.(edit) saw your bugreport and it's not what i'm talking about.
relative linking ismade like this. if you what to move the .blend. don't use relative.

ZanQdo
Posts: 0
Joined: Sun Apr 11, 2004 4:57 am

Post by ZanQdo »

I mean, I have two .blends side by side, one with the real object and the other with the linked one. As soon as I move the folder containing the .blends to other location and I try to open the second .blend (with the linked archive) blender crash. Is that correct or is me doing something not supossed to do?

I'm Working whit two other guys and we move betwen diferent computers, so it would be very annoying to have the exact same directory in each computer (we have different names for our hard drive, not only "C"). So if this ism't available in blender, mabe some one could code it :oops:

gabio
Posts: 0
Joined: Thu Jan 15, 2004 6:41 am
Location: Canada - Québec - Sherbrooke
Contact:

Post by gabio »

ZanQdo wrote:I mean, I have two .blends side by side, one with the real object and the other with the linked one. As soon as I move the folder containing the .blends to other location and I try to open the second .blend (with the linked archive) blender crash. Is that correct or is me doing something not supossed to do?

I'm Working whit two other guys and we move betwen diferent computers, so it would be very annoying to have the exact same directory in each computer (we have different names for our hard drive, not only "C"). So if this ism't available in blender, mabe some one could code it :oops:
ha, ok. i reported. I could crash it too but it's never realy at the same place.

Post Reply