Page 1 of 1

Tuhopuu3 / Linux-amd64 (2005/02/12)

Posted: Sat Feb 12, 2005 9:08 pm
by Dracarys
amd64 optimized - will not run on any other architecture
*prays his first build post works out*
No international support or quicktime; couldn't get those to compile. Game engine enabled.

Posted: Sun Feb 13, 2005 2:42 pm
by johannes
i have no amd64 ;-) but i had also trouble with the international support on linux (32 bit). after looking through the code i get out how to compile it. are you interested?

Posted: Mon Feb 14, 2005 1:52 pm
by Panther
Hi Dracarys, thanks for this !!! :-)

I too run an AMD64 ( using FC3 ), but I keep getting told that libopenal.so can't be found and I can't find an RPM for it... so I was wondering if you would mind doing a build without the game engine ???

Happy1776's builds worked fine ( http://www.blender.org/modules.php?op=m ... pic&t=4823 ), but they weren't Tuhopuu and I'd love to see what's new / different.

<rant>

Tried building with Scons a couple of time but gave-up, as it always found something to fail on. :-s

I think us 64-bit people have to band together and release these testing builds, until someone gives Ton ( or Gabio ) an AMD64 !!! ;-)

If someone can tell me how to get Scons working right, I happily submit some builds.

</rant>

;-)

Posted: Tue Feb 15, 2005 2:32 am
by Dracarys
It's always worked fine for me, just have to disable some stuff (which is disabled by default, I just like as many features as possible; dropping international support was painful, as it's AA fonts were quite nice) that doesn't build properly. IIRC, OpenAL was seperate from the game engine in the config.opts; I'd be happy to rebuild w/o that and post another DL. Atm I'm at a school computer, but I'll try to get a build uploaded within a day or two. Thanks for the feedback!

[edit] johannes, yes, I'd love to have a patch or something for international support. Perhaps you could submit it to tuhopuu's CVS? I'm sure they'd accept it, if you talked to the right person. For now, though, a patch is fine :) Thanks!

Posted: Wed Feb 16, 2005 8:20 pm
by johannes
I think this is a SCons Problem on Linux machines! I don't know if you have the same compile error.

Copy all header files in blender/extern/bFTGL/include to blender/source/blender/ftfont/intern

This is an unaesthetic hack but it worked for me.

Posted: Wed Feb 16, 2005 9:28 pm
by grizzly69
Well, I tried it on my AMD64 FC3 linux, and it doesn't find python, but it runs.

Posted: Thu Feb 17, 2005 2:44 pm
by arangel
What OS supports this build?
How the the game engine performance compared to 32bits compiles?

Posted: Sat Feb 19, 2005 11:17 am
by Panther
Hi Arangel, good to here from you - How's things ???

I'm assuming this build only works on the 64-bit version of Fedora Core 3 ( Linux ), but I've not tried other distros ( as Linux has many )... but maybe someone can inform us otherwise. :wink:

I don't really use Blender's game engine, but if there's a .blend somewhere you want me to try, just post the URL or something. :)

After Johannes' input, I'm gonna give Scons another shot over the weekend ( hopefully ), so I guess I'll be posting again soon - All being well it won't be another <rant> next time !!! :D

Posted: Sun Feb 20, 2005 11:02 pm
by Dracarys
Panther wrote:I'm assuming this build only works on the 64-bit version of Fedora Core 3 ( Linux ), but I've not tried other distros ( as Linux has many )... but maybe someone can inform us otherwise. :wink:
Rather predjudiced of you to assume it's FC3 only; I built it on gentoo, but it should work fine on all distros (the amd64 variations therof, of course). Good luck compiling it; I'm gonna give it another try myself with johannes' hack and the latest CVS.

[edit] :oops: forgot to rebuild w/o openAL, but it seems you got it to work anyway. Sorry!

[edit2] johannes, in the latest CVS your fix does not work; compile fails with "Cannot find '-lftgl'" or something like that.

Posted: Mon Feb 21, 2005 9:08 am
by Panther
Hi Dracarys,
Rather predjudiced of you to assume it's FC3 only; I built it on gentoo, but it should work fine on all distros
... you're right, that was predjudiced of me, sorry ( wasn't thinking ) - But I did say, 'maybe someone can inform us otherwise'. :oops:

And nope...

Tried Scons ( with Johannes input ), and the bloody thing still won't compile, so I'm still running Happy1776's builds - It seems to fail on the '*button.c' files or something. :?

A build w/o OpenAL would still be great, if you can spare one at some point, thanks. :)

Posted: Tue Feb 22, 2005 12:48 am
by johannes
Dracarys wrote:[edit2] johannes, in the latest CVS your fix does not work; compile fails with "Cannot find '-lftgl'" or something like that.
ftgl is a library for rendering TrueType fonts in opengl.

http://opengl.geek.nz/weblog/archives/cat_ftgl.html
http://homepages.paradise.net.nz/henryj ... .html#FTGL

Posted: Sat Feb 26, 2005 9:42 pm
by Dracarys
johannes wrote:
Dracarys wrote:[edit2] johannes, in the latest CVS your fix does not work; compile fails with "Cannot find '-lftgl'" or something like that.
ftgl is a library for rendering TrueType fonts in opengl.

http://opengl.geek.nz/weblog/archives/cat_ftgl.html
http://homepages.paradise.net.nz/henryj ... .html#FTGL
What? I said your fix doesn't work. Are you saying that I need to install ftgl?

Panther, yeah, I'll try to build an openal-free version next time I boot Linux.

Posted: Mon Feb 28, 2005 1:27 am
by johannes
Dracarys wrote: What? I said your fix doesn't work. Are you saying that I need to install ftgl?
YES! :D

Posted: Wed Mar 23, 2005 7:03 am
by ZanQdo
Hi, my father buy an AMD 64 so I´m really interested in this :) Can somebody explain me if this is going to make better render times? and what about Yafray? Its a 3.2 Ghz processor with Windows 64 bits vercion