Page 1 of 2

bf-blender / Windows (2005/04/23)

Posted: Sat Apr 23, 2005 6:06 pm
by gabio
Big week of little thing. I was away most of the time. So sorry for delay.


***The Xtra file got updated, please test with***
***a fresh env. by getting the new package. ***

-Made with MSVC 7 and scons
-------------------------
Relevant feature:
-providing a minimalistic UI for SB vertex to face collision detection
-access to layers was improved a little(python)
-Local axis constraints for pose mode
-bugfixes
-Weld/Align is now in a menu. and other goodies.(UV)
-Game Engine fix for lights.

Commit:
-bjornmose
Log:
providing a minimalistic UI for SB vertex to face collision detection
in the particle interaction panel
"D"= "Amount of damping during softbody collision/intrusion"
"I"= "Inner face thickness" good value for unit cube == 0.2
"O"= "Outer face thickness" good value for unit cube == 0.02
still we can easily hide that before releasing

Log:
rescaled stregth of wind and forcefield effects by some magnitudes
wind 250
field 1000
yeah WARNING to all testers:
tighten belts
scale down wind and forcefield settings (IPOs)

-ianwill
Log:
BPython:
- based on a request by Campbell (he also provided a patch for scene.Layer) access to layers was improved a little, keeping the old method (ob.Layers is a bitmask) and adding the nicer one (ob.layers is a list of ints). Done for objects and scenes. House-cleaning: .Layer was renamed to .Layers (actually just using strncmp instead of strcmp, so both work, same done for Window.ViewLayers).
- finally committing patch by Ken Hughes to let .clearScriptLinks() accept a parameter (list of strings) to clear only specified texts.
- doc updates and fixes (JMS reported a problem in nmesh.transform() example code).

Thanks all who contributed.

-theeth
Log:
Local axis constraints for pose mode. Added
Camera rotation fix (was off centered because it used persinv instead of viewinv. Now rotation center is always center screen in camera mode. (Still need to fix the helpline not showing)
Numinput constraint function was no good, didn't check if a constraint was even on... Fixed.
Rotation was missing constraint text in header print. Fixed.

-stiv
Log:
doc updates. NMesn.transform( matrix, recalc_normals )
had description for recalc_normals backward.

-bjornmose
Log:
gave softbody runge kutta error limit a nice default value

-guitargeek
Log:
Matched the default value for rkerror limit in bpy

-ton
Log:
The do_versions() for new shaders always initialized the values...

-desoto
Log:
Commented out DOF code that did not have a home yet because it broke
compile. Normally it would probably be best just to wait till Ton committed
but its still pretty early and I didn't want people complaining all night.
Hope its no problem!

-blendix
Log:
Merging over some uv editor tweaks from tuhopuu:

- Moved Weld/Align out of transform code, now it's a menu.
- Removed confirmation popups for LSCM unwrapping in the uv editor, didn't
make sense anymore now we have undo.
- Extended select linked, to work more like it does in edit mode:
- L: select linked uvs/faces under the mouse
- Shift+L: select/deselect linked uvs/faces under the mouse
(like shift+click for selecting single uvs/faces)
- Ctrl+L: how L worked before
- More accurate uv selection: when selecting one uv from a group of uvs that
are in the same position, it now selects the uv belonging to the face the
mouse is over, instead of a random uv.
- 'View Selected' (numpad .-key) for both faceselect mode and the uv editor.

-Kester
Log:
Added bone parent relationship.

Log:
Fix lighting in game engine

Log:
Support reinstancing the physics mesh from Python.

Log:
Added the docs & use Python booleans for physics reinstance.
-----------------------------------
A new build is available

Posted: Sat Apr 23, 2005 7:59 pm
by Saluk
Thanks for the lighting back finally kester :)

It seems that when I parent anything to an armature it doesnt work correctly. If I do a normal standard parent, or a bone parent, it just dissapears. If I do an armature parent, it works correctly however.

Posted: Sun Apr 24, 2005 4:31 am
by TorQ
Blendix,

Please put back the confirmation for the LSCM in the UV editor! I've had a problem with this since it went into Tuhopuu. Too many times I accidentally hit the E Key and unwrap my mesh. I don't think that undo is very good, at the best its kinda slow. I would rather save myself time and peace of mind by having the confirmation PUT BACK!! Thanks for doing this immediatly.

TorQ

Posted: Sun Apr 24, 2005 4:52 am
by DYeater
TorQ wrote:Blendix,

Please put back the confirmation for the LSCM in the UV editor! I've had a problem with this since it went into Tuhopuu. Too many times I accidentally hit the E Key and unwrap my mesh. I don't think that undo is very good, at the best its kinda slow. I would rather save myself time and peace of mind by having the confirmation PUT BACK!! Thanks for doing this immediatly.

TorQ
Wow, kind of demanding aren't we?

Posted: Sun Apr 24, 2005 7:51 am
by TorQ
Well, yeah. This is OUR software!! There are have been things recently that have been changing that negatively effect the way I work with this software. Some of them are overlookable but when something is changed that I feel is a big step backward you better bet that I am going to speak up.

TorQ

Posted: Sun Apr 24, 2005 9:43 am
by tuxbot
Hi Gabio
it seems, there are still some problems with downloading the builds.
Would you mind if i mirror your build on my server?

Greetings

Posted: Sun Apr 24, 2005 9:44 am
by zaphire
Not sure if this has been touched on yet, but Ortho-ed cameras are weird now.

I see the new scale feature has replaced the camera distance. Is there going to be any kind of support option for finding the right scale value for an older blender file which was determining the scale based on camera position? (my guess would be no )

What happens now if you load an blend file that used an Ortho-ed setup is that the camera zoom is completely off and has to be re-adjusted. I'm using blender for 2D game development so the majority of the files I work with use an Ortho camera.

Posted: Sun Apr 24, 2005 12:40 pm
by thoro
Thank you, Gabio.

A hint to all Windows users with download problems: You can use Wget to download the files, it is automatically resuming your download where the connection broke up. I use WinWGet, which is a GUI for Wget - you can download it here.

Posted: Sun Apr 24, 2005 1:39 pm
by blendix
TorQ wrote:Well, yeah. This is OUR software!! There are have been things recently that have been changing that negatively effect the way I work with this software. Some of them are overlookable but when something is changed that I feel is a big step backward you better bet that I am going to speak up.
Sure, the feedback is appreciated. I personally don't see how this is a "big step backward" really, i find it more efficient this way, when tweaking pins. In my opinion, if you press the wrong key, you just undo.

But it's not that important to me, i can change it back in my next commit.

Posted: Sun Apr 24, 2005 4:01 pm
by solmax
oh i love the softbodies - it's exciting as back in the old days when "motion designer" came out for lightwave :)

i hope that we'll soon get a good caching system for the simulation, loosing all data is just so painful..

great work !!!

Posted: Sun Apr 24, 2005 5:00 pm
by SamAdam
an idea, not a bug or complaint:

what about just keeping the proportional editing menu in the header and adding an option for "no proportional." I find, when editing models, that i can do everything with my mouse and my left hand on the keyboard, except the OKEY for proportional. I have to move my left hand across the keyboard or take my hand off the mouse to do this operation, which greatly slows me down. Is there any way to do this, and then that would free up the OKEY too?

Posted: Sun Apr 24, 2005 8:06 pm
by William
Great idea SamAdam! Would be much more intuitive, especially for those who use the menu. The toggle is far from the activation item in the Mesh menu.

Posted: Sun Apr 24, 2005 8:15 pm
by bertram

Posted: Mon Apr 25, 2005 1:06 am
by gabio
Xtra got updated again. Some tuhopuu script was missing.

Posted: Mon Apr 25, 2005 4:12 pm
by DYeater
gabio wrote:Xtra got updated again. Some tuhopuu script was missing.
I'm getting some weird results with soft bodies (parented soft body objects not moving with the parent ... real crazy stretches ... automatically going to frame 2 when I hit Shift Down Arrow [instead of frame 1] ... stuff like that).

Is this missing file needed? Do I need to get the xtra files as well as the executable (I only downloaded the exe file)?