Nightly bf-blender/windows optimized

User-contributed CVS development builds. Please test and give feedback!

Moderators: jesterKing, stiv

mchs3d
Posts: 0
Joined: Thu Feb 03, 2005 6:05 am
Location: Loveland, CO

Nightly bf-blender/windows optimized

Post by mchs3d » Thu Jun 16, 2005 9:23 pm

I will be posting (hopefully) nightly builds from now on. The optimized part means that it has been optimized in my compiler (MSVC 7.1) for usage on high performance Win32 platforms. Here are the build options I used:

- Global Optimizations are on (/Og)
- Intrinsic functions enabled (/Oi)
- Fast code favored (/Ot)
- Optimized for Pentium 4+ Processors (/G7)
- Optimized for Windows .exe builds (/GA)

In addition to those options, I use Python 2.4, no 2.3 code at all. I also included the atioglxx.dll driver for ATI users, which should greatly enhance performance on those cards. Please let me know if there are any problems or any changes needed.

P.S. - Please tell me if for some reason you can't download the file.

-- Download --
-- Download Benchmark --
Last edited by mchs3d on Fri Oct 07, 2005 1:08 am, edited 8 times in total.

ysvry
Posts: 0
Joined: Thu Aug 05, 2004 4:28 pm

Post by ysvry » Tue Jun 21, 2005 4:44 pm

thats great i have a p4 and ati card thx for making this build.

free model i did in blender :
http://home.deds.nl/~mp/elf/elf.htm

mchs3d
Posts: 0
Joined: Thu Feb 03, 2005 6:05 am
Location: Loveland, CO

Post by mchs3d » Tue Jun 21, 2005 11:11 pm

Great! :D Can you post your specs and do a benchmark in Blender? I'd like to see how well this build is working.

- Mine are:
Mobile Pentium 4 ~2.8 GHz HT 533 MHz FSB
640 Mb RAM
ATI Mobility Radeon 7000 IGP AGP 128 Mb VRAM
Windows XP Home Edition SP2

Benchmark: 158.562 FPS @ 794 Iterations

thoro
Posts: 15
Joined: Thu Oct 17, 2002 10:20 am
Location: Berlin, Germany
Contact:

Post by thoro » Wed Jun 22, 2005 3:24 pm

Thanks, this one really really renders faster on my machines (AMD 64 3400+ and Intel Pentium 4 2.8 GHz).

Render times for my test scene:

Blender 2.37a: 02min 01sec
This Build: 01min 40sec

By the way, I thought the ATI problems were already solved a few Blender versions ago - I have ATI Radeons in both machines and have no slowdowns without the atioglxx.dll.

mchs3d
Posts: 0
Joined: Thu Feb 03, 2005 6:05 am
Location: Loveland, CO

Post by mchs3d » Thu Jun 23, 2005 5:59 am

thoro wrote: By the way, I thought the ATI problems were already solved a few Blender versions ago - I have ATI Radeons in both machines and have no slowdowns without the atioglxx.dll.
That's interesting! It must be different for everyone. :? I'm surprised to hear the build is working as well as it is! I never thought it would be that good. Anyway, sorry it hasn't been nightly, I've been having a few "issues" with my FTP utility. :wink:

mchs3d
Posts: 0
Joined: Thu Feb 03, 2005 6:05 am
Location: Loveland, CO

Post by mchs3d » Thu Jun 23, 2005 6:51 am

I've updated the latest build now. Fixed:

- added notes
- removed unnecessary files

Also, PLEASE post your specs and a benchmark!

- P.S. - I'm posting this as a sticky now

Sutabi
Posts: 53
Joined: Fri Oct 18, 2002 1:35 am
Location: Oceanside, California
Contact:

Post by Sutabi » Mon Jul 04, 2005 6:40 am

Celeron 3.6Ghz
1gig RAM
ATI Radeon 9600 AGP 8x 256Mb
Windows XP Home Edition SP2

760 FPS @ 3805

lucky3
Posts: 12
Joined: Thu Oct 17, 2002 6:08 pm

Post by lucky3 » Mon Jul 04, 2005 11:42 am

Seems like builds are not updated anymore? Latest build was performed on 23 June 2005.

bleen
Posts: 0
Joined: Fri May 09, 2003 1:58 am

Post by bleen » Tue Jul 05, 2005 6:30 pm

@ lucky3:
seems that you have to hug "your" blender-coder before an update will performed ;)
keep your patient, young samurai!

lucky3
Posts: 12
Joined: Thu Oct 17, 2002 6:08 pm

Post by lucky3 » Tue Jul 05, 2005 7:58 pm

eheh i just followed the title of the topic that is: nightly bf-blender.
Since this is a sticky post, i thought that was still updated? But this is obviously not a reproach, the previous post was just as information.

mchs3d
Posts: 0
Joined: Thu Feb 03, 2005 6:05 am
Location: Loveland, CO

Post by mchs3d » Fri Jul 08, 2005 1:32 am

Sorry, been gone. Will update TONIGHT! 8)

lucky3
Posts: 12
Joined: Thu Oct 17, 2002 6:08 pm

Post by lucky3 » Fri Jul 08, 2005 2:42 pm

Oh, thank you! :)

mchs3d
Posts: 0
Joined: Thu Feb 03, 2005 6:05 am
Location: Loveland, CO

Post by mchs3d » Mon Jul 11, 2005 1:16 am

What do you think of the splash screen? If you want another picture to be used as splash screen, please tell me! :P

lucky3
Posts: 12
Joined: Thu Oct 17, 2002 6:08 pm

Post by lucky3 » Mon Jul 11, 2005 2:51 pm

hi mchs3d,
I've just downloaded your latest build but when i run blender, it crashes! I don't know why... :(

fobsta
Posts: 0
Joined: Sat Jun 12, 2004 11:21 pm

Post by fobsta » Mon Jul 11, 2005 6:58 pm

I like the rotate around selected objects in user preferences

very intuitive

Post Reply