Page 1 of 2

nightly bf-blender build for OSX **Latest (02 Nov 2005)**

Posted: Sun Aug 28, 2005 9:56 am
by BrianH
I will be maintaining the nightly build for OS X here:

http://blendertestbuilds.de/index.php?d ... SX/BrianH/

Compiled on OS X 10.4.2 Tiger and Python 2.4 is required. You can get Python 2.4 here:

http://undefined.org/python/

and the Tiger Patch (if needed) here:

http://pythonmac.org/packages/TigerPython24Fix-r2.zip

Posted: Thu Sep 15, 2005 5:59 pm
by Money_YaY!
thankyou! :D
can you do tuhopuu as well just if you have time

Posted: Thu Sep 15, 2005 9:17 pm
by BrianH
sure, I'm trying to get all the builds working (bf-blender, tuhopuu, fluid-sim, etc). I'll have a tuhopuu one up the end of the night (hopefully).

Posted: Thu Sep 15, 2005 10:18 pm
by BrianH
Tuhopuu3 build finished, I'll keep it uptodate as well as the rest. Enjoy.

http://blendertestbuilds.de/index.php?d ... SX/BrianH/

Posted: Fri Sep 16, 2005 4:02 pm
by Money_YaY!
cool! Thank you,, does it require the new pythoon? I did install the new python but it is still not launching

Posted: Fri Sep 16, 2005 4:38 pm
by BrianH
It's not launching at all? Are you on Panther or Tiger? I seem to be having a problem building for Panther, because this wasn't the first complaint about it not running. I'll defeinitly look more into it.

Posted: Fri Sep 16, 2005 11:36 pm
by Money_YaY!
tiger 10.4.2

Posted: Sun Sep 18, 2005 8:37 pm
by Money_YaY!
ran the python 2.4 installer and the fix, but still no worky.

It might be looking for shared libraries or some sort of files if it was not built to contain all of it's stuff, I ran into this in the past. I dont knpow how to fix it, I just know it is some files needed to edit in the compile

Posted: Tue Sep 20, 2005 6:49 pm
by osxrules
To get it to launch, I had to change permissions on the executable. Just right-click and open package contents and go to contents/macos/blender. Open a terminal and type chmod 755 and drag in the file called blender and hit return. It should launch after that.

Thanks for the builds blueGecko, I was using an old CVS version and the rig from project orange wasn't working but it does with the latest build.

[edit] However, it's crashing when I try to open my blend files made using one of Lukep's builds, which was an older CVS. I get an update_pose_constraint_flags error from crt.c when reading the files:

0 org.blenderfoundation.blender 0x0029ecec update_pose_constraint_flags + 232 (crt.c:355)
1 org.blenderfoundation.blender 0x002cfe38 do_versions + 10860 (crt.c:355)
2 org.blenderfoundation.blender 0x002d2fb0 blo_read_file_internal + 596 (crt.c:355)
3 org.blenderfoundation.blender 0x002d6ac0 BLO_read_from_file + 60 (crt.c:355)
4 org.blenderfoundation.blender 0x002612b8 BKE_read_file + 92 (crt.c:355)
5 org.blenderfoundation.blender 0x00004d9c BIF_read_file + 56 (crt.c:355)
6 org.blenderfoundation.blender 0x00061dbc filesel_execute + 780 (crt.c:355)
7 org.blenderfoundation.blender 0x00064930 winqreadfilespace + 4264 (crt.c:355)
8 org.blenderfoundation.blender 0x0000c354 screenmain + 2768 (crt.c:355)
9 org.blenderfoundation.blender 0x000048e4 main + 2596 (crt.c:355)
10 org.blenderfoundation.blender 0x000033bc _start + 348 (crt.c:272)
11 org.blenderfoundation.blender 0x0000325c start + 60

I managed to open it in 2.37 and save the file again and it opened with all the UVs and stuff intact. Phew. This is why I didn't use CVS stuff before. It's also why I like the security of an ascii scene file, which Blender still doesn't have.

Posted: Sun Sep 25, 2005 6:55 am
by osxrules
There seems to be a bug with this CVS version in that follow path constraints don't work properly. If you parent an object to a path, the constraint doesn't appear in the constraints panel although the constraint works.

If you constrain a bone to a path, the constraint appears but it doesn't work - the bone doesn't move along the path.

Posted: Thu Sep 29, 2005 1:14 am
by Money_YaY!
do you have a new one ? Their is some sort of new particles tool everyone is going gaga over ..

9-30-2005 Build

Posted: Mon Oct 03, 2005 3:01 am
by boswellian
I was able to build the CVS source from 9-30-2005:

http://boswellian.spymac.com/files/bf-b ... 0-9-05.zip

I also built a version with the particle patch which supports guides:
http://boswellian.spymac.com/files/bf-b ... epatch.zip

They were both built with OS X 10.3.9, python 2.4

Posted: Mon Oct 03, 2005 11:05 am
by William
The newest October 2nd build does not work for me, even after installing Python, running the fix, AND changing the permissions of the blender executable as described by osxrules.

I am running Mac OSX 10.4.2 on an iMac G5.

Any ideas? Hints?

Posted: Mon Oct 03, 2005 2:14 pm
by osxrules
The fix for the executable was still needed but it crashes when launching because the binary is bad. Lol, if you open the binary up in a hex editor, it's just full of URLs. It looks like the developer's browsing history or something. I tried to look for any porno sites he had been visiting :P. Mostly it's just project orange and things. There's nothing you can do to run this I'm afraid, you'll just have to wait for an update.

Posted: Thu Oct 06, 2005 7:43 am
by BrianH
Here is the fix:

http://bchynds.com/index.php?option=com ... 3&id=12#12

I am sorry for the problems, it's under investigation.