Page 2 of 2

Posted: Mon Sep 19, 2005 5:32 am
by malefico
Cool, thank you, I missed it somehow. Thanks !

Posted: Mon Sep 19, 2005 11:35 pm
by malefico
I tried to compile the latest BF-Blender CVS (with Fluidsim included) and got this:

Code: Select all

g++-3.3.2: cannot specify -o with -c or -S and multiple compilations
scons: *** [/home/malefico/CVS-blender/build/linux2/intern/elbeem/intern/cfgparser.o] Error 1
scons: building terminated because of errors.
Using Scons on a mandrake 10.0. I've read people is having problems to compile this but AFAIK those propblems are of different nature (like files missing). Any hint anyone ?

Anyway, I tried a binary (couldn't try your because of older libraries) and the sim looks pretty cool, however, looks like you can't have moving objects (I tried a glass rotating to poor its content).

Regards

malefico.

scons defines

Posted: Tue Sep 20, 2005 10:28 am
by n_t
This seems to be a problem with the way i added the defines in the SConscript file in combination with the scons or linux version... for a quick fix you can replace the lines:

elbeem_env.Append(CXXFLAGS= ' -DNOGUI -DELBEEM_BLENDER=1 ');
elbeem_env.Append(CCFLAGS= ' -DNOGUI -DELBEEM_BLENDER=1 ');

with

elbeem_env.Append(CPPDEFINES= 'NOGUI');
elbeem_env.Append(CPPDEFINES= 'ELBEEM_BLENDER=1');

this hopefully fixes it. I'll try to check that into the official branch soon. Regards,
-> Nils

Re: scons defines

Posted: Wed Sep 21, 2005 12:56 am
by malefico
n_t wrote:This seems to be a problem with the way i added the defines in the SConscript file in combination with the scons or linux version... for a quick fix you can replace the lines:

elbeem_env.Append(CXXFLAGS= ' -DNOGUI -DELBEEM_BLENDER=1 ');
elbeem_env.Append(CCFLAGS= ' -DNOGUI -DELBEEM_BLENDER=1 ');

with

elbeem_env.Append(CPPDEFINES= 'NOGUI');
elbeem_env.Append(CPPDEFINES= 'ELBEEM_BLENDER=1');

this hopefully fixes it. I'll try to check that into the official branch soon. Regards,
-> Nils
YES it works !!! Thank you very much, now it compiles fine. Cool seeing progress bar as it bakes !

Congratulations for your work, it's just amazing.

malefico.

Posted: Sat Sep 24, 2005 8:46 pm
by renderedbrian
Hi Guys.

I have recently checked out blender cvs (24th September 05),

After compiling using scons (Ubuntu amd64, gcc 3.3.5) I get a segfault while trying to bake the fluid simulation.

Has anyone else been able to compile on AMD64?

--
Brian

Posted: Wed Oct 26, 2005 7:05 pm
by short circut
Where did the windows build go. when i click the linke i get Line 404 error.

Posted: Wed Oct 26, 2005 7:51 pm
by lguillaume
short circut wrote:Where did the windows build go. when i click the linke i get Line 404 error.
I remove the file, because Blender 2.40 alpha 1 have fluid system.
If you want, I make test build for windows, you can download it at : http://blendertestbuilds.de/index.php?d ... /20051024/

The fluid system have 2 new type, a better gui.