Blender, Orange branch / Win32 (2006/01/12)

User-contributed CVS development builds. Please test and give feedback!

Moderators: jesterKing, stiv

Post Reply
zupermonkey
Posts: 0
Joined: Tue Jul 06, 2004 1:13 pm

Blender, Orange branch / Win32 (2006/01/12)

Post by zupermonkey » Thu Jan 12, 2006 6:46 am

New Orange features, in short:
Ripped from the cvs logs, dated from 2006/01/10 to 2006/01/12
  • Blender General:

    Option in View Properties panel to disable drawing of the dashed "relationship lines"

    Image
  • Textures / Texturing:

    Subsurf for UV's (fixes UV distortion issues on subdivision surfaces)
    Image textures use float colors now, when present (including mipmap and AO skycolor)

    Image
    © blendix
  • Image Window:

    Float buffer support
    Alpha viewing with checkered backdrop
    Alpha viewing as B/W
    Z-buffer viewing (when available)
    Re-used existing icons in header, no time for fancy design (ton)
    The Z value range is now linearly mapped from camera clipstart to clipend

    Image
  • Render Window:

    (ton) recoded the way alpha-only only draws, much faster now
    Backbuffer option uses float buffers
    Sampling with LMB now displays Z values in float range of 0.0 to 1.0
    After rendering, Z values are converted to floats. Also saves in EXR files now.


Download from GraphicAll: click here



The CVS Log Notes:
With all the information you need, from the people behind the features
ton:

And now for the real exr fun: float buffer support in Image window!

Image as loaded in Blender (from openexr.com):
http://www.blender.org/bf/exrcurve1.jpg

Image with different white point:
http://www.blender.org/bf/exrcurve2.jpg

Image with white and black point and a curve:
http://www.blender.org/bf/exrcurve3.jpg

Use SHIFT+click to set the black point, and CTRL+click for white point.
The buttons in the panel work too, of course.

The curves work after the black/white range was corrected, so you can stick to curves with a normal 0-1 range.
There's also now a general color curve, marked with 'C' button.

Note; this currently only maps the float colors to a visible 8 bits per channel rect. You can save it, but when the blender file loads the curve or mapping is not executed until you click in the curves... have to look at that still.
Speed for this is also quite unoptimized... still WIP, but fun!
campbellbarton:

Fixed bug in convert function with Mesh objects.
Objects with no modifier could still be converted, but resulting meshes were corrupt and segfaulted Blender when cycling edit mode.
This tests each mesh object for modifiers before converting.

Resulting metaballs meshes were not visible in wireframe.

Also made the selection context nicer, All new converted objects are selected while objects that are converted are deselected.
blendix:

Apply Subsurf to UV's.

This fixes most of the UV distortion issues with subsurf. Near seams however there might still be some distortion, but this should at least not be worse than before. Subsurf UV is enabled by default on new meshes, and can be enabled in the modifier panel for existing ones.

Before and after:
http://users.pandora.be/blendix/notsmooth.png
http://users.pandora.be/blendix/smooth.png
ton:

More work on float/exr buffers;

- EXR now saves and reads Zbuffers correctly
- EXR reading didn't set alpha to 1 yet when no alpha buffer was present

- ImageWindow: the "black point" only checked for the r value... now is OK
- ImageWindow: Curves panal has button "reset"
- ImageWindow: hold LMB drag shows rgba and z values. With SHIFT or CTRL it applies black/white point whilte dragging too
- ImageWindow: saving file copied the entire buffer... removed that. Also made the header print clear; this save only saves in own file type.
- Curves: zoom and drag now gets clamped by the Clipping value
- Imbuf: duplicate buffer only copied one quarter of to new buffer
ton:

Added Alpha viewing option in Image window.
ton:

ImageWindow goodies

- options to show with alpha-over (checkered backdrop), only alpha (BW) and when available: the zbuffer.
Note: it's icons in the header, I just re-used existing ones, no time now for fancy design. :)

Also: recoded the way alpha-only draws, also in renderwindow. Mucho faster!

Oh, and sampling the buffer with LMB now displays z values in float range of 0.0 to 1.0. Note that we still save signed int in files for Z...
broken:

Added an option in View Properties panel to disable drawing of 'relationship lines' - i.e. the dashed lines that connect objects in parent/constraint/hook/IK relationships. After talking to the others I rolled the Armature-specific one into the same setting for simplicity's sake. We can see how it goes, always possible to put it back.
ton:

More float buffer support;

- Image textures use float colors now, when present. Works for mipmap too, and for AO skycolor (probes)
- Backbuffer option uses float buffers too. Note that rendering OSA will resample the backbuffer, filtering it... will need to be solved with the new composit stage
- LMB sampling in image window now shows float color too

+ bugfix in imbuf, filtering for float buffers had an error.
ton:

Until now, the zbuffer was written straight from the internal zbuffer, which has values that are inverse-proportional (like 1.0/z) which makes it very hard to use it for postprocess, like zblur or other composit effects that require Z.

Based on info from ILM, the values stored for Z in exr files is the actual distance from a camera. I think that's about time to migrate to that convention!

By default now, after render, the z values are converted to floats. This saves in exr files now, but not in the Iris Z files. That latter was a blender-only anyway, so might be not a real hassle to drop. :)

You can see the difference in the image window, but notice the range now is linear mapped from camera clipstart to clipend.

Note; I just discover that ortho Z values need a different correction...


ps. There's no option dialog for the primitives-aligned-to-world-patch yet.
That's because the UI code of Blender drives me crazy... bleh
Last edited by zupermonkey on Thu Jan 26, 2006 10:53 pm, edited 1 time in total.

ZanQdo
Posts: 0
Joined: Sun Apr 11, 2004 4:57 am

Post by ZanQdo » Thu Jan 12, 2006 8:00 am

Thanks a lot for the build and for the damm cool feature list :D
:-) Hosting for your test builds:
GraphicAll.org

zupermonkey
Posts: 0
Joined: Tue Jul 06, 2004 1:13 pm

Post by zupermonkey » Thu Jan 12, 2006 8:36 am

I guess it shows that I really miss those long announcements (weekly community journals) with new features, development news and other nice things to read about Blender... ;)

cessen
Posts: 109
Joined: Tue Oct 15, 2002 11:43 pm

Post by cessen » Thu Jan 12, 2006 8:49 am

Woohoo! Lots of much needed fixes/improvments in this build. It's great to see that the not-so-gloryfull (but equally important) stuff is being taken care of too. :-)

Erm... any chance we could get a Linux build of this?

cessen
Posts: 109
Joined: Tue Oct 15, 2002 11:43 pm

Post by cessen » Thu Jan 12, 2006 9:21 am

Just started messing around with the new build and noticed that the subdivided UV's are displayed in the UV editor. So while they do get rid of nasty distortions, it's a pain in the ass to paint textures for it since you can't export the subdivided UV's to paint on top of. XSI suffers from the same problem (unless they fixed it in 5.0), and it makes things a real hassle.

Don't get me wrong, I really appreciate the subdivided UV's a lot. They're great! It's a huge step in the right direction. But the subdivided UV's really, really need to be displayed.

M@dcow
Posts: 0
Joined: Sun Apr 20, 2003 12:50 pm

Post by M@dcow » Thu Jan 12, 2006 9:29 am

errr.....so where is this openexr support then? what am I missing?

I want to render my blender scenes in openexr, then post pro them as shown in the images above.....but without any options to save in openexr, where exactly does it fit into my workflow?

jedrzej_s
Posts: 0
Joined: Sat Nov 26, 2005 8:19 pm
Location: Poland

Post by jedrzej_s » Thu Jan 12, 2006 11:28 am

M@dcow wrote:errr.....so where is this openexr support then? what am I missing?

I want to render my blender scenes in openexr, then post pro them as shown in the images above.....but without any options to save in openexr, where exactly does it fit into my workflow?
I have this same trouble... and more: I want to open image EXR (from openexr.com) in UV/Image Editor and this EXR has opened, but it doesn't display... :(. In Blender consol: "Unknown fileformat" ! What does it's wrong ???

env
Posts: 12
Joined: Thu Oct 17, 2002 9:58 pm
Location: Italy
Contact:

Post by env » Thu Jan 12, 2006 1:19 pm

Doh! Simple bug: raytraced shadows doesn't appear in the rendering.

EnV

fobsta
Posts: 0
Joined: Sat Jun 12, 2004 11:21 pm

Post by fobsta » Thu Jan 12, 2006 2:52 pm

Option in View Properties panel to disable drawing of the dashed "relationship lines"
thank you very much!

PiotrKosmala
Posts: 0
Joined: Tue Aug 03, 2004 12:08 pm

Post by PiotrKosmala » Fri Jan 13, 2006 1:26 am

where is a EXR saver?!? i don't see it at render panel
also
opening a exr file in uv/image window don't work, i don't see a image!

it's a joke? what's up? =)

zupermonkey
Posts: 0
Joined: Tue Jul 06, 2004 1:13 pm

Post by zupermonkey » Fri Jan 13, 2006 3:55 am

Hm, odd... I'm fairly sure the OpenEXR support was really in there. I've even been playing with those sample images, a few hours before I did the latest build (the one I've uploaded to GraphicAll)..

And no, I wasn't dreaming :)

I'm going to find out why this happened, but will first have to fix some linker errors (not an issue, but I have to re-read the logs to fix it and don't have time for that at the moment)...

I'll let you know when I've updated the build (hopefully WITH exr support).

J0hann3s
Posts: 0
Joined: Sat Jan 01, 2005 10:50 pm

Post by J0hann3s » Fri Jan 13, 2006 9:36 pm

seems this version has some problems with yafray.
it crashes always when photons have to be shot. all the same with xml output.

cekuhnen
Posts: 0
Joined: Mon Jan 13, 2003 11:04 pm

Post by cekuhnen » Sun Jan 15, 2006 2:56 am

also the polygon decimator does not work. it crashes windowsxp on my xeon workstations.

jedrzej_s
Posts: 0
Joined: Sat Nov 26, 2005 8:19 pm
Location: Poland

Post by jedrzej_s » Mon Jan 16, 2006 10:34 pm

Open EXR work in this build :) :
http://www.blender.org/forum/viewtopic.php?t=7848

Regards !!!

Post Reply