bf-Blender / Linux (2005/08/02) FFMPEG support

User-contributed CVS development builds. Please test and give feedback!

Moderators: jesterKing, stiv

madman
Posts: 0
Joined: Sat Jun 19, 2004 3:06 am

Post by madman »

Damn!
I can't found avutil for my kubuntu :S

I install:
http://packages.ubuntu.com/breezy/graph ... file-utils

I hope this right!
But...
./blender: error while loading shared libraries: /usr/lib/libavutil.so.49: invalid ELF header

OTO
Posts: 60
Joined: Wed Oct 16, 2002 8:51 pm
Contact:

Post by OTO »

Really really funny! Like a game

In the libavutilscvs0 package you should have a libavutil.so.0.0.0
link it with 49 thing
It works for me in Debian
Bye

gabio
Posts: 0
Joined: Thu Jan 15, 2004 6:41 am
Location: Canada - Québec - Sherbrooke
Contact:

Post by gabio »

If I remeber right avutil might be part of ffmpeg package.

madman
Posts: 0
Joined: Sat Jun 19, 2004 3:06 am

Post by madman »

I install ffmpeg... but avutil not exist.
Searching...

madman
Posts: 0
Joined: Sat Jun 19, 2004 3:06 am

Post by madman »

I found avutil.h in the ffmpeg/include path, but nothing about avutilsomething.so.

OTO
Posts: 60
Joined: Wed Oct 16, 2002 8:51 pm
Contact:

Post by OTO »

For the Debian there's a libavutilcvs package

madman
Posts: 0
Joined: Sat Jun 19, 2004 3:06 am

Post by madman »

i found the .deb package for amd64, ppc and sparc but not for i386.

damn!

Statik
Posts: 0
Joined: Fri Apr 16, 2004 2:05 pm
Location: Nova Scotia Canada
Contact:

Post by Statik »

Cannot find a way to get libavformat.so.50

I only have libaviformat.a

Any ideas?

Statik

raphael
Posts: 4
Joined: Mon May 26, 2003 10:18 pm
Location: france
Contact:

Post by raphael »

Ok... after 2 week of "hard days nights", i get this built working.
As some of you, i'm using Ubuntu and i had troubles to install ffmpeg. Here's what i'v done to get the famous libavutil.so :

download ffmpeg cvs:
cd /usr/local

cvs -z9 -d:pserver:anonymous@mplayerhq.hu:/cvsroot/ffmpeg co ffmpeg

./configure --enable-mp3lame --enable-vorbis --enable-faad --enable-faac --enable-a52 --enable-a52bin --enable-pp --enable-libogg --enable-gpl --enable-shared --prefix=/usr

sudo make install

It works for me, but i had to install (via synaptic) a "lot" of other libs.

raphael
Posts: 4
Joined: Mon May 26, 2003 10:18 pm
Location: france
Contact:

Post by raphael »

Hi,

Fot those who don't find the libs, i made this horrible thing
http://dwarf.free.fr/wip/BLENDER_ffmpeg ... -27.tar.gz

i've done it for my laptop wich is "runing" on an old slackware...
To launch blender, extract the archive, open an terminal, cd to the "BLENDER" dir and run to the blender.sh file.

So, my fisrt anim completly done (render+seq) with Blernder... having fffmpg into blender is a great pleasure !
http://dwarf.free.fr/wip/entre_amis_ffmpegPcm01.mpg4

unfear
Posts: 0
Joined: Sun Jan 09, 2005 6:53 pm

Post by unfear »

Hi guys can you help me? I don't undestand that are this error

Linking program ==> 'blender'
/usr/lib/libavformat.a(dc1394.o): In function `dc1394_read_header':
: undefined reference to `dc1394_create_handle'
/usr/lib/libavformat.a(dc1394.o): In function `dc1394_read_header':
: undefined reference to `dc1394_get_camera_nodes'
/usr/lib/libavformat.a(dc1394.o): In function `dc1394_read_header':
: undefined reference to `dc1394_dma_setup_capture'

I have de ffmpeg, libdc1394-13-dev and libraw1394-dev and the others lib -dev

Post Reply