Page 1 of 2

bf-Blender / OS X for INTEL CPU (2006/03/08)

Posted: Wed Mar 08, 2006 10:42 am
by Timothy
This is a version of bf-blender (CVS) compiled for the new Apple Core Duo imacs and MacBooks with an INTEL CPU.

This still has some issues that need to be solved regarding Big Indian -> Little Indian migration, for instance loading of raw .tiff images resuls in colors getting mixed up.

I will always keep my latest build here:

Right now, the gameengine is still disabled but I'll try to get that compiled in soon too.

Also relevant is:

If you find errors specific to this build, please let me know.


Does not run?

Posted: Thu Mar 09, 2006 2:01 am
by eagle007
I tried to run this on my iMac Core Duo, but it doesn't start.

Opening the package and running the executable in it, tells me it cann't find libopenal1.0.0

Any idea?

Posted: Thu Mar 09, 2006 6:33 am
by TroutMaskReplica
doesn't launch. intel imac, 20". report below. i've blanked out my name with x's.

===== Thursday, March 9, 2006 12:30:19 AM Canada/Eastern =====

Host Name: x's-computer
Date/Time: 2006-03-09 00:30:21.799 -0500
OS Version: 10.4.5 (Build 8G1454)
Report Version: 4

Command: blender
Path: /Users/x/Desktop/blender
Parent: WindowServer [60]

Version: 2.41 (2.41, 2006-Mar-08, Blender Foundation)

PID: 2690
Thread: Unknown

Link (dyld) error:

Library not loaded: /opt/local/lib/libopenal1.0.0.dylib
Referenced from: /Users/x/Desktop/blender
Reason: image not found

Posted: Thu Mar 09, 2006 8:34 am
by jesterKing
You'll need to install OpenAL, however that is done on OSX.


Posted: Thu Mar 09, 2006 11:18 am
by alelink
I've installed OpenAL though the MAcosx pgk,
but the error is the same as above.

Posted: Thu Mar 09, 2006 12:53 pm
by Timothy
TroutMask wrote:(i've cross posted this in your thread in the developer's forums)

doesn't launch. intel imac, 20". report below. i've blanked out my name with x's.
I'll cross-post this too :)

I know what is causing this (OpenAL, duh) I can easily create a build that does launch for you but won't be home again untill friday night. OpenAL is used by the gameengine which I hope I can build saturday.

You can probably make this build work by installing OpenAL through Darwinports, but I recommend you just wait till friday :-)


Posted: Fri Mar 10, 2006 3:51 am
by TroutMaskReplica
i installed apple developer tools, and darwinports, but every command i type into the terminal (using the darwinports documentation as a guide) results in a string of garbage.:?

therefore, i will do as you suggest and eagerly await your next intel mac build, when you are able to get around to making it.

Posted: Sat Mar 11, 2006 3:22 pm
by TroutMaskReplica
just tried installing the binary of OpenAL from but it appears to not have any affect. the blender crash log displays exactly the same message as before.

my assumption is the binary for OpenAL is not Universal yet.

Posted: Sun Mar 12, 2006 4:13 pm
by Timothy
I updated the link, it should run for you now.

Posted: Sun Mar 12, 2006 5:21 pm
by Timothy
Now also an untested version of Blender for OSX with the gameengine:

Posted: Tue Mar 14, 2006 5:04 pm
by alelink
hello, thanks for this build.
I've done some tests and it is very fast, finally :)
This build don't load correctly movie files as animated texture, it load
only the first frame of the movie and shows it all green,
I've tried a mov file encoded with sorenson codec.

Posted: Wed Mar 15, 2006 12:30 am
by TroutMaskReplica
i'm finding the internal render engine is about 2.5 - 3x faster then blender under rosetta.

the interface feels about the same as the rosetta version. i have a complex facial character setup that chugs under rosetta (when the head is subsurfed) which chugs slightly less using the intel build.

rendering seems to be the only area that gets a serious improvement from the intel build.

Posted: Thu Mar 16, 2006 11:18 pm
by MrMunkily
that seems about right; OGL acceleration should still work under rosetta, no?

Thus the only really intensive thing would be the rendering.

Posing can be pretty toucgh too, unsure why that wouldn't be accelerated.

Try comparing the speed of native blender in OS X , linux, and XP.

XP now boots on all availible intel macs, other than the imac 20"

Posted: Wed Apr 19, 2006 12:43 am
by alelink
can you provide a build of the latest CVS? :)
thank you!

Posted: Sun Apr 30, 2006 5:09 pm
by jsplifer

I am still having make and scons fail trying to compile this. And I am quite sure it is not because of i386ness. Rather it is issues with gcc4.

With that being said I see Lukep is working on this matter. For me to be sure and for others to experiment I think it would be good to provide the darwin-8.6.1-i386 libraries on the cvs.

Unfortunately I must of reversed something within the last few hours because now I'm getting several errors. I did get to final compile with ld putting it all together and failing, and that was the error I wanted to post here for help.

At any rate I would love to see a walkthrough, fixes for gcc4, i386 libs in cvs... or an updated build from cvs... but I really hate not being able to do it myself.

Cool ;)