Page 2 of 3

Posted: Tue Aug 08, 2006 1:59 pm
by calli
Hello rcas,

could you please post your separately? I want to have a look without need to get 12MB over my ISDN line.



Posted: Tue Aug 08, 2006 2:13 pm
by rcas
Will post tonight.

Posted: Fri Aug 11, 2006 9:55 am
by johanjohan
Hello rcas,

I have installed your Blender 42a, but after if I want to install (with synaptic) Jahshaka, there are package's problem..

to be installed : jahshaka, openlibraries, libopenal0, openlibraries

to be removed : Blender, libalut0, libopenal0a

Its possible to install Jahshaka? (I prefer to use Ubuntu)


Posted: Fri Aug 11, 2006 10:47 am
by rcas
First, my file

Code: Select all

BF_FFMPEG = '/usr'
BF_FFMPEG_INC = '${BF_FFMPEG}/include'
BF_FFMPEG_LIB = 'avformat avcodec avutil xvidcore ogg dc1394_control raw1394 faac faad x264 mp3lame vorbis theora vorbisenc dts gsm'
# BF_FFMPEG_LIB = 'avcodec avformat avutil xvidcore ogg dc1394_control faac faad mp3lame dts z vorbisenc gsm vorbis theora x264 a52 raw1394'
# WITH_BF_OPENAL = 'false'

# CCFLAGS = ['-pipe','-fPIC','-funsigned-char','-fno-strict-aliasing','-march=i586']
# CCFLAGS = ['-pipe','-fPIC','-funsigned-char','-fno-strict-aliasing','-march=pentium-m','-msse2']
# CCFLAGS = ['-pipe','-fPIC','-funsigned-char','-fno-strict-aliasing','-march=pentium4','-msse2']
# CCFLAGS = ['-pipe','-fPIC','-funsigned-char','-fno-strict-aliasing','-march=athlon-xp','-m3dnow']
CCFLAGS = ['-pipe','-fPIC','-funsigned-char','-fno-strict-aliasing','-march=athlon64','-msse2']

# CXXFLAGS = ['-pipe','-fPIC','-funsigned-char','-fno-strict-aliasing','-march=i586']
# CXXFLAGS = ['-pipe','-fPIC','-funsigned-char','-fno-strict-aliasing','-march=pentium-m','-msse2']
# CXXFLAGS = ['-pipe','-fPIC','-funsigned-char','-fno-strict-aliasing','-march=pentium4','-msse2']
# CXXFLAGS = ['-pipe','-fPIC','-funsigned-char','-fno-strict-aliasing','-march=athlon-xp','-m3dnow']
CXXFLAGS = ['-pipe','-fPIC','-funsigned-char','-fno-strict-aliasing','-march=athlon64','-msse2']

# CPPFLAGS = ['-DXP_UNIX','-pipe','-fPIC','-funsigned-char','-fno-strict-aliasing','-march=i586']
# CPPFLAGS = ['-DXP_UNIX','-pipe','-fPIC','-funsigned-char','-fno-strict-aliasing','-march=pentium-m','-msse2']
# CPPFLAGS = ['-DXP_UNIX','-pipe','-fPIC','-funsigned-char','-fno-strict-aliasing','-march=pentium4','-msse2']
# CPPFLAGS = ['-DXP_UNIX','-pipe','-fPIC','-funsigned-char','-fno-strict-aliasing','-march=athlon-xp','-m3dnow']
CPPFLAGS = ['-DXP_UNIX','-pipe','-fPIC','-funsigned-char','-fno-strict-aliasing','-march=athlon64','-msse2']

REL_CFLAGS = ['-O3']
Second, either you install libopenal0 or libopenal0a, they conflict with each other. libopenal0a is from Ubuntu main repository and libopenal0 is from a CVS snapshot.

I don't mind rebuilding all stuff with libopenal0 instead, as long as no one else complaints that they need libopenal0a instead :) .

Anyway, you can always force the install, check the menus on synaptic for Force Install.

Sunday night I will hopefuly do the following:
- New set optimized debs of 2.42a, now with BlenderPlayer
- Add Core Duo + SSE3 deb
- Add AMD64 + SSE3 deb
- Add P4 + SSE3 deb
- Add FLV (Flash Video) to the FFMPEG export options
- Fix dependency of OpenEXR
- Fix dependency of libopenal0

Will leave for two days now.

-- Rui --

Posted: Fri Aug 11, 2006 12:40 pm
by calli

Is core duo optimized == Pentium-M and sse3?

I lost track about the CPUs at PentiumPro level I guess ;-)

One more thing, where do I get the ffmpeg development package? I could not find it in the debian rep.

ffmpeg is installed but there is no ffmpeg-dev or such.


Posted: Fri Aug 11, 2006 1:16 pm
by rcas
Look at my server folders, the dev packages for ffmpeg are there. You have to enable universe and multiverse on the repositories to have it.

Will build optimized builds for SSE3 Sunday, currently there is only SSE2.

Posted: Mon Aug 21, 2006 4:27 pm
by kidb
calli wrote: One more thing, where do I get the ffmpeg development package? I could not find it in the debian rep.
Mr. Marillats depository:

deb sid main
deb-src sid main

Posted: Mon Aug 21, 2006 5:01 pm
by calli
Or properly update blender/extern ;-)

Stupid me...

I can see ffmpeg in the extern on the server but it did not get checked out? Help...


Posted: Thu Sep 14, 2006 1:20 am
by Rush Kha Rater
Heya, I'm running edgy eft knot-2 here and I had a problem with installing your package (2.42a optimized for A64).

What I got is this:

Preparing to replace blender 2.42.a5ubuntu2 (using blender-2.42.a5ubuntu2.deb) ...
Unpacking replacement blender ...
dpkg: blender: dependency problems, but configuring anyway as you request:
blender depends on ffmpeg (= 3:0.cvs20060718-5ubuntu1); however:
Version of ffmpeg on system is 3:0.cvs20060823-0ubuntu1.
Setting up blender (2.42.a5ubuntu2) ...

And trying to install the older ffmpeg package dosen't work too well :P
Got any ideas or upcoming solutions for this?

Btw, why dont you provide your files as tar.gz that only needs to be unpacked and then run from the directory directly?

conflicts !!!

Posted: Thu Oct 05, 2006 6:45 pm
by mangojambojr
this optimized blender is a bad blender, becouse "conflit" with others packages!! lol

I'm using the dapper386 and blender-athlonXP ... everything is working well...

- I mean, when I render a movie with a lot frames in jpg or png, some frames are bugged, and I have to render that frames again!! (sux)

- I've tried install cvs-cinelerra (from it repository) and the ffmpeg, faad and others package are in conflits! So, I had to choice: stay with blender or cinelerra! (guess what?) ;)

But I want to install cinelerra...

wait for some help... thanks in advanced..

Cheers ...

Posted: Wed Oct 11, 2006 10:55 pm
by bmud
I've got an AMD64 processor and I've had no success installing a 32-bit version of Ubuntu. It seems that i'm only allowed to install the matching 64-bit OS.

That's not such a big deal. The program installer list even includes Blender but when I try running it nothing happens. I'm curious if the Blender that keeps getting installed when I try this method is even a 64-bit version.

This new build (which i heard plenty about via Blendernation) sounds promising, but I can't seem to get it to build. Keep in mind that Ubuntu is gearing itself towards linux noobs. I'm one of them.

I put the Blender blender-242x64.deb, ffmpeg-3:0.cvs20060718-5ubuntu1.deb, and a folder with lame-3.79.
I've read about APT to install an app that requires multiple debs... Well, I don't see anyone else here complaining about how ffmpeg requires lame. Is that normal?
Secondly, dpkg-scanpackages is an unknown command in my Terminal.

Can I get some hand-holding help on this issue? I just want to see Blender running propperly on a 64-bit linux, period. I'm really interested in seeing some boosted render times.

Posted: Sat Oct 14, 2006 8:37 pm
by rcas
Hi guys, sorry for the late answer but I don't get any mail notification when you guys post a new comment.

Anyway, this build is designed for Dapper Drake only, sorry.
On the 64 bits, sorry about it, but I don't have a 64 bit system to test it with.

Next version of Blender I will do something better, working on this, but the Conference and lots of other affairs are taking all my time away.

Things to expect on the next build:
- Dependencies corrected;
- Edgy-Eft compatibility;
- Cinelerra issues fixed, hopefully some issues with Jahshaka too;
- Installer or something that eases the install process, perhaps a command line script using dpkg;
- Availability of package as tar.gz too, with libraries also in tar.gz;
- Hosting at new website (coming soon);

I just need to have time to do all of this. I'm building my own automated build system, this way we can get weekly optimized CVS builds too.

My problem right now is that I don't have the time to even scratch my back, I'm sure you guys would love to have the Blender Professionals Portal online as well as the Blender Builds website with weekly optimized builds.

Adding to all of this, I'm an editor at Blendernation and I have to keep my status there too ;) .

Hope you guys can forgive me if I haven't posted more often and haven't updated the build yet, but I promisse good things are comming soon.

-- Rui --

Posted: Sun Oct 15, 2006 11:48 pm
by rcas
Hi guys,

I just did a CVS optimized build, its in tar.gz , if you have all the needed libraries installed go to and download the one for your specific platform, else you can get the specific libraries at too.

This is an extract and run build, nothing fancy.

-- Rui --

Posted: Fri Dec 22, 2006 2:39 am
by Ric95
thanks for all that work to make the 64 bit install easier, but It still doesn't run for me.. :oops: Heres the error;
blender-bin: error while loading shared libraries: cannot open shared object file: No such file or directory
Any idea how I can fix this?

Posted: Fri Dec 22, 2006 6:34 am
by jesterKing
Installing the proper python version would be a very good idea.