Blender v2.42a & YafRay v0.0.9 for Windows x64 *[Aug-11]

User-contributed CVS development builds. Please test and give feedback!

Moderators: jesterKing, stiv

Posts: 0
Joined: Mon Feb 06, 2006 12:19 pm

Post by adkiller »

etr9j wrote:Good news on both fronts:

After upgrading to the latest build, the texture issue went away.... at least so far it has.

I have also loaded the files on my own site. You can find the builds at
There is new build coming that fixes bugs in the node editor. To demonstrate the bug, try opening nodelib.blend in and you will see it crash.

This and few more minor fixes will be coming along in the next build. I am updating my toolset at the moment before a new rebuild.


Posts: 0
Joined: Thu Aug 24, 2006 7:38 am

Post by waran »

very nice Release - offers really somewhat better performance.

1 question:
Whats actually the advantage(s?) of "ActivePython" and this

Furthermore I think I found a (nasty) bug:
When you try to do a Circle- or Boxselect while "Limit selection
to visible" is active Blender crashes immediately.
Without this option it works fine (so does it in the official Build).

Posts: 0
Joined: Fri Mar 10, 2006 2:40 am

Post by etr9j »

Confirmed the box select and brush select crash when "Limit selection
to visible" is on.

Site Admin
Posts: 350
Joined: Wed Oct 16, 2002 12:13 am

Post by ton »

I would like to emphasize that Blender isn't ready for 64 bits usage yet. Please only use 64 bits versions for testing purposes and at own risk. Files saved with 64 bits versions now have the risk that these will crash Blender later on, something we won't be able to fix.

Whether or not the speedup is related to 64 bits or to use of optimize flags I don't know...

For more details about the work to be done to make Blender 64 bits ready, please check on the official developers mailing list. Info is on the 'get involved' section of
Of course everyone is invited to help with it. :)


Posts: 0
Joined: Thu Aug 24, 2006 7:38 am

Post by waran »

Ton, you are a party-pooper :D
I switched to the "normal" Windows Optimized Build;
runs fine here but not as fast as the SSE3/A64 Version,

I really would like to help but I dont want to learn planets
propably most unusable programming language*, sorry :roll:

*well, there's still ASM and Brainf*ck :P

Posts: 0
Joined: Thu Aug 31, 2006 4:17 pm

Post by mattias.nordenmark »

My blender crashes when I do rendering with YafRay...

The thing I try to render is one ball you can see through, and the letters S W E O in 3d shape. (The ball was taken from a example model that was supplied with older version of Blender that I found on the blender homepage)

The letters I created myself with a 2D image laying in the background and then using that as a blueprint for making it to 3D. The letter are subsmurfed with Catmull-clark at editor level 2, and rendering level 5. So it's alot of vertices and faces and stuff.

I've been using Blender for about 2 weeks now and I don't know very much but I try more and more along the way. Other rendering works, like with the internal renderer and YafRay renderer, and I've tried to render other models aswell and they work.

But I don't know if I have too many vertices and things cause with Catmull-clark level of 5 it get's alot.. but I would need atleast level 5 to get the smoothness I want.

Well anyways this is not maybe the right sub-forum for all that but im just trying to explain how I did this and why it crashes =)

I have emailed you lots of info adkiller, if you need anything more and the .blend file I would be happy to submit that too.

Posts: 0
Joined: Thu Mar 25, 2004 7:03 am

Post by LetterRip »

blender and yafray need to be compiled with the same compiler to be compatible.


Posts: 0
Joined: Thu Aug 31, 2006 4:17 pm

Post by mattias.nordenmark »

Ok I don't know much about this :)

I downloaded the versions found in this thread:
Adkiller wrote: Here are the links to download 'em:

For AMD64/EM64T processors with SSE3 support:
Blender v2.42a for Windows x64 *SSE3* (R5)
YafRay v0.0.9 for Windows x64 *SSE3* (R4)
Stackless Python 2.4.3 for Windows x64 *SSE3* (R3)

If you need a full installation of Python, it is strongly recommended that you use the following Python distribution with Blender x64 as they are fully compatible with each other.

Python 2.4.3 for Windows x64 by ActiveState:
ActivePython for Windows x64
I confirmed I have support for both SSE3 and SSE2, so I downloaded the SSE3 version of Bleder, YafRay, Stackless Python. And I think ActivePython is SSE3 too but atleast it said it was compatible with the x64 version of Blender.

But maybe they all are compiled differently?

I use this on Windows XP Professional x64 Edition, so I don't have a compiler or anything installed.

The strange thing, is that it saved a picture of the rendering in my rendered_pictures folder I created, but blender crashes without displaying this targa image...

Posts: 0
Joined: Thu Jun 01, 2006 3:31 pm

Post by m25 »

Don't know which of your versions I am using now (the first or the second) because I'm in the heat of a walkthrough to put togeather tomorrow 9AM but in 1 hour I got 3-4 crashes when I press <TAB> to enter edit mode and even yesterday I encountered this problem with a different file.

Posts: 0
Joined: Sat Nov 11, 2006 1:34 am

Post by ogi010 »

The links are down for Yafray v0.0.9 and Stackless Python 2.4.3 for SSE2.

Thanks for making those builds :)


Posts: 0
Joined: Sat Dec 02, 2006 11:33 am

Post by AtomicOne »

Link to...

Blender v2.42a for Windows x64 *SSE3* (R5)
is dead.

I downloaded and installed x64 SSE2
But i'm missing most of my AVI Codecs in x64 Build.
Only "Intel IYVU Codec", "Microsoft Video 1" and "uncompressed" is available.


Posts: 0
Joined: Tue Jan 09, 2007 10:55 am

Post by chrislu »

could you please correct the link to the SSE3 build?


Posts: 0
Joined: Tue Jan 09, 2007 10:55 am

Post by chrislu »


could someone fix the SSE3 build link?

Posts: 0
Joined: Fri Dec 02, 2005 5:56 am
Location: Underground

Post by Freak »

chrislu wrote:please!

could someone fix the SSE3 build link?
Yes is there anyone here who can provide a link to the SSE 64bit AMD, i don't care what version....

Anybody.... I have tried emailing the OP, with no luck...

Post Reply