bfblender + SculptPatch / OSX PPC (2006/10/31) updated

User-contributed CVS development builds. Please test and give feedback!

Moderators: jesterKing, stiv

psyborgue
Posts: 0
Joined: Thu Sep 28, 2006 8:18 am

compiling blender

Post by psyborgue » Thu Oct 12, 2006 8:41 am

Well i can understand that. If you come from a UNIX background, OSX feels right at home. If you come from windows it might be a little different. One day i'll probably write a tutorial on "how to build" on OSX.

psyborgue
Posts: 0
Joined: Thu Sep 28, 2006 8:18 am

build updated

Post by psyborgue » Tue Oct 17, 2006 11:23 pm

as of the 17th of October. more info at top

William
Posts: 0
Joined: Tue Jan 11, 2005 3:07 am

Post by William » Sun Oct 22, 2006 4:26 pm

I get the same message as some others:


2006-10-22 16:24:33 +0200

Link (dyld) error:

Library not loaded: /usr/local/lib/libIex.4.dylib
Referenced from: /Applications/blender october 06.app/Contents/MacOS/blender
Reason: image not found


Assuming it's OpenEXR I am mising then.
But how the do you get OpenEXR on the mac? I can't find it anywhere on the Blender site, it's not on openexr.org or anywhere. The closest I got was downloading two files called exrlib.carb.lib and exrlib.macho.lib. What are these where do I put them?

What am I missing? What am I doing wrong?

psyborgue
Posts: 0
Joined: Thu Sep 28, 2006 8:18 am

openexr

Post by psyborgue » Sun Oct 22, 2006 10:42 pm

my build does not have openexr statically linked into blender (i should probably see if this can be done).

You can get OpenEXR as a source tar.gz on the OpenExr website. You have to have apple's developer tools installed (included on your OSX disks)

Just download it to your desktop, open terminal and type the following

Code: Select all

cd Desktop [hit enter]
tar -xzf openexr-1.4.0a.tar.gz [hit enter]
cd openexr-1.4.0 [hit enter]
./configure && make && sudo make install [hit enter]
you will be asked for your admin password when it reaches "make install."

Until OpenEXR releases a nice nifty pre-compiled package, this is the only way to get the new version (1.4.0) on a mac. Don't ask me why they have a pre-compiled windows version and not a mac version.

If the compile fails for some reason or you are not comfortable with doing it, here is a zip file with all you need. Just built fresh 5 mins ago.

first you need to open /usr/local (from a finder window hold down shift+command(apple)+g) type in "/usr/local"

Everything should be placed in /usr/local (obviously, don't overwrite you're whole "bin" folder for example). Just drag the files from inside the bin folder in the zip file to your bin folder. the OpenEXR folder in "include" should be dropped onto your "include" folder. Etc...

TroutMaskReplica
Posts: 0
Joined: Thu Jun 02, 2005 4:13 am

Post by TroutMaskReplica » Wed Nov 01, 2006 7:34 am

is there any way this build could be made to launch properly after downloading it? if not then perhaps place a warning saying the build will not work without some acrobatics.

psyborgue
Posts: 0
Joined: Thu Sep 28, 2006 8:18 am

Post by psyborgue » Wed Nov 01, 2006 10:40 pm

TroutMaskReplica wrote:is there any way this build could be made to launch properly after downloading it? if not then perhaps place a warning saying the build will not work without some acrobatics.
well so far i have only gotten reports of one problem (related to OpenEXR: you must have it). If there are others, please tell me an i will fix them.

I'll post a build in the future without OpenEXR support as well.

EDIT: as of 10/31, a build without EXR support is inluded in the zip. It should just work.

TroutMaskReplica
Posts: 0
Joined: Thu Jun 02, 2005 4:13 am

Post by TroutMaskReplica » Sat Nov 11, 2006 3:46 am

many thanks. downloading now.

TroutMaskReplica
Posts: 0
Joined: Thu Jun 02, 2005 4:13 am

Post by TroutMaskReplica » Sat Nov 11, 2006 3:51 am

unfortunately, the NOEXR build does not launch either.

10.4.8 Intel Core Duo 2ghz 20" iMac

"dyld: Library not loaded: /usr/local/lib/libSDL-1.2.0.dylib"

edit: downloaded and installed libSDL-1.2.2 and installed according to the SDL readme but i get the same error.

please don't recompile on my behalf, i just thought this information might be useful to you in some way. i'll wait for an RC build to try again. i have an early sculpt build that works, from august i believe.

Post Reply