Page 1 of 1

Wrong Notification Links

Posted: Sat Feb 18, 2012 12:45 am
by ldo
I frequently seem to get e-mail notifications about new forum posts with URLs that point nowhere. For example, I just got a notification that pointed here http://www.blender.org/forum/viewtopic. ... 3247#93247 when it was really about here http://www.blender.org/forum/viewtopic.php?t=22388.

Posted: Sat Feb 18, 2012 12:55 am
by Tehrasha
My guess is that they are spammers that have been removed by the time you get to them.

Posted: Sat Feb 18, 2012 12:59 am
by Tehrasha
Or, a post, which is then deleted and replaced by a corrected version... (since we dont have edit anymore)

Posted: Sat Feb 18, 2012 2:13 am
by ldo
You might hvae a point ... except that the links sent out are to the topics, not individual messages. And the notification message even gives the topic subject, so I know which one it is.

Posted: Sat Feb 18, 2012 3:13 am
by Tehrasha
Yes, the notification you cited was for Message #93247 in topic #22388

There is no #93427 anywhere, but there is a #93428 from Makuto under that topic. If he posted 93247, then deleted it because he forgot to put CODE tags around his debug, his corrected post would have been 93428. (just a guess)

Posted: Sat Feb 18, 2012 6:16 am
by stiv
We have been deleting a lot of spam lately (Thanks Pakistan & China!) Without delving into the mysteries of data base keys, this is the most likely explanation for notifications that turn up empty.

Posted: Tue Mar 06, 2012 6:56 am
by ldo
I think there might be another bug associated with this: when it sends out the notification, it says you won’t get another one unless you log in and visit the thread.

However, if that notification was for a deleted message (which I can check without logging in), then presumably I won’t get another one, even if a subsequent legitimate message appears.