Page 1 of 1

Are there ways to eliminate artifacts from rendered images

Posted: Thu May 31, 2012 7:12 pm
by terryleemartin
I'm creating an animated logo. When it is rendered, about 45% of all of the Letter "T" have black artifacts in them. They resemble lightning bolts. The only way I have come up with to handle the problem is to bring the images into Photoshop and clean them up. The animations I am doing create 600 images and that means that I have to clean up over 350 of them. Very time consuming. Is there anything that can be done so that they don't occur in the first place? I would like to have this animation rendered as a MPEG movie file, but can't because of these artifacts. They only occur in the letter "T". They may happen in other letters as well, but if they do, I haven't used those letters yet. If they can't be eliminated, are there any suggestions how to make this clean up a little easier.

Posted: Thu May 31, 2012 7:17 pm
by Tehrasha

Posted: Fri Jun 01, 2012 4:18 am
by terryleemartin
Tehrasha wrote:This should help...

http://www.blender.org/forum/viewtopic.php?t=21211
I did read the information at that viewtopic, and I'm afraid I still don't exactly understand. I selected the three sections of text in my blender project and after selecting each of them I hit ALT-C. It opened the small window with the two options.
"Curve from Mesh/text ALT C" and the second one is "Mesh from curve/meta/surf/text ALT C".

I assume the one you are talking about is the 2nd choice there, but what do I do with it once it is displayed? I did select the Mesh one and then again tried to render my animation, but the artifacts on the T still occurred in my rendered images. Did I miss a step here?

Posted: Fri Jun 01, 2012 5:17 am
by Tehrasha
After you have converted the text into a mesh, then select all and 'remove doubles'. That should remove any duplicate polys that are causing the z-fighting that you see at render time.

Posted: Fri Jun 01, 2012 6:57 am
by terryleemartin
Tehrasha wrote:After you have converted the text into a mesh, then select all and 'remove doubles'. That should remove any duplicate polys that are causing the z-fighting that you see at render time.
I'm very sorry to be such a pain, but this software is certainly a bit different than any that I've used before.

To convert the text into a mesh, am I doing that correctly? I just hit ALT C and then make certain that the second option is highlighted? That's the one that says "Mesh from curve,meta/surf/text". To do the process of converting the text into a mesh, is there an enter button or something else I'm supposed to click, or will it just occur after I highlight that 2nd option?

Once I then click on "select all", where do I find "Remove doubles? Is that an option that shows up after I click on "Select all?" Thanks very much for all the help.

Posted: Fri Jun 01, 2012 3:07 pm
by terryleemartin
terryleemartin wrote:
Tehrasha wrote:After you have converted the text into a mesh, then select all and 'remove doubles'. That should remove any duplicate polys that are causing the z-fighting that you see at render time.
I'm very sorry to be such a pain, but this software is certainly a bit different than any that I've used before.

To convert the text into a mesh, am I doing that correctly? I just hit ALT C and then make certain that the second option is highlighted? That's the one that says "Mesh from curve,meta/surf/text". To do the process of converting the text into a mesh, is there an enter button or something else I'm supposed to click, or will it just occur after I highlight that 2nd option?

Once I then click on "select all", where do I find "Remove doubles? Is that an option that shows up after I click on "Select all?" Thanks very much for all the help.
This morning when I got up and checked the rendering process, it looks like the steps I described above did the trick. It is only 1/6th done rendering, but there are no artifacts on the T's. Thank you.

Posted: Fri Jun 01, 2012 3:23 pm
by terryleemartin
terryleemartin wrote:
terryleemartin wrote:
Tehrasha wrote:After you have converted the text into a mesh, then select all and 'remove doubles'. That should remove any duplicate polys that are causing the z-fighting that you see at render time.
I'm very sorry to be such a pain, but this software is certainly a bit different than any that I've used before.

To convert the text into a mesh, am I doing that correctly? I just hit ALT C and then make certain that the second option is highlighted? That's the one that says "Mesh from curve,meta/surf/text". To do the process of converting the text into a mesh, is there an enter button or something else I'm supposed to click, or will it just occur after I highlight that 2nd option?

Once I then click on "select all", where do I find "Remove doubles? Is that an option that shows up after I click on "Select all?" Thanks very much for all the help.
This morning when I got up and checked the rendering process, it looks like the steps I described above did the trick. It is only 1/6th done rendering, but there are no artifacts on the T's. Thank you.
Also, the text is much smoother now. There were color changes from one image file to the next which I assume was the reason for some of the flicker you mentioned to the other person asking for help. I still have another 20 some hours before I can see if all images turn out this well, but it sure looks promising. After 6 rendering processes over the past week and a half it looks like you solved my problem and I appreciate it very much.