Page 1 of 1

Installing on Ubuntu (Blender 2.41 64/AMD64/Dapper64)

Posted: Sun Apr 23, 2006 7:50 pm
by Ric95
I have been trying to install Blender on Ubuntu (Dapper, 64bit) using its automatic installer (Synaptic). It installs, but when I try to run it, I get the 'Unable to open window' error. Looking through several board I have found several people have the same problem, One suggensted it was an dependancy messup;
aptitude install blender
"blender: Depends: libglu1-mesa which is a virtual package. or
libglu1 which is a virtual package.
it should depend on libglu1-xorg"
Does anyone here know how to get this installed? I have even tried compileing from source, but it fails at that too. :(

very similar problem

Posted: Tue Jul 11, 2006 4:01 pm
by pixelpixie
hy,
I just wanted to ask if you solved the problem already.

I use ubuntu 6.06 where I can install blender 2.41 without problems - it works nearly; when entering play-mode it segfaults.

I had this problem on debian woody where a apt-get dist-upgrade solved it :-)
but this does not work here :-(

any ideas?

THX in advance

Posted: Fri Sep 01, 2006 3:06 pm
by geraldshastri
The same problem here, I installed blender from the synaptic tool but when i try to launch it it gives me a one line error message ERROR: Unable to open Blender window and fails to open. Does anyone know what exactly is wrong? Thanks.

Ubuntu 6.06 LTS?

Posted: Fri Sep 01, 2006 3:14 pm
by pixelpixie
hy,

I installed blender with the ubuntu add/remove tool - not with synaptic. But I think the result should be the same.
Try to use the ubuntu software update to be up to thate with your x-server stuff.
When I installed the last xfree update everything worked fine.
Pleas look at your xfree-config file and be sure that the "Load GLX" line is not commented out.

Posted: Fri Oct 13, 2006 6:15 pm
by CaveMole
Similar here. AMD64 blender.
It comes up, but the render is messed up.
bad text.
Gmome/Evolution desktop.

It dies with a zombie (defunct process) when I try to touch a control.

I wonder if there is some flavor of OpenGL libraries it expects,
and I have the other one installed.
glxgears and GoogleEarth work, so some OpenGL is OK.

Posted: Sun Oct 15, 2006 3:51 am
by yorik
I had the same "unable to open blender window" problem, until I read that ubuntu64 built-in drivers don't support well my radeon x200m chip. I installed the ati proprietary drivers, according to methods found on ubuntu forums, and blender opens normally now, but with same messed-up texts problem as in last post...
I keep searching.

SOLVED! (edited)

Posted: Sun Oct 15, 2006 4:29 am
by yorik
I managed to solve (partially) that problem selecting "international fonts" in blender user preferences... you must know where the item is, because you cannot see the texts :)
There are still some faults in the 3d views, but all the other windows display correctly.

edited:

Actually the texts display correctly only in the buttons window and the user preferences window. In the 3d views as well as in the file open dialogs, texts remains messy and unreadable.