Import images as planes not working

The forums here are for Blender development. Questions and discussion about *using* Blender belong on blenderartists.org If your thread was moved here, you are probably in the wrong place.

Moderators: jesterKing, stiv

Post Reply
Saras
Posts: 0
Joined: Fri Aug 24, 2012 2:25 am

Import images as planes not working

Post by Saras » Fri Feb 15, 2013 3:42 am

a few weeks ago I tried to import an image I had worked on in gimp to blender using the import images as planes add on, but it only showed the plane and no image. I watched a few tutorials to see if there was something I had to select to show the image and I started again and tried everything the tutorials said to no avail. Then just today I tried to see if turning off the add on and turning it back on would help but now it's even worse. Now when I select "import images as planes" it comes up with an error message and won't even make a plane without an image on it. Any idea what is wrong?

brasshat
Posts: 0
Joined: Mon Nov 16, 2009 1:06 pm

Post by brasshat » Fri Feb 15, 2013 6:39 am

I suspect based upon your recital of the earlier failure to get the image to display on the plane, that what you failed to do was to set the display method for the plane object to "textured".

It would be helpful to determine what is wrong now, if you included the text of the error message you receive.

If it was not one you watched before, a video tutorial on Youtube which discusses what you are trying to do is to be seen at <http://www.youtube.com/watch?v=IEKN40D64ag>, starting about 9 minutes into the video.

ns

adamjedgar
Posts: 0
Joined: Fri Apr 13, 2012 11:57 pm

Post by adamjedgar » Sat Feb 16, 2013 11:32 pm

I agree, if you havent set the image to display as texture in the "viewport shading" it will display as a coloured plane.

Note there are 2 places where you need to check this setting in 2.65...one is directly at bottom of screen immediately to the right of your "object mode" tab...and the other is on extreme rhs panel under "object>display" (object is the orange 3d cube near the top of the rhs panel).

either of these two may disable the texture...so both need to be set to "texture" in order for it to work properly.

One other thing, sometimes the image import seems invisible, it may need scaling...i usually have to scale it up 100% on my imports!

When it is imported, before you do or touch anything else, type "s" then "100" and hit the enter key! (the object is usually already slelected when it is imported so you dont need to hit any selection keys prior to performing scale operation)

id put in an image that shows it really simply, however, for those of us who dont have an url either the image function doesnt bloodywell work properly or is disabled!

Saras
Posts: 0
Joined: Fri Aug 24, 2012 2:25 am

Post by Saras » Mon Feb 25, 2013 9:30 pm

I tried what you suggested and no the image stays blank in texture mode. Thankfully the message isn't coming up any more (I think it might have just been that one time). Also I decided to try rendering it to see if the image would show up once rendered, and it worked. So I guess I'll just have to live without seeing it while editing.

tahseen
Posts: 0
Joined: Mon Nov 08, 2010 10:54 am

Post by tahseen » Fri Jun 28, 2013 10:08 am

Saras wrote:I tried what you suggested and no the image stays blank in texture mode. Thankfully the message isn't coming up any more (I think it might have just been that one time). Also I decided to try rendering it to see if the image would show up once rendered, and it worked. So I guess I'll just have to live without seeing it while editing.
Please make sure that the rendering engine you chose is Blender Internal

Only when Blender Internal is chosen as Renderer in the menu, the texture is visible in the viewport

Post Reply