make invisible plane for shadow only?

The forums here are for Blender development. Questions and discussion about *using* Blender belong on blenderartists.org If your thread was moved here, you are probably in the wrong place.

Moderators: jesterKing, stiv

Post Reply
zedeneye1
Posts: 0
Joined: Thu Feb 07, 2013 12:25 pm
Location: Canada

make invisible plane for shadow only?

Post by zedeneye1 » Fri Mar 01, 2013 5:27 am

I am camera tracking. Have setup a wonderful track. And added an object. Now how to cast shadow? I need a plane that is invisible otherwise but shows shadows. so how do I do it?

thanks.

zedeneye1
Posts: 0
Joined: Thu Feb 07, 2013 12:25 pm
Location: Canada

Post by zedeneye1 » Fri Mar 01, 2013 6:12 am

Also I need to know why the background image is not rendering ?

I have a movie set as background but it doesn't render. How do I do it?

mooncaine
Posts: 0
Joined: Sat Dec 05, 2009 9:01 pm

Post by mooncaine » Wed May 01, 2013 10:19 pm

Just saw your question about invisible shadow planes. I had the same Q, and found an answer here:

http://blenderunderground.com/forums/vi ... f=2&t=3821

I'm using version 2.66. The tip didn't work for me exactly as described. To render objects & shadows without the background, I must also change a setting in the Render Properties panel, in Shading: check the Ray Tracing box and choose "Transparent."

The render still has a faint dark tint across the entire 'empty' area, as if there were 1 huge, dim shadow cast on everything... but I'm close. When I get rid of that shadow/darkness, my objects will be rendering with shadows, but with no visible background.

I don't know why the background movie isn't rendering (I've never tried that), but if you can render the front layer(s) with your shadow-catching plane, maybe you can composite that render on top of the background movie that isn't rendering.

mooncaine
Posts: 0
Joined: Sat Dec 05, 2009 9:01 pm

Post by mooncaine » Wed May 01, 2013 10:42 pm

update:

I also had to go to the plane's Materials Properties panel, check the Transparency box, then set Alpha (in same panel) to about .50, and click "Raytrace."

The number .50 seems to affect how dark the shadows (and the supposedly invisible shadow plane) will appear in the final render. It needed to be greater than 0 but less than 1. Maybe it'll need tweaking.

My goal is to have a background that exactly matches the blue of a web page that will hold this embedded video.

Post Reply