Animation Problem: Can't Keyframe Object Rotation

The forums here are for Blender development. Questions and discussion about *using* Blender belong on blenderartists.org If your thread was moved here, you are probably in the wrong place.

Moderators: jesterKing, stiv

Post Reply
DapperDirewolf
Posts: 0
Joined: Mon May 13, 2013 11:32 am

Animation Problem: Can't Keyframe Object Rotation

Post by DapperDirewolf »

Greetings!

I'm having a strange problem I've never come across before in Blender (v2.67.0) where an object I'm attempting to animate rotating simply won't animate.

I keyframe the start Z rotation of the object at 0° and then keyframe to 360° a few dozen frames later, as with any animation keyframing, and yet despite seeing the curves in the node/graph editor and even the value in the transform menu changing, the actual object on the stage won't move at all.

What's strange is that I have two other objects parented in a chain to the main object (it's effectively a book), which are animated with rotation too, and yet they animate exactly as I want them to with no problems.

There are no locked axes on the problem object, and it rotates fine in the view, but it just seems that no matter what keyframes I position and use, the object simply stays wherever I change it's rotation to and doesn't animate whatsoever.

If anybody has any ideas or suggestions as to why I might be experiencing this strange phenomenon I've never seen before that'd be fantastic.

Thanks!
"I say we take off and nuke the site from orbit. It's the only way to be sure."

DapperDirewolf
Posts: 0
Joined: Mon May 13, 2013 11:32 am

Post by DapperDirewolf »

I'm just realising now based on some other posts that this may not be the correct place to ask my question, so forgive me for doing so. I'll ask again in BlenderArtists instead, which seems to be the correct place. I appreciate this thread may be deleted, which is fine.

Sorry!
"I say we take off and nuke the site from orbit. It's the only way to be sure."

Post Reply