Build with mingw-gcc fails when quicktime enabled

Compiling, libraries, modules, coding guidelines and porting

Moderators: jesterKing, stiv

Post Reply
damir
Posts: 0
Joined: Tue Feb 21, 2006 7:50 pm

Build with mingw-gcc fails when quicktime enabled

Post by damir »

While compilation with MSVC 8 goes without any problems, I have problems when I want to compile Blender with qucktime enabled using mingw-gcc because of errors:

Code: Select all

C:\build\lib\windows\QTDevWin\CIncludes/fp.h:89: error: conflicting types for 'float_t'
c:\mingw\bin\../lib/gcc/mingw32/4.3.2/../../../../include/math.h:317: error: previous declaration of 'float_t' was here

C:\build\lib\windows\QTDevWin\CIncludes/fp.h:90: error: conflicting types for 'double_t'
c:\mingw\bin\../lib/gcc/mingw32/4.3.2/../../../../include/math.h:318: error: previous declaration of 'double_t' was here
and

Code: Select all

C:\build\lib\windows\QTDevWin\CIncludes/CFXMLNode.h:31: error: redefinition of typedef 'CFTreeRef'
C:\build\lib\windows\QTDevWin\CIncludes/CFTree.h:31: error: previous declaration of 'CFTreeRef' was here
Anyone knows how to correct these errors?

jesterKing
Site Admin
Posts: 207
Joined: Fri Oct 18, 2002 12:48 pm
Location: Finland

Post by jesterKing »

You can't have it enabled as there's no mingw support for the quicktime libraries.

/Nathan

damir
Posts: 0
Joined: Tue Feb 21, 2006 7:50 pm

Post by damir »

Thanks for quick response, last few days I was driving my self mad by looking for solution of this problem :)

Post Reply